[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

Heh. My shotgunned messages this morning would say otherwise. I just turned my phone over and ignored it. The person in my office just kept looking at me like “are you going to answer that?”.

Me: don’t worry, it’s just my smoke detectors in the house…

In all seriousness, when the app can’t talk to the NST cloud, it starts griping. 3-5 messages at a time 5-15 minutes apart. Unfortunately because I have both apps on my phone I get two notices for each instance. (yes, my problem not yours) it would be really nice to be able to throttle it.

The only reason I mention it is due to the instability in the NST platform the last week or so it’s been quite annoying. And brought up on the Facebook SmartThings group this AM. Many are asking to be able to temporarily silence these because we all know they’re bogus and eventually go away. I told OP on the Facebook post that the quickest way to get your attention if it was possible is to post a feature request to your Github for it. :slight_smile:

I went back and looked at my notifications for this am. What it appears is happening is multiple TYPES of alerts. You are correct that they are each throttled to 15 minutes, but that’s 15 minutes for a single type of alert. If yiu then have multiple alerts, it’s not global and will allow the new alert through even if it was less than 15 minutes.

When the Nest cloud goes down, we start seeing these multiple types connectivity alert scenarios. See below:

Net end user perception: alert spam even though the program is behaving as designed.

You can turn these notifications off

NST Manager -> Notifications ->

be sure to done/save you way out.

1 Like

I did for now. But off isn’t the intended case. Heavily throttled is. I’d still like to know if there’s issues to check out. Just not 47 times before I had my second cup of coffee. :slight_smile:

The REAL fix is for Nest to figure out whatever instability they have and eliminate it

Why is SmartThings specifically calling Nest APIs? There’s no official integration, right? :stuck_out_tongue:

Oh, and called it! I don’t know what the heck is going on with Nest lately as they seem to have gone DRASTICALLY down hill which, if they were just some small startup, I could see happening but when you’re owned by Google and have access to Google’s cloud…

1 Like

Is there any update to the random disconnects and having to press the play button to get the connection back?

Is there a way to program this button press using webcore?

I tried using webcore to both ‘Refresh’ & ‘Poll’ on regular intervals, but this didn’t help.

I’ve started using the Node-Red integration to set Home/Away instead of NST manager, seems stable with fewer requests on that API key, but I’d like to solve this problem as all my actiontiles are just stuck.

My messages had stopped over the weekend but it appears they’ve reappeared as of this morning :confused:

I have a feeling, what with all the recent combo Google Home and Nest sales happening over the past couple of weeks, along with the leaks, Nest is evolving and they’re gearing up for something at Google I/O in a months time.

i have the NST manager since a while now and am really enjoying it. Thanks for a fantastic app! i am not a total newbe anymore in ST but its probably something i messed up lol. Some help would be appreciated. If i look at the “things” in my home in the iphone app and open any of my 3 nests i used to see a fancy graph. now all i get there is an error
{“error”,“type”:“groovy.lang.MissingMethodException”,“message”:“An unexpected error occured.”}
it says there Firmware v5.9.3-3 and device type v5.3.5 (New: v5.4.5) which is confusing because i tried now several times to update and struggled a bit with that it seems. i tried to update via Github repo and community installer. i even tried to uninstall the app via iphone classic app and via IDE>home>edit but on the iphone app i get an unexpected error and in the IDE it doesnt remove it when i try to do that. very strange. i hope you guys can point me in the right direction.

Should I contact Smartthings support and have them remove it and start fresh? Trying to avoid that until someone confirms. I made some screen shots and saved the log. I hope that helps.
The full log is here
NST Diagnostics - Logs

What happened when you tried updating by repo? Both device handlers and Smartapps.

Oh yeah sorry I didn’t mention those details. I have that missing graph and error since a while and I hoped updating fixes it. Strangely enough I got a success message when updating via Repo. The error is still there and to me it looks like the DTH version is still outdated. So I went to the community installer and tried that. Same thing, got a success message and saved my way out of the app. Same thing error is still up and DTH looks to be a few versions behind to me. This is when I attempted to uninstall/delete. I tried first via NST manager SmartApp on the classic ST app IOS but got an error. I then tried via IDE but the wheel spins just for a sec and nothing happens. So I attempted to delete each app and DTH manually but that errors with item is in use.

Try deselecting all your nest devices in Manage/View Devices in NST Manager. Wait a few minutes, then login to IDE using an incognito/private tab in your browser. Remove all the device handlers, then remove your smart apps. Then install from repo.

1 Like

Thanks I’ll try that.

I’m sure this has been asked a million times, but are there any hopes of getting the Nest X Yale lock into ST?
I love these locks but the lack of integration with basically anything is maddening.

Is there a way to force the heater on ignoring the set temperature? I am exploring the possibility to use mechanized and controllable vents to create micro zones in my house. Temperature sensors would cause the vents to close and open and if any of the sensors reports temperature below the set point I would like the heater to turn on. Any thoughts on how I could do this?

When Nest adds support to the Works With Nest API i will absolutely add support

1 Like

That’s amazing news. Is this a question of WHEN or is it possible they won’t add support to the API at all? That lock drives me nuts. It’s the only thing I can’t get in ST in my house.

BTW, incredible job on NST Manager! Game changer man!

1 Like

They’ve been revamping their developer stuff, I have a feeling we might see some change in Nest and Google next month at Google I/O…