[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

I’m not even sure how this would ever happen. The nest itself has safeties in place. Unless the skew between the remote sensor temp and thermostat temp was more than 15 degrees

Out of curiosity, what does your Nest wiring diagram look like? Goto Settings and spin all the way to the far right until you see Equipment and Press:

It is really that skewed. I actually have 3 sensors in that room (one dumb, one multi with a battery, and one plug in night light) and they all read 100. The Nest is right on the other side of the wall, but the door was closed. The hallway was 75 with a heat set-point of 76. I went through the events as best I could and I think it went something like this…

Remote sensor reports it is 68 and the target temp was 69.
Hallway temp (actual Nest) was 66.
vTstat turned Tstat to 76 to make the heat come on.
ST goes down
Heat stays on trying to get the hallway with no ventilation to up to 76 from 66
ST comes up at some point
Heat continues to run and safety temps are exceeded in the remote zone (but not hallway so the Nest never reacts)
Wife throws dumb remote sensor at me at 5 am
I look in the app with utter dismay and confusion wondering how the vTstat can say it is 100 degrees, have a heat set point of 69 and and cool set point of 74, and still be pumping out heat
Look through logs and notice about 2 hours of nothing reporting
See email and post at 7 am about outtages - explaining the original issue, but not why the heat was still on after everything appeared to be working.

This was definitely not a NM issue, I was just confused as to why it didn’t get back on the right page after things were up and running again - although - I was still getting “Your Hub at Home is now active” messages a couple hours ago so maybe it wasn’t really “up and running.” Seems like it should have reevaluated at some point… BUT, I guess NM perhaps thought when it came back on line that it was in override mode and would have corrected at the next schedule or 4 hours…

@WB70 - I could still control the Nest itself for sure. The issue was we were all sleeping when it happened. The heat ran for several hours because there are no actual vents into the hall area and with all of the doors closed the rooms that have heat get significantly warmer than the hallway.

I now have a CoRe failsafe that will turn the Tstat off if the plugged in remote sensor gets above 76. Obviously that wouldn’t do a thing if ST is down, but hopefully it would have kicked in still at some point before the wife did. Will NM turn the Tstat back on according the next schedule/ event if it is off?

I think that coupled with making the adjust temp setting only 4 degrees I should be better off. If it had been 4 degrees then the hallway would have only been set at 70 instead of 76. It probably still would have gotten up to 80 in the remote room though.

((my wife did not literally throw anything at me. ILMW))

I can check when I get home, but I believe it is exactly like that. I just had to look at it two days because my downstairs unit was overloading and shutting down which resulted in the Nest itself to lose battery power…

I have no doubt something screwy is going on here, but I will point this out.

So I only use NST Manager and the Automations piece using Modes to set my Nest environment Home/Away based on ST Mode. I have no TStat schedules set, no remote sensors tied in that would cause any havoc between ST / NST Manager and Nest.

With that being said, I realized the issue that ST was having last night just before midnight because one of my Pistons failed to put my system into Armed (Home) and Night Mode. However, earlier in the evening (not sure about time), I realized that it was extra warm in the house and walked by my Nest Thermostat which is set to Auto - 72 heat and 78 cool, and it was still heating at 75° F.

Call it a coincidence in timing that ST was having issues, but is there anyway @tonesto7 that anything from the Nest side (Cloud) could have affected people locally or are the Nest settings completely local to our thermostats and impossible for Nest to create an issue like this from their end? My Thermostat has never malfunctioned this way before. All I did to correct it, was by setting the Heat Setpoint down to 70° directly on the Nest and the Heat immediately shut off.

Hi All,

Very new to this and slightly confused…got through and have my NST Manager showing up in my SmartThings app, but none of my devices are, and I have the following two errors:

Warn: Nest Manager Update(s) are Available:
Invalid or Missing Automation File, please reinstall the correct automation file Automation App v5.2.2

Please visit the IDE to update code

-AND-

Error: Device Handlers are Missing or Not Published. Please verify all device handlers are present before continuing.

ANY and ALL help would be greatly appreciated lol…My wife is due any day so want to make sure I get the house all set before our hospital stay lol.

Thanks in advance.

  1. Is this your first time installing?

  2. When you logged into your IDE, did you login to https://account.smartthings.com?

  3. Did you manually copy/ paste all the code into IDE?

  4. Or did you add the code via Update from Repo?

  5. Did you create/publish the code for both NST Manager and NST Automations?

  6. Did you create/publish code for ALL Device Handlers (even if you don’t have those devices)?

Send screenshots from IDE of the SmartApps page and the Device Handlers Page.

Also upload screenshot from IDE of Locations / Installed SmartApps showing Nest or NST Manager down under Other.

Answer those questions and we will continue.

[quote=“WB70, post:2101, topic:83228”]
Is this your first time installing?
-Yes
When you logged into your IDE, did you login to https://account.smartthings.com?
-Yes

Did you manually copy/ paste all the code into IDE?
No
Or did you add the code via Update from Repo?
Yes
Did you create/publish the code for both NST Manager and NST Automations?
Yes
Did you create/publish code for ALL Device Handlers (even if you don’t have those devices)?
[/quote] Yes

Screenshot_20180104-154417

Let me answer things in a couple of different replies.

Your Device Handlers are all in Edited mode. I will give you steps in a minute. That’s the first thing.

So the second screenshot is from Marketplace.

The screenshot I want is from IDE (the web). Goto Locations / Installed SmartApps / scroll down to Other and give me a screenshot of the Nest stuff.

06 PM

Ok so first, I’m guessing that you added both NST Manager and NST Automations from the Marketplace. Am I correct? If so, you are NOT to add NST Automations from Marketplace.

In the Mobile app goto Automations / SmartApps and take a screenshot (Not my apps - that’s the marketplace where you perform an initial install only).

I may have added them both…quick update, my devices show under my things but when I click I can’t connect…here’s that ss

Ok, so ST is having major issues that started at around midnight last night. Major issues that are still currently being worked on, so as far as devices not working, leave them alone for now. The fact that they added to Things is good.

Here are a couple of things we need to fix though.

  1. You need to go back to Locations / Installed SmartApps / click Edit (upper right corner). Scroll down to other and where you see NST Automations above NST Manager, you need to uninstall each one of those. Make sure they disappear.

Then reply.

so, the 3 automations and watchdog? or just the 3?

Im sorry it was 2…heres what I have now…

No don’t touch NST Manager or the sub entry Watchdog. Those two items are correct.

The Nest Manager underneath is not supposed to be there.

I’m going to guess you tried to install NST Manager 2x.

So do me a favor and try and uninstall just that Nest Manager one underneath Watchdog.

Got it…done.