[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

Anthony and Eric,
Should we also update the Rest implementation to get the triggers to be closer to real time?

Thank you! Works great.

1 Like

Thank you. I just got set up and in under the wire.

1 Like

I’m not seeing an update available when I try to Update from Repo. My version in the app is showing v5.4.6. Is there some other way to push the update? My Tstat has stopped checking in as of about 1800 UTC yesterday.

Checked back in because I’ve received a few update notifications and wanted to see what the changes are and whoa… lotta action on this thread recently. :wink:

Understand that Works with Nest is going away and will screw everything up, but do we need to do anything now? Seems to be working fine still on the latest version (5.6.4).

How does one get the tokens. I can’t update a repo I must do it manually

I’m having an issue with NST not adjusting my temperature when my ST mode changes. It worked using the same webCore code for heating controls during winter and spring and webCore forum folks confirmed my code is correct. I’ve updated the app thru Community Installer recently. Curiously, when I’m looking at my thermostat in ST it says there is an update available and it also says API status has issue. I checked ST IDE an there are no updates available there either. Here is a screenshot of my Downstairs thermostat. Please help!!

did you check for updates in both My SmartApps and My Device Handlers in IDE and all are published? Also, opent the NST Manager and click Save.

No such luck. The NST was saved. There was nothing to update in device handlers or smart apps. However two instances on the app exist when i click update from repo: ‘nest-manager (beta)’ and ‘nest-manager (master)’. …but when I look at my smart apps i see only one version of the app and a separate automations app.


I’m having to reset my token everyday to get my nest manager to communicate. It just seems to stop even though it say api is good etc. Has anyone got any advice. Has worked fine for ages but last few months been a pain.

Thank you

FYI, in case anyone is wondering… Nest is having issues at the moment :slight_smile:


Would that explain why I am constantly (every 5 minutes or so) getting messages like the following:

  • NST Manager Data update IssueS: The app has not refreshed data in the last (108501) seconds. Please try refreshing data using device re (***and the rest cuts off)
  • NST Manage API CMD Failed: the (nestCmdResponse 0 (structures{away:home})) CMD sent to the aPI has failed. Status Code: null ErrorMsg: Rec (***and I don’t know if there is any text beyond this).

These messages popped up today around 3pm Eastern time and they won’t stop. If the Nest issues are not the cause of this, what is? I have changed nothing since the initial setup. I do keep up with the latest updates (running version 5.6.4 now).


1 Like

Yes it would

Thank you for the quick response! Using your Nest status link, it looks like they show all systems as OK now. Perhaps they are not that accurate or whatever changes they made need to trickle through the network?

Also, is there a way to disable these notifications? Or at least send me every 5th one? It’s like every 5 minutes since 3pm.

In NST Manager, go to the Notifications section where you can disable alerts for the api

I don’t know how I never saw that before. That is exactly what I needed. Thanks for the assist!

The Nest platform is back but I am still offline in ST’s and continue to receive notifications.

Same with me.

It’s not just Nest, it’s the entire Google Home platform is having stability issues. It’s likely Google trying to migrate Nest stuff over/make changes to the Google Assistant API to accommodate Nest stuff.

Yea, I saw that on downdetector.com. My Nest thermostats have reconnected to ST’s now. Not sure if it is related but I did reboot them.