[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

Thanks for passing this letter from Michele Turner on. Pushing this through under the guise of privacy really angers me and as a result I’m going to be ditching my Nest hardware (thermostat, 3 cams) & camera subscription.

I’m going to move to another manufacturer that gives me the choice of what I can do with my hardware.

Using Home/Away Status via the API should be my choice. It’s my home. I make my privacy decisions, not Google.

I was just going to go buy a 4th cam, guess I’ll be spending that money with somebody else.

2 Likes

Watching closely for an update on this. I just found out about this smartapp and I would really like to use it even if its only for a few months

I don’t have a problem if the manufacturer tells me how to use their hardware. It is my choice to buy the hardware that best suits my needs.

HOWEVER, I do have a big problem with those who decide to change the rules of the game long after the game started. If apps like NST Manager weren’t possible or that so many other official “Works with Nest” integrations didn’t exist, I would’ve never bought into the Nest Universe. Therefore, I cannot wait for the new Ecobee 4+ to come out :slight_smile: @tonesto7 & @E_Sch is the EcoB Manager ready yet? :slight_smile:

I agree. That’s exactly what I’m getting at. We’re just dealing with semantics.

I bought their hardware, based on features that were present at the time. Now they are stripping those features back, making their hardware that I purchased no longer suit my needs and presenting the change as protection of my privacy.

They don’t need to make that choice for me, but since they are compelled to do so, my alternative is to dump them and support someone else.

1 Like

I assume I am going to just have to install fresh since it’s in My SmartApps but it’s not showing as an app because I couldn’t setup integration without a dev account? I am a newbie to installing apps in the IDE so I am not sure how to update them.

You may want to check out the Community SmartApp installer. You will still need to install the custom code for this app but once you do - installing and updating other apps is much simpler.

You can also refer to the wiki page for installation and updating NST Manager.
http://thingsthataresmart.wiki/index.php?title=NST_Manager

1 Like

That’s actually how I got it installed in the first place! I guess I do remember seeing where occasionally things will say Update, so I’ll keep an eye out there.

1 Like

I really appreciate the work that Tonesto7 and E_Sch put into the NST Manager. Thank you.

4 Likes

I just pushed up version 5.6.4 with the tokens embedded

3 Likes

thank you!!!

Anthony and Eric,
Should we also update the Rest implementation to get the triggers to be closer to real time?

Thank you! Works great.

1 Like

Thank you. I just got set up and in under the wire.

1 Like

I’m not seeing an update available when I try to Update from Repo. My version in the app is showing v5.4.6. Is there some other way to push the update? My Tstat has stopped checking in as of about 1800 UTC yesterday.

Checked back in because I’ve received a few update notifications and wanted to see what the changes are and whoa… lotta action on this thread recently. :wink:

Understand that Works with Nest is going away and will screw everything up, but do we need to do anything now? Seems to be working fine still on the latest version (5.6.4).

How does one get the tokens. I can’t update a repo I must do it manually

I’m having an issue with NST not adjusting my temperature when my ST mode changes. It worked using the same webCore code for heating controls during winter and spring and webCore forum folks confirmed my code is correct. I’ve updated the app thru Community Installer recently. Curiously, when I’m looking at my thermostat in ST it says there is an update available and it also says API status has issue. I checked ST IDE an there are no updates available there either. Here is a screenshot of my Downstairs thermostat. Please help!!

did you check for updates in both My SmartApps and My Device Handlers in IDE and all are published? Also, opent the NST Manager and click Save.

No such luck. The NST was saved. There was nothing to update in device handlers or smart apps. However two instances on the app exist when i click update from repo: ‘nest-manager (beta)’ and ‘nest-manager (master)’. …but when I look at my smart apps i see only one version of the app and a separate automations app.

Hi.

I’m having to reset my token everyday to get my nest manager to communicate. It just seems to stop even though it say api is good etc. Has anyone got any advice. Has worked fine for ages but last few months been a pain.

Thank you