[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

My Nest goes to away but my AC continues to run. Sometimes it stays on and sometimes it goes to Eco mode.

Had more offline message overnight. They self correct next connection attempt. Happened on some of my thermostats and Protect. I believe this started happening after the last update.

I had this happen yesterday. The data I saw came from Nest. I expect they are doing updates in their cloud

PREVIOUS NOTICE: We had to make some changes to how the clientId and clientSecrets are distributed. They are no longer in the code or appData file. So this means that if you with want to clear your existing auth token and recreate you will need to be running v5.0.5+.

FYI: This change will have no effect on existing installs

Updated: Manager: v5.0.8

Manager App:
• UPDATED: Detects and notifies on installation issues
• FIXED: Small bugs and optimization; Quieting of logs

Automation App: v5.0.4
• FIXED: Quieting of logs; small bugs and optimizations

Updated: Weather v5.0.4
Updated: Thermostat v5.0.2
Updated: Protect v5.0.2
Updated: Camera v5.0.4

UPDATED: Quieting of Logs

http://thingsthataresmart.wiki/index.php?title=NST_Manager

Over the last few releases, I’ve been unable to rename my devices again (Protect, Thermostat and Weather). Whenever I rename “Nest Weather - 00000” to “Outside Weather”, it renames back to “Nest Weather - 00000” on the next update of the device. Just reporting the bug…

Thanks

You can rename devices in several locations:

  • in the dth
  • in NST Manager

If you do this in the dth, you should turn off the NST manager updates: (or you can make the change in NST Manager)

NST Manager -> Application Preferences -> Device Customization -> Device Names

This is to allow you to update names in one place. If you want to do naming in DTH (or IDE), turn off
NST Manager updates Device Names

1 Like

I am thinking about trying to install this and it will be my first time installing something like this on smartthings. So far I have just added things that are automatically detected.

Is this an install and forget? As in, if I install this one do I have to keep installing updates or will it just update for me or are updates not necessary?

community provided devices have to be updated - (they don’t auto-update)

If you use github, it is pretty easy (but not as easy as the marketplace…)

See the docs:
http://thingsthataresmart.wiki/index.php?title=NST_Manager

Thanks. I have to start at the beginning as this is all new. Will it notify me they an upset is available/required or does it just stop working?

You aren’t the only one on this. I’ve been having the same issues. Not sure where the issue lies at the moment. What happens when you use the Nest app? Does the same thing happen? I have two zones and I’ve seen one zone go into Eco and the other not. Or both refuse to go into Eco unless you cycle the home/away in the Nest app.

Nest Manager will let you know there are updates, or when you go in the IDE.

An installed version should not stop working. It could happen as Nest changes APIs, but not likely.

1 Like

The Nest App shows Away but the AC continues to run (as if I am home, i.e cooling at 76). It sometimes goes into eco mode when cycling between home and away on the Nest App but not always. I had two locations for Nest and SmartThing’s. One has 6 zones and the other has one, I have seen similar behavior for both locations.

Update: I have a similar experience with the Nest Cam, I continue to receive notifications while I am at home when I have it to only send them in away mode.

1 Like

Nest has a feature called home/away assist, which is suppose to move your house into eco mode when you are away.

You have to enable this in your Nest Mobile or in the Nest Web site.

Some folks have experienced issues with home/away assist coming out of eco mode, even though you are still away.

This has been reported a bit in the nest developer community site.

You can enable the NestMode automation in NST Manager to monitor the eco state while you are away, or to have it set the Nest to Eco when ST has you as away.

You should check if you have home/away assist enabled or not, and I suggest at least enabling Nest Mode to monitor / notify you on coming out of eco while Nest is “away”

1 Like

Thanks, I was renaming the device directly. After changing in NST Manager, the rename took.

Thanks again

1 Like

Can someone please remind me how to add a second device to the hub?

I had to remove one device and now I can not add the device back to my hub. It isn’t identifying it.

I’m having an issue where my thermostats aren’t responding. The settings in NST don’t match the Nest app and aren’t adjustable through Smartthings and NST Manager. Please see screen shots below. I thought update to 5.0.8 would fix the issue but it hasn’t.

Downstairs Tstat (Actual):

Downstairs Tstat (NST):

Upstairs Tstat (Actual):

Upstairs Tstat (NST):

Please Help! My automations aren’t working because of this issue.

This isn’t a code issue. It’s a side effect of using ST. Open the manager app and press done while you have ide logs open. Look for errors

OK i just tried that. Things are adjustable but it’s still not in sync with Nest.

Edit: strangely it says my device type is 4.5.1 and that a device update is available however all updates have been posted and i’m running 5.0.8.

And whatever this means:

First time writing here, and first things first: thank you for this great SmartApp and for your work in our benefit.

Everything’s working for me, but today I modified my thermostat automation config. I mistakenly modified the Cool Set Point of one of my schedules, and set it to 27,5 C (see the comma instead of the decimal point) I don’t remember the exact secuence that I used, but the system saved that value in my Cool Set Point, I think it said there was some error, but I don’t remember.

From that point, I was unable to modify the Thermostat Automation Config. The app did nothing (apparently) when I tap to modify. After live logging my system, I got this error message:

error groovy.lang.MissingMethodException: No signature of method: scriptxxxxxxxxxxx(big number).roundTemp() is applicable for argument types: (java.lang.String) values: [27,5]
Possible solutions: roundTemp(java.lang.Double) @ line 5680

I was able to solve the problem forcing ctemp:to 27 in line 5694 of the NST Automations code, inside the “newScd = cleanUpMap([” call in line 5680, as the error stated. Once done, I went back to the app, modified the Cool Set Point in the schedule, saved, and restore code to it’s original state.

Luckily it worked, but I think it’s something you should know in order to try to solve the problem for other users.

Again, thank you guys for all this wonderful work!

Did you publish the device handlers when you updated?