Bosch Motion Detector

Hello, first time posting and I’m mostly a newb to smartthings, but have gotten a few door sensors setup as well as my Honeywell thermostat so I’m starting to get a feel for things but still have a lot to learn.

Question for the board: Has anyone had success setting up a Bosch Motion Detector in SmartThings? Specifically I have model ISW-ZDL1-WP11G, which is supposedly wireless as well as ZIGBEE compatible. I got the detector from a previous install so I have no documentation on it (other than a zigbee id), and have not had success searching online. I’ve been unable to pair it trying both manual entry on the smartthings portal as well as searching via my android app. Any thoughts would be appreciated, thanks!

2 Likes

I’ve got a similar model. Did you unpair the sensor before you tried to pair it to ST?

As far as I see there’s only one button/switch at the top of the thing. It makes an LED flash and I’ve messed with it ad nauseum, but still haven’t figured out if that means it is trying to pair as a zigbee device, or trying to connect over wifi/WPS, or what. Is yours like that?

Andy

that blue(center white) switch looks like sensitivity adjuster
if you deleted device from previous install, then remove and install batteries it should go in paring mode and will be detected (at-least mine got detected as a “Thing” but still does not work my model is “ISW-ZPR1-WP13”)

once paired LED should only lit up when motion detected
still looking which Device type to select , will be posing another question

On mine there is a small tamper switch. To force it to start pairing you take out all the batteries, hold down on the tamper switch, put all the batteries back in, wait less than four seconds, release the tamper switch. Put the back of the sensor back on, lock it, and it should show up as a Bosch Motion Sensor when you search for a new thing.

Christofer

ST hub does not detect my Bosch motion sensor "ISW-ZPR1-WP13"
I wrote to support and they say it is not supported, can you please tell me what device type i should chose
Thanks

I’d go and look at https://github.com/smcasagrande/SteveC_SmartThings - perhaps fork that tree, and import the motion sensor DTH. Or I can provide the specific DTH to you.

Let me know if it works.

1 Like

@abostian - We may need to modify that DTH to work with yours as well.

Thanks for your replies. I did get the motion sensor to pair as a thing by doing what you said and taking out the batteries while holding the switch. I’m a little lost trying to find the device handler on your github page. Sorry to ask, but can you help point me to what I should be looking for?

Making some progress - I found motion-detector.groovy from your repository and copied the code over to a new device handler and set that as the device type for my Bosch motion detector. On the PC it shows no events though, and on my phone app it shows the status as ‘MOTION’ always. Any ideas?

The code may need to be tweaked for your specific motion detector. Can you go into the IDE, bring up the device, make a screenshot and post it?

I have the same model and have done a factory reset. Was able to detect and pair as a thing. Tried changing to various different motion sensor types but am not getting any events. I guess i am at same juncture as as ANDY and would be interested in seeing how to make it work.

Below is what device looks like when added with a modified STMotion sensor handler
i also tried the the one listed here on Git hub at below link , same result
any ideas?

SteveC_SmartThings/devicetypes/smcasagrande/bosch-motion-sensor.src/bosch-motion-sensor.groovy

Please send a screenshot from the IDE for what the thing shows up like @SmartBK.

@sandyis - Please Unpair the device, and use the Bosch that was in that fork. It should just work. I’m attaching my screenshot below, and we have the exact same motion detector.

@abostian - I need you to pair it as a thing, and post a screenshot.

@madducks Is this what you are looking for? I re-paired it and set it to the Bosch Motion Detector type from your repository. Not getting any events yet though, not sure what I would need to change.

@MadDucks
yes its working :slight_smile::beers:

Thanks

@MadDucks
You nailed it. For me i was not using the correct device type. Did that from the link given by SANDY and it still didn’t work. Then deleted and paired it again as you suggested. It is working great now.

Thanks. Now off to next device… :slight_smile:

@SmartBK and @sandyis Do you mind ifI ask where you got the devices?

I have one of them in my garage and in basement. It’s cool to have lights just turn on.

@SmartBK, You have the ISW-ZDL1-WP11G and got it to work with the bosch-motion-sensor.groovy DH without any edits to the code? Anything else you did besides deleting and repairing?