Bizarre Issue with a GE Dimmer Today (or maybe not)

I had a very strange issue happen today. I have a ceiling fan/light combo in my master bedroom that has independent switches for the light and fan (as do all my fans in the house). I’ve had a GE dimmer and Fan Control on this fixture for a month or two - no issues. I went to manually turn on the light today via the dimmer switch and even though the LED went out, the light did not come on. First thing that sprang to mind is, okay, I’ve got my first GE dimmer failure. So I started troubleshooting to be sure.

The switch showed online in the IDE.

The switch responded in the iOS app.

I noticed that with repeated manual operation the switch would sometimes turn on and off on demand but not always (I went by the LED as all the while the fixture never turned on).

The fan worked without issue.

I tested the load wire and it showed voltage when the switch indicated it was on and vice versa.

The obvious at this point was a fault with the fixture itself but before I went there I tried another, brand new out-the-box GE dimmer. I got the exact same results.

I put the old GE dimmer back in then ‘toggled’ the light in the fan by the chain. Voila, everything started working again.

I know, did someone pull the chain on me? No, the chain is two inches long and needs a ladder to reach it. Not a single fan/light in the house is ever operated by the chain as they are unreachable without ladders.

The ceiling fan is a decent quality Hunter and has never once had a problem.

So weird.


I’ve had this fan installed for probably 15+ years. I guess developing a fault now is quite possible.

Very suspicious it happened a month or two after putting a new dimmer in. I wonder if the GE pushed a surge somehow. Prior to the GE I had a Lutron slider dimmer.