[Beta] Zigbee Edge Driver compatible with Lidl, Ecosmart, Osram, SmartThings & Others

@uncledaveghr,

Added to this driver version as RGBW.
I have seen on the internet that it is RGBW

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Light Multifunction Mc        │
│ Version     │ 2022-02-01T22:50:02.155871           │
└─────────────┴──────────────────────────────────────┘
  - id: "GLEDOPTO/GL-C-007"
    deviceLabel: GLEDOPTO GL-C-007
    manufacturer: GLEDOPTO
    model: GL-C-007
    deviceProfileName: rgbw-level-colortemp-2700-6500

Hey Mariano… greetings!

Could you please include this FPs in Zigbee Contact Mc?
It´s a ZEMISMART Contact Door Sensor

image

Data

  • application: 44
  • endpointId: 01
  • manufacturer: _TZ3000_o5wjxxqn
  • model: TS0203
  • zigbeeNodeType: SLEEPY_END_DEVICE

Raw Description 01 0104 0402 01 04 0000 0001 0500 EEFF 01 001

Thank you dude!

Hiya
Tried it this morning and it changed to the edge driver ok,
Colour change works ok
Seem to have problems that cant turn off device or use the dimmer on this one.
The other unit 008 using the same driver does all functions
Here is a screenshot of the problem device on the old ide

I see no reason why it shouldn’t work.

In these cases, it is usually solved by uninstalling and reinstalling it from scratch.

Taking into account the following for the edge drivers:
The installation is a longer process than it seems in the app.

once the device appears let it finish the configuration and installation in the hub, it can take up to almost a minute sometimes.

close the app and reopen the device, it should work.

1 Like

Hi, trying to use the edge driver for a 3 gang multi switch zemismart.
Edge drivers in have enrolled for and are listed on my hub.
But when i pair the switch it show up as a “thing”, changing that in IDE to Zigbee Multiswitch gives 2 gangs working but third not detected.

How do i get it to use the “Mc” versions of the driver?

Added to this driver date version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Contact Mc                    │
│ Version     │ 2022-02-02T18:50:15.859639           │
└─────────────┴──────────────────────────────────────┘
  - id: "_TZ3000_o5wjxxqn/Close Sensor"
    deviceLabel: TS0203 Close Sensor
    manufacturer: _TZ3000_o5wjxxqn
    model: TS0203
    deviceProfileName: contact-battery-profile

Hello,

This is a small guide on how to use the existing edge drivers in the official channels and shared by users instead of the groovy DTH ones.

Thanks for that
Shows up as

  • application: 47
  • endpointId: 01
  • manufacturer: _TZ3000_34zbimxh
  • model: TS0003
  • onOff: catchall
  • zigbeeNodeType: ROUTER
    In the IDE
    I guess I need to look for “_TZ3000_34zbimxh”
    in fingerprints.yml for Zigbee Switch Mc?
    Is this on Gitlab?

Edit: I assume it is here?

If so then “_TZ3000_34zbimxh” is missing and I guess it’s not supported yet.

Added to this version of the driver Zigbee Multi Switch Mc
I have added it to this driver because there are several TS0003 models in this driver, if it doesn’t work for you tell me and I’ll add it to the Zigbee Multi Switch Zemismart Mc
If it works tell me and I add it to the list of devices that is in the header post

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Multi Switch Mc               │
│ Version     │ 2022-02-02T21:06:05.221211           │
└─────────────┴──────────────────────────────────────┘
  - id: "TS0003/_TZ3000_34zbimxh"
    deviceLabel: TS0003 Switch
    manufacturer: _TZ3000_34zbimxh
    model: TS0003
    deviceProfileName: three-switch

thanks, i will give it a go and report back

Just Tried it - it reports as Switch Ts003 but unfortunately only shows as a single gang switch rather than the 3 gang it should be.
The one switch is working though!

Update: The IDE shows two child switches switch2 and switch3 but they don’t show up in the smartthings app.

If it’s android, Close the app and clear the app’s cache.

You can reinstall it, if they appear in the IDE, although the IDE information is not reliable for the edge drivers, they should appear in the app

In Edge driver appears as this, one multi device

Hmm.
I deleted the device and reinstalled it.
Was expecting it to show as 3 switches but it shows as one before.
The device was not responding at all (even for 1 switch) see screenshot.
Deleted and reinstalled it a couple more times with no success.
So i uninstalled the driver and reinstalled it and then it worked!
I’m guessing since this is only exposed as a single switch to Alex that the other two switches are not controllable from there (expect by ST routines and virtual switches)?

Many thanks Mariano, much appreciated!

Yes, you can use virtual devices to create mirror devices of switches 2 and 3.
It is an inconvenience for many this operation
I don’t know if they will improve it in the future

1 Like

Hey Mariano, greetings!

Could you please include this 3 gang multi switch zemismart?

Data
application: 43
endpointId: 01
manufacturer: _TYZB01_stv9a4gy
model: TS0013
onOff: catchall
zigbeeNodeType: SLEEPY_END_DEVICE

Raw Description 01 0104 0100 00 03 0000 0003 0006 01 0019

Thanks my friend! Have a great day.

Great dude!
Thanx

1 Like

Thanks, same for you

Added to this driver date version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Multi Switch Mc               │
│ Version     │ 2022-02-03T16:31:37.739989           │
└─────────────┴──────────────────────────────────────┘
  - id: "TS0013/_TYZB01_stv9a4gy"
    deviceLabel: TS0013 Switch
    manufacturer: _TYZB01_stv9a4gy
    model: TS0013
    deviceProfileName: three-switch
1 Like

Can you please add driver for SmartThings Multipurpose sensor (2015)?
Thanks in advance.

Added to this version of the driver
I don’t know if the information of the 3 axes works well
I guess smartthings will have to edge this stock DTH that affects several smartthings devices and centralite

  - id: "CentraLite/3321-S"
    deviceLabel: Multipurpose Sensor
    manufacturer: CentraLite
    model: 3321-S
    deviceProfileName: st-multipurpose
┌─────────────┬──────────────────────────────────────┐
│ Name        │ SmartThings Multipurpose Sensor Mc   │
│ Version     │ 2022-02-04T18:24:38.471734           │
└─────────────┴──────────────────────────────────────┘
1 Like

A recent zigbee switch with power meter.

  • application: 45
  • endpointId: 01
  • manufacturer: _TZ3000_u5u4cakc
  • model: TS011F
  • zigbeeNodeType: ROUTER
    Raw Description 01 0104 010A 01 09 0000 0003 0004 0005 0006 0702 0B04 E000 E001 02 0019 000A

I am especially interested in utilizing the power meter function with your driver.
Thank you for your great work!