[Beta] Zigbee Edge Driver compatible with Lidl, Ecosmart, Osram, SmartThings & Others

Hi @Mariano_Colmenarejo , @Paul_Oliver. I’m wondering if this zigbee-multi-switch-Zemismart edge driver may work with the Zemismart No Neutral Wall Switch shown below. I’m really looking forward for local control and like the design of those switches :stuck_out_tongue:

@SableBlack,

Without trying it it is difficult to know if it will work and without knowing which clusters it uses even less.
Knowing if it works with any DTH makes it easy to make the prediction

It’s a matter of trying it

1 Like

I’ve just order one and will give it a try, will keep you posted. Also im wondering if it would be possible to add the device shown in the picture below to either of your zigbee multiswitch drivers. Im currently using it with the “Zigbee Multiswitch” DTH. The device picture is also shown.

1 Like

@SableBlack
Is a doble switch?

@Mariano_Colmenarejo
Both aqara contact and motion are not working and for illuminance it need motion to be updated .
They are stuck at verify, and contact and motion as the cloud sign with a line …

For the sonoff contact sensor i saw maybe something that could solve the problem of showing offline if the sensor as not been trigger for some hours ,

What do you think , is it possible for you to do that for the sonoff contact sensor?
Thank You
Sylvain

It is Mariano, it has two independent relays.

Added to zigbee Multi switch Mc
if not works fine, then I will change to Zigbee Multi Switch Zemismart Mc

  - id: "eWeLink/ZB-SW02"
    deviceLabel: eWeLink ZB-SW02 Switch
    manufacturer: eWeLink
    model: ZB-SW02
    deviceProfileName: two-switch

Thanks Mariano! I’d give it a try. So I’d uninstall the device, install the new driver and then re-add it. Right?

1 Like

I will remove them from the rivers to avoid confusion.

Regarding the sonoff MS01 motion sensor, it is on the official list of beta driver smartthings. If the driver is modified in the battery configuration, it is modified for all devices in the driver.
However, even if you reduce the battery interval time, the report is only sent if there is a minimum change of 1%. I don’t know if this would help solve the problem.

It was more for the sonoff door sensor , sonoff motion sensor seem to be more reliable.
If you think it will not solved the problem then forget it

@Mariano_Colmenarejo It didn’t worked :frowning: I can only control the main switch, but for the second I only see the offline cloud. It is interesting that if I manually turn on Switch2, in the app the status of the Main switch is the one that changed to on and I cannot turn switch 2 off from the app after being manually turned on. Could you please help me update the zemismart one driver so we can try if that works? Thanks again man!

Added to Zigbee Multi Switch Zemismart Mc

You do no need uninstall switch.
Install driver Zigbee Multi Switch Zemismart Mc in your hub and perform a driver change.

@Mariano_Colmenarejo thanks man. I did what you tell me but it has the same behavior. I even uninstall the device, delete all drivers, reboot the hub, install the driver again and add the device but the final result was the same. I recall reading in this thread that another guy was in a similar situation and used a different driver to force the 2nd switch and then your worked, but im not sure how to do that :confused:

@GiacomoF hey! I saw you struggle with the 2 gang Zemismart driver that @Mariano_Colmenarejo shared, you said you use another driver to enable the 2nd switch. How did you do that, which other driver did you use? Thanks! :wink:

@SableBlack,
if you slide your finger down on the details screen to do a refresh, it doesn’t do anything?
If I turn on from the physical switch, does it not do anything either?

Sliding down to refresh dont do anything. Turning switch 2 by hand shows Main switch turned on

Without seeing the logs I cannot analyze what happens.

sorry

@Mariano_Colmenarejo no worries man, I appreciate the interest. Just wondering if I can get the logs you need from the IDE?

Ive just noticed also that the status of the main switch changes to off for no reason on the app when it is actually on.