[Beta] Zigbee Edge Driver compatible with Lidl, Ecosmart, Osram, SmartThings & Others

Did you configure these values in your driver’s fingerprints, @Mariano_Colmenarejo? Along with the uppercase manufacturer?

1 Like

Yes, this data

  - id: "SONOFF/01MINIZB"
    deviceLabel: SONOFF Switch
    manufacturer: SONOFF
    model: 01MINIZB
    deviceProfileName: single-switch

But don’t they have priority to match drivers over stock DTHs?

Yes, that’s correct, but if they’re paired to stock DTHs, it means the matching fingerprint is not found in any driver installed. Let’s review the things we need to check:

  • The fingerprint must match the one in the device’s DTH, if there’s no DTH, then you need to look at the Hub events (instructions here).
  • The driver must be assigned again to the channel when it’s updated (package and publish). Remember that for the users invited, updates might take a few hours to be effective.
  • If you add more fingerprints to your driver, and only some of them are failing, then the device has a specific issue
  • If all new fingerprints are not working (even after the automatic update), then, something might be wrong with the driver’s update.

@Mariano_Colmenarejo and @nayelyz

I just got the Sonoff Mini to pare as a driver using the “ZigBee Switch mc” driver, but it is not functioning.

The app shows it stuck in the ON position, but the light connected to it is off.

If I operate the dumb switch connected to the Sonoff Mini the light goes on and off and the app shows the correct status. After the manual switch operation the app can be used for a few cycles before it gets stuck in the ON position with the light off. In addition the icon does not change.

If tried uninstalling and reparing the mini, rebooting the hub, closing the app, clearing the cache, force stopping the app. I did each of the above multiple times and nothing helps.

I also tried to operate it via an Automation and that did not work.

The only thing that works is cycling the dumb switch, but that only fixes the app for 1 to 3 cycles.

EDIT: After several hours the icon changed to a bulb, but the switch still can NOT be operated from the app or automations.

@Mariano_Colmenarejo, @nayelyz

The Tuya TZ3000 switch pared as a driver on the 1st try using the “ZigBee Switch mc” driver. I was able to change the icon and it works as expected.

Thanks again for your help.

1 Like

I think this is very important to keep in mind for users who are already using a driver and have requested or want to use other devices added later to that driver.

  • Once published, they have to wait for the automatic driver update for several hours.
  • If you want it to be faster, you should uninstall the hub driver and reinstall the new version.
    This implies not having devices paired to the driver to uninstall it.

You can check the version of the driver (Date and time of creation of the driver) in details of the hub, menu driver, select a driver

The Sonoff Mini seems to be working as expected this morning (12 hrs after the change) and the icon change is sticking.

Thanks again

EDIT: I spoke to soon. It is stuck in the on position again.

So the TS0001 is now working correctly, however, the ewelink switch toggles on/off but only after refreshing the device page…otherwise the icon sticks at on or off and spins.
Still no pairiing with ST Outlet or ST v2 motion sensor

Glad to hear it!

however, the ewelink switch toggles on/off but only after refreshing the device page…otherwise the icon sticks at on or off and spins.

Try following it, there are times that they do not pair well.
Install the zigbee switch Mc (OLD) driver, it does not have custom capabilities.
In the switch, details, menu driver, choose another driver.
Choose the one that shows you, it will appear zigbee switch Mc (OLD)
click on use this driver.

Exit the app, clear the cache and reopen to see if that works.

If it works fine, and you want to, reinstall the zigbee switch Mc driver following the same steps.

I’m going to add the fingerprints from the stock dht, but smartthings should fix that if there is a driver with the fingerprints, choose the driver and not the DTH

@troy_owens,

Added theses fingerprints for zigbee motion sensor MC and zigbee switch power Mc

zigbeeGeneric:
  - id: "outletv4"
    deviceLabel: "Zigbee SmartTings outletv4"
    zigbeeProfiles:
      - 0x0104
    deviceIdentifiers:
      - 0x0002
    clusters:
      server:
        - 0x0000
        - 0x0003
        - 0x0004
        - 0x0005
        - 0x0006
        - 0x0009
        - 0x000F
        - 0x0B04
      client:
        - 0x0019
    deviceProfileName: power-meter
zigbeeGeneric:
  - id: "motionv5"
    deviceLabel: "Zigbee SmartTings motionv5"
    zigbeeProfiles:
      - 0x0104
    deviceIdentifiers:
      - 0x0402
    clusters:
      server:
        - 0x0000
        - 0x0001
        - 0x0003
        - 0x000F
        - 0x0020
        - 0x0402
        - 0x0500
      client:
        - 0x0019
    deviceProfileName: motion-temp-battery

Tried what you suggested… Same behavior

I Think @Paul_Oliver have same problem with sonoff mini but the ewelinks works fine for mi and others user.
Sorry, I do not what happend!

@troy_owens
Try to re-add eWelink again. I had issue with only one plug, and after reinstall, work fine

I have 3 eWeLink switches, and Ikea plug working with the driver, and I am not have any issues.

But I can NOT get a Sonoff Mini to work correctly with this driver. I have deleted and reinstalled it at least 3 times.

I could implement this function in the future when I’m done with other things I’m doing, but I don’t have RGb or RGBW zigbee bulbs to debug it.

1 Like

In cases where the device is added but doesn’t work correctly, it would be useful that you checked the Hub logs to see if there was an error during the pairing of the device.

Here are the instructions to enable them:

I already have the CLI installed. Do you want logs of it joining, and/or turning it on and off?

Agree,

but do not put them with developer format giving </> that the mobile browser crashes