[Beta] Zigbee Edge Driver compatible with Lidl, Ecosmart, Osram, SmartThings & Others

Hi Mariano
Did you resolve this?
Sorry for the confusion.

The Sonoff Mini switch is pairing with a DTH, not your ZigBee Switch driver. I did it twice. Before the 2nd try I closed the app cleared cache, force stopped app, and rebooted hub.

I have not tried the Tuya switch.

That manufacturer makes zwave, Zigbee, and WiFi models, often using the same case so they look identical, but with different model numbers.

They have a Zigbee motion sensor and a Zigbee contact sensor, but I think the most current Zigbee models are rebranded tuya devices.

http://szneo.com/en/products/index.php?id=68

Wath DTH and is stock or custom?

Normally is due to device pairng with a custom dth or generic fingerprint.

I would have to add the generic fingerprint and then anyone who does not want to use the driver on some switch, would have to uninstall the switches paired to the driver and remove the driver.

If your switch paired with de DTH zigbe switch power stock, normally is due to device pairng with a generic fingerprint.
I would have to add the generic fingerprint to driver but then anyone who does not want to use the driver on some switch, would have to uninstall the switches paired to the driver and remove the driver.

In this case sent me, is a zwave model

1 Like

Both the Sonoff Mini and Tuya switches use the stock “ZigBee Switch” DTH.

Only the single gang models, though, right?

As I understand it, the multi gang tuya switches use the proprietary EF00 cluster to manage the extra gangs and so need custom code. The stock multigang Zigbee switch DTH doesn’t work with them. :disappointed_relieved:

See the following discussion for details:

[Device Handler] Moes 2 and 3 gang Zigbee wall switch ( cluster EF00)

ST motion sensor and ST plug pairing with stock or custom dth?

El ewelink would works fine after reboot hub and clear memory cache
Some times the driver install slower or not install correctly.

Ecolink is the other? If yes, is possible the battery profile is different to percentaje remaining and need make a subdriver.

TS0001 pir wit dth stock. I see in your screenshot the switch is without status. Workd well with dth?

I don’t understand how these switches pair with the stock dth zigbee switch if it doesn’t match any generic fingerprint

// 		// Generic
		fingerprint profileId: "C05E", deviceId: "0000", inClusters: "0006", deviceJoinName: "Light", ocfDeviceType: "oic.d.light" //Generic On/Off Light
		fingerprint profileId: "0104", deviceId: "0103", inClusters: "0006", deviceJoinName: "Switch" //Generic On/Off Switch
		fingerprint profileId: "0104", deviceId: "010A", inClusters: "0006", deviceJoinName: "Outlet", ocfDeviceType: "oic.d.smartplug" //Generic On/Off Plug

SONOFF have fingerprint in dth but the driver must be preference to DTH stock


		// SONOFF
		fingerprint profileId: "0104", inClusters: "0000, 0003, 0004, 0005, 0006", outClusters: "0000", manufacturer: "SONOFF", model: "BASICZBR3", deviceJoinName: "SONOFF Outlet", ocfDeviceType: "oic.d.smartplug" //SONOFF Basic (R3 Zigbee)
		fingerprint profileId: "0104", inClusters: "0000, 0003, 0004, 0005, 0006", outClusters: "0000", manufacturer: "SONOFF", model: "S31 Lite zb", deviceJoinName: "S31 Outlet", ocfDeviceType: "oic.d.smartplug" //S31 Lite zb
		fingerprint profileId: "0104", inClusters: "0000, 0003, 0004, 0005, 0006", outClusters: "1000", manufacturer: "SONOFF", model: "01MINIZB", deviceJoinName: "SONOFF 01MINIZB" //01MINIZB

Will they add blanks in manufacturer and model as well? @nayelyz

Yes the Sonoff and Tuya switch we are discussing are both single gang switches.

Mariano has a multi gage ZigBee driver that works with my 3 gang Zemismart (Tuya) switch. It has some issues with gangs 2 and 3, but it works.

1 Like

Hi Mariano.
I used this plug with your “Zigbee-Switch-Power” driver
it works well I tested it all yesterday.

  • id: “innr SP 120”
    deviceLabel: innr Plug
    manufacturer: innr
    model: SP 120
    deviceProfileName: switch-power-plug

The only thing that creates some problems is the dynamic change of the icon, in the sense that sometimes it goes back to the old profile then changes again.

Also you should edit the profiles within the “Zigbee Light Multifunction Mc” driver for these devices that I have and they work fine

  • id: “OSRAM / Classic B40 TW”
    deviceLabel: OSRAM Classic B40 TW
    manufacturer: OSRAM
    model: Classic B40 TW - LIGHTIFY
    deviceProfileName: level-colortemp-2700-6500
    • id: “LEDVANCE / A60 TW”
      deviceLabel: LEDVANCE A60 TW
      manufacturer: LEDVANCE
      model: A60 TW Value II
      deviceProfileName: level-colortemp-2700-6500
1 Like

Thanks for the feedback.

Yes, this happens with some icons.
They also move to the last place in the room where it is as if they had just been added.

If there are more benefits than disadvantages, everyone can choose whether to change them or not.

ST motion and plug are still pairing with stock dth.
Ecolink pairs and works with exception of battery data.
TS0001 paired as a “thing” as it did originally and has to change to ZigBee switch in IDE and did work as intended on the stock dth.

Mmm…I haven’t seen comments about issues pairing Sonoff devices from other devs, but it could be the case for the _TX3000_hktqahrq manufacturer
But @Paul_Oliver, please verify the fingerprint values of both devices in the Hub events when the device is paired.

  1. Got to the IDE and select “My Hubs”
  2. Tap on “List Events” (it is the penultimate option in the table)
  3. The paint event is before the “deviceAdd” event. Eg.

Hi @Mariano_Colmenarejo Thanks for coming back to me on this.

I’ve followed your instructions, but it’s still not connecting beyond “Checking…” stage.
Any other suggestions I can try?

I notice in the Settings that there is an option to change the icon. Could you please add water valve to these options too?

Thank you so much for all your support with this.

@Hendo25,

I think not Will work, does not have cluster 0006 and have tuya cluster EF00.

Works with zigbee switch DTH?

Is this what you are looking for:

zbjoin: {“dni”:“1ED7”,“d”:“847127FFFE281752”,“capabilities”:“8E”,“endpoints”:[{“simple”:“01 0104 0100 01 06 0000 0003 0004 0005 0006 1000 01 1000”,“application”:null,“manufacturer”:“SONOFF”,“model”:“01MINIZB”},{“simple”:“F2 A1E0 0061 01 00 01 0021”,“application”:null,“manufacturer”:null,“model”:null}],“parent”:0,“joinType”:1,“joinDurationMs”:11029,“joinAttempts”:1}

Name Value
archivable true
commandId 0
date 2021-11-03 3:01:06.000 PM EDT (2021-11-03T19:01:06.000Z)
description zbjoin: {“dni”:“1ED7”,“d”:“847127FFFE281752”,“capabilities”:“8E”,“endpoints”:[{“simple”:“01 0104 0100 01 06 0000 0003 0004 0005 0006 1000 01 1000”,“application”:null,“manufacturer”:“SONOFF”,“model”:“01MINIZB”},{“simple”:“F2 A1E0 0061 01 00 01 0021”,“application”:null,“manufacturer”:null,“model”:null}],“parent”:0,“joinType”:1,“joinDurationMs”:11029,“joinAttempts”:1}
displayed false
eventSource HUB
hubId db86d2e4-3209-409c-b36b-f613d7b32bcb
id 6add9514-021b-48ea-97dd-fc9f9d6fd803
isStateChange false
isVirtualHub false
linkText Home Hub
locationId f5ed0b5a-6249-4e72-bea7-2736f235e817
name zbjoin: {“dni”:“1ED7”,“d”:“847127FFFE281752”,“capabilities”:“8E”,“endpoints”:[{“simple”:"01 0104 010
rawDescription
translatable false
unixTime 1635966066000
value zbjoin: {“dni”:“1ED7”,“d”:“847127FFFE281752”,“capabilities”:“8E”,“endpoints”:[{“simple”:“01 0104 0100 01 06 0000 0003 0004 0005 0006 1000 01 1000”,“application”:null,“manufacturer”:“SONOFF”,“model”:“01MINIZB”},{“simple”:“F2 A1E0 0061 01 00 01 0021”,“application”:null,“manufacturer”:null,“model”:null}],“parent”:0,“joinType”:1,“joinDurationMs”:11029,“joinAttempts”:1}
viewed false

Hi @Mariano_Colmenarejo - ok, thank you.

I have not got this working with any DTH yet.

I have reviewed this thread - How to connect Tuya compatible 2 gangs Zigbee Switch module
and
[Device Handler] Moes 2 and 3 gang Zigbee wall switch ( cluster EF00) - #6 by johnconstantelo

and tried different DTH. Not working.

I can see this device works in Home Assistant, but nothing for Smartthings yet.

Thank you for trying.

1 Like

@nayelyz,
I do not quite understand what is happening so there are more problems to match the drives when the devices have full or generic fingerprints in DTH Stokcs.

The ST motion sensor motionv5 is in the dth stock smartsense motion sensor

fingerprint inClusters: "0000,0001,0003,000F,0020,0402,0500", outClusters: "0019", manufacturer: "SmartThings", model: "motionv5", deviceJoinName: "Motion Sensor", mnmn: "SmartThings", vid: "SmartThings-smartthings-SmartSense_Motion_Sensor"

I can’t see the ST plug outlet4 on the zigbee switch or zigbee switch power

Has something changed in the Hub?