[Beta] Zigbee Edge Driver compatible with Lidl, Ecosmart, Osram, SmartThings & Others

One last favor Mariano, just got on the door a three gang (3-switch) version of another Zemismart Zigbee Switch. As well is showing right now as a thing. Could you please help me to add it to the your Edge Drivers? The details of the device as follows:

Thanks again man!

Added to both drivers

│ Name │ Zigbee Multi Switch Mc
│ Version │ 2021-11-29T22:01:47.836882

│ Name │ Zigbee Multi Switch Zemismart Mc
│ Version │ 2021-11-29T22:02:00.78457

  - id: "Zemismart/TZ3000_k44bsygw"
    deviceLabel: Zemismart TZ3000 Switch
    manufacturer: _TZ3000_k44bsygw
    model: TS0013
    deviceProfileName: three-switch

Thanks Mariano!. Same behaviour as with the two gang switch. I’m only able to control the main one and there is a cloud symbol for the other 2. Would it be possible that the Smartthings Wifi Hub is probably the cause of this issues? I’m aware that some edge functionalities in this hub are not working properly… just thinking out loud.

I would not know how to answer that.
I lack the knowledge to analyze if it is the fault of that type of hub.
Being able to see them logs could help to analyze the problem.

Hi! @nayelyz do you think the fact that I can only control the main switch and none of the others (childs) using Marianos’ drivers is somehow induced by the Smartthings WiFi hub?

1 Like

Yes, some driver’s functionality is not working as expected on this type of Hub. Our team keeps working on this.
Once I get an update, I’ll share it in this main thread:

3 Likes

Is anyone aware of issues in the drivers websites? For some reason I cannot access the official Smartthings repository nor Marianos’ one.

I can’t access any channel via the web either
I can acces from the cli.

In the app I cannot see the drivers installed in the hub and neither from the cli.

2 Likes

Same here

And here. Apparently it has lasted for a while now.

Maybe they decided to kill Edge platform :wink:

This driver works OK for my IKEA bulbs. The progressive on behaves correctly both on a button push and a scene, but I can’t get progressive off to work in a scene - have tried setting options against the device, dimmer options, etc. Any ideas?

You mean Activate prigressive OFF and turn off the light?

Only in one scene, these two actions cannot be executed on the same device.
You have to have the progressive OFF function activated and then execute an Off command

If you don’t have it activated Progressive OFF and you want to activate it in the same automation, you have to do it in 2 steps:

  1. activate light and activate progressive OFF
  2. select automatic shutdown after 10 sec, for example.

The progressive shutdown begins when the Off command is received and the progressive Off function is activated.


If it must to be done in a scene, you can do a routine:
If progressive Off → Active then Light → Off and delay this action 5 sec.

You make a scene:
Activate prigressive Off in the light

When you run the scene, it will start progressive shutdown after 5 sec

@Mariano_Colmenarejo
I and trying to pair the following ST MultiPurpose sensor with you Edge driver. But it keeps pairing with the stock DTH.
I removed your custom DTH prior to trying it with your Edge Driver.

I have 3 running with the driver.
I didn’t have to delete the custom DTH, I just named it by the same name as the stock DTH, SmartSense Multi Sensor.

Is rare!

I will check the fingerprint

Try to activate secure rejoint in the Hub, to prevent it from pairing as the previous device

Using secure rejoin did not help.
It is still pairing with the stock DTH.

Hello, @nayelyz,
you have a multipurpose sensor, can see what happens to pair with the stock DTH.
Until now there were no problems with this device

Thanks

1 Like

Sure, is it the driver named SmartThings Multipurpose Sensor Mc?

1 Like