[Beta] Zigbee Edge Driver compatible with Lidl, Ecosmart, Osram, SmartThings & Others

Sorry, I forgot to answer you

Does it work with battery or external power supply?

The driver that I use does not have battery information

The smartthings driver stock in the beta channel does have battery and power source information, but it does not have your fingerprints.

@Mariano_Colmenarejo
It has battery backup, but uses external power. Here is a screen shot from the DTH.

I’m going to add it to the smartthings driver and test

Added to this driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Valve ST Beta                 │
│ Version     │ 2022-01-12T15:24:14.575482           │
└─────────────┴──────────────────────────────────────┘
  - id : WAXMAN/Valve
    deviceLabel : WAXMAN Valve
    manufacturer: WAXMAN
    model: leakSMART Water Valve v2.10
    deviceProfileName: valve-battery-powerSource

I do not know if I have put the model correctly, it is better to send in text, to copy and paste

Does this help?

Data * zigbeeNodeType: SLEEPY_END_DEVICE

  • firmwareManufacturerCode: 4411
  • firmwareFullVersion: 00000019
  • application: 19
  • endpointId: 01
  • firmwareImageType: 1000
  • manufacturer: WAXMAN
  • model: leakSMART Water Valve v2.10
    Raw Description 01 0104 0002 00 07 0000 0001 0003 0006 0020 0B02 FC02 01 0019
    Firmware * Current Version: 0x00000019
  • Target Version: 0x00000019
  • Last Updated: N/A
  • Last Checked: 2021-10-04 3:41 PM EDT - Check Now
1 Like

Glad to see this fix coming with firmware 0.41.x:

  • Bugfix for Edge Driver backed Zigbee devices with the Power Meter capability reporting power levels that were off by a factor of 1000 (incorrect conversions between Watts and Kilowatts)
1 Like

Both of this supposed to fix most of the issues with lights and plugs

1 Like

Hi Mariano, it is the same model that @Glauber_GD informed.
I tried to pair it again with driver Zigbee Motion Sensor Mc the vibration sensor is eternally as detected. It only changes to “no movement” when pressing the device button.

I think it’s normal that it doesn’t work, I was surprised that it worked for @Glauber_GD

I do not know if it will continue to work

@Mariano_Colmenarejo, can you add this device to the ST-Zigbee Moisture sensor.

Data * endpointId: 01

  • firmwareFullVersion: 10015100
  • firmwareImageType: 11
  • firmwareManufacturerCode: 49887
  • manufacturer: CentraLite
  • model: 3315
  • zigbeeNodeType: SLEEPY_END_DEVICE
    Raw Description 01 0104 0402 00 07 0000 0001 0003 0402 0500 0020 0B05 01 0019

Added to this driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ ST-Zigbee Moisture Sensor Mc         │
│ Version     │ 2022-01-13T22:22:26.176871           │
└─────────────┴──────────────────────────────────────┘
  - id: "3315-CentraLite-Sensor"
    deviceLabel: ST CentraLite Water Sensor
    manufacturer: CentraLite
    model: 3315
    deviceProfileName: moisture-temp-battery-volts

Thank you. Will test when the update gets pushed to me.

Good morning my friend, sorry, I’m a little busy due to working in hospital and lately it’s been really hard, the vibration sensor doesn’t work properly, when it detects the vibration it stays as motion detected continuously, @reinaldots is having the same problem, is there any solution? Thank you so much in advance for your usual help!

@Glauber_GD, @reinaldots,
I think a possible solution would be to put it as a sensor with acceleration capability.

I am going to add a profile as sensor acleration and you will try it.

I’ll let you know when it’s done

1 Like

ok, wait Thanks !

1 Like

@Glauber_GD , @reinaldots

The solution is easier. I did not remember that there is a subdiriver to reset the motion state in some sensors.
I have put it back to inactive in 30 sec
this is the driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Motion Sensor Mc              │
│ Version     │ 2022-01-14T17:35:30.336175           │
└─────────────┴──────────────────────────────────────┘
1 Like

You do not need to wait for the update, it is a new driver

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Valve ST Beta                 │
│ Version     │ 2022-01-12T15:24:14.575482           │
└─────────────┴──────────────────────────────────────┘

Hey, @Mariano_Colmenarejo, regarding this:

You can check if the device supports the OnOff.StartUpOnOff attribute. I assume that this can be easily rolled back with a factory reset.

1 Like

Hello @erickv,

I have made a version of the driver with that option and all the switches that I have respond with UNSUPPORTED_ATTRIBUTE for 0x4003.

I have tried in all and it doesn’t work.

It seems strange to me because I have used some of them in Tuya app and they do have that adjustment option and it works.

This is the log for one of them, I write the value 255 (0xFF) in the attribute 0x4003 of the cluster 0x0006.

2022-01-15T15:43:24.514417372+00:00 PRINT Zigbee Switch 5.5  << Preference changed: name, old, new >>   stateAfterPowerLost     SetOn   PreviousState
2022-01-15T15:43:24.555821706+00:00 INFO Zigbee Switch 5.5  <ZigbeeDevice: 782297fd-21de-4fbd-b2b2-884bc9878a04 [0xFC69] (Lidl Plug)> sending Zigbee message: < ZigbeeMessageTx || Uint16: 0x0000, < AddressHeader || src_addr: 0x0000, src_endpoint: 0x01, dest_addr: 0xFC69, dest_endpoint: 0x0B, profile: 0x0104, cluster: OnOff >, < ZCLMessageBody || < ZCLHeader || 
frame_ctrl: 0x00, seqno: 0x00, ZCLCommandId: 0x02 >, < WriteAttribute || < AttributeRecord || attr_id: 0x4003, DataType: Enum8, data: 0xFF > > > >
2022-01-15T15:43:24.583428039+00:00 PRINT Zigbee Switch 5.5  device.preferences[infoChanged]=   Plug
2022-01-15T15:43:24.599769706+00:00 PRINT Zigbee Switch 5.5  device.preferences[infoChanged]=   10.0
2022-01-15T15:43:24.607682706+00:00 PRINT Zigbee Switch 5.5  device.preferences[infoChanged]=   1.0
2022-01-15T15:43:24.616601706+00:00 PRINT Zigbee Switch 5.5  device.preferences[infoChanged]=
2022-01-15T15:43:24.628821372+00:00 PRINT Zigbee Switch 5.5  Device ID  <ZigbeeDevice: 782297fd-21de-4fbd-b2b2-884bc9878a04 [0xFC69] (Lidl Plug)>
2022-01-15T15:43:24.644253372+00:00 PRINT Zigbee Switch 5.5  Manufacturer >>>   _TZ3000_kdi2o9m6        Manufacturer_Len >>>    16
2022-01-15T15:43:24.650833706+00:00 PRINT Zigbee Switch 5.5  Model >>>  TS011F  Model_len >>>   6
2022-01-15T15:43:24.656895706+00:00 DEBUG Zigbee Switch 5.5  Lidl Plug device thread event handled
2022-01-15T15:43:24.686309706+00:00 TRACE Zigbee Switch 5.5  Received event with handler zigbee
2022-01-15T15:43:24.720950373+00:00 INFO Zigbee Switch 5.5  <ZigbeeDevice: 782297fd-21de-4fbd-b2b2-884bc9878a04 [0xFC69] (Lidl Plug)> received Zigbee message: < ZigbeeMessageRx || type: 0x00, < AddressHeader || src_addr: 0xFC69, src_endpoint: 0x0B, dest_addr: 0x0000, dest_endpoint: 0x01, profile: 0x0104, cluster: OnOff >, lqi: 0xB4, rssi: -55, body_length: 0x0006, < ZCLMessageBody || < ZCLHeader || frame_ctrl: 0x18, seqno: 0x62, ZCLCommandId: 0x04 >, < WriteAttributeReponse || < WriteAttributeResponseRecord || ZclStatus: UNSUPPORTED_ATTRIBUTE, AttributeId: 0x4003 > > > >

@BaRaD5,
If you want to try on your switch, I publish it and try

Will try it out now!

EDIT: i did a re-pair and it was found as a thing, not as a driver

Uh :pensive: that’s unfortunate