[BETA] Z-Wave Tweaker (See post #209 for new V3 app version)

Perhaps you have a range issue. You might try removing the devices from the wall. Wire them to an extension cord end (tape it up good so you don’t fry yourself) then plug them both in near to the hub. See if you can get tweaker to set up the association then. You would likely have to run network repair after moving them back to the wall but at least you might get it working.

Huh, I can do that. If I move the hub between them - it’s maybe 5’ or 6’ from each device to the hub. Is that close enough?

Worth a try.

Found this on another thread. Seems there is an issue with the ST and associations.

ST staff chime in further down the string and promise a fix.

1 Like

Just a note - with the most recent Firmware update - this is fixed. I was able to do associations for three different switches, and they all work just fine.

1 Like

I have problems using the tweaker with Fibaro Double Relay FGS221. Get the message “: error java.lang.NullPointerException: Cannot invoke method startsWith() on null object @line 1618 (initialise)”.

Have tried two different FGS221 and also tried uninstall and reinstall the device handler.

It works well with other Fibaro devices as dimmer.

so I wanted to add more info to this thread for other eaton users.

I went ahead and in IDE changed the DTH for the 9542 to tweaker
Then in app I changed the 9542 settings to “Configure group - 1” (no other group ID functioned for me)
Devices in group, “XX, XX” (9540 master and 9542 accessory) which worked fine for my kitchen, but failed in my family room.
Set to “auto” recognize the type
It then sync’d, turned green and I went back to the IDE to change the DTH of the devices back to their originals.
in the family room I was only successful with the 9542 having the master ID of the devices in group list was the only variation to succeed
I used group 1 again for the family room.

I spent weeks on using Tweaker but I finally gave up and bought the Eaton AspireRF RFTDC remote and it just works with simple programming.

I tried to use Zwave Tweaker to figure out how the AspireRF programmed into the 9540/9542 but can’t see any changes from Tweaker. Seems the Eaton Aspire has different configuration parameters into the switch that Tweaker can not perform

Good afternoon, guys! I’ve installed Zwave Tweaker and even looked at youtube video https://www.youtube.com/watch?v=9D-hz2ITU18

I cannot get my Cooper 9540-N and 9542-Z switches to talk and need assist.

Thanks!

I am NOT, NOT an expert, but I have four switches associated fine with four dummy switches that always work.

I believe you have to have the associated Group ID as a “1”, not a “2”.

1 Like

Not sure if this answer has been updated:

Does Z-Wave Tweaker work with the new app?

1 Like

Depends what you need to do with it, I guess.

Everything I’ve ever needed to do with it can be done using the device settings so that should be fine in the new app. If I sound slightly vague it is because I would already have been on the device page in the IDE to have swapped the Tweaker in, so it is easier to change the settings from there.

If you have to do something that involved clicking on the tiles in the Classic app you might have an issue currently because several of the tiles work with custom commands and the new app doesn’t have a UI for those yet. Nothing to stop you running the commands from something like webCoRE if necessary.

Thanks! I just use it to associate some WT00Z’s to WS15Z’s.

Hello. I am having trouble with associating 2 Eaton Z Wave switches.

I have an Eaton RF9601 master switch and Eaton RF9617 Accessory switch. The master switch (titled “Light” in ST app) works fine turning the light on and off, but i cannot figure out how to associate the accessory switch (titled “Light 2” in ST app). Here is what I’ve tried:

Can someone please help? I just want the accessory switch to work to turn the light on and off.

Because I rely on text to speech, I can’t help with the specific Tweaker settings, but two things which often trip people up I thought might be worth mentioning.

  1. after you have added both switches to your smartthings account, you will use the Tweaker on the trigger switch, in this case the RF9617 Accessory switch. You do this by temporarily assigning the switch to the Tweaker DTH. Then you make your parameter settings, save them, and then change your switch back to its original DTH.

You don’t have to do anything with the master switch. You do need to know the network ID which was assigned to the master switch so you can enter that into the Tweaker field for the target device.

  1. because these are Z wave plus devices, association group one is reserved for the “lifeline group.“ Don’t try to make your association between the switches in this group. Instead, you check the manufacturer’s instructions for the device to see which association group to use.

In this case, you will be using association group 2.

https://products.z-wavealliance.org/products/3037/assoc?noFilename=True

You may have already done all of that, but I just wanted to mention it, because people often get confused and think they are supposed to do something with the target switch. But what Z wave direct association does is give the trigger switch (your accessory switch) permission to send a command directly to the target switch without going through the hub. The target switch actually doesn’t care where the command comes from as long as it’s on the same network.

Good luck! :sunglasses:

Hi @JDRoberts

I followed your instructions. I first removed the Accessory switch RF9617 from my SmartThings Hub and re-added it to have a fresh start.

I then went into the IDE and loaded the tweaker in the device. I then set the following configuration

Group ID: 2 (per your link above)
Group Member: 09 (this is the master switch RF9601)
Class: Auto-detect

I verified that it synced successfully. Then loaded back the original DTH (Z Wave Switch Secure)

But the light is still not turning on and off? I feel like im still doing something wrong…

i also have problems with association group ID on 2 out 3 MCO Home switches.
i managed to associate 1gang switch to the second button of the 2gang switch but i’m not able to do it vice-versa.
this is what i get in the logs:

for MH-S412 (2 gang):

zwtAssocGroupCc enum 0
zwtAssocGroupId number 5 (the groupID for the second gang)
zwtAssocGroupMembers text 10

21d412c8-fec1-4556-aebe-40e6204a5dbf 12:43:48 PM: info sync(): Unknown association group. Requesting more info.
21d412c8-fec1-4556-aebe-40e6204a5dbf 12:43:48 PM: trace sync(): Syncing.
21d412c8-fec1-4556-aebe-40e6204a5dbf 12:43:48 PM: trace parseAssocGroupInput(): Parsing Association Group Nodes: 10
21d412c8-fec1-4556-aebe-40e6204a5dbf 12:43:48 PM: trace updated()

for MH-S314 (4 gang):
zwtAssocGroupCc enum 0
zwtAssocGroupId number 11 (groupID for the 4th gang and actually is in hex B)
zwtAssocGroupMembers text 1E:02

092cc868-7ee5-486d-9562-5a88716e7faa 12:55:14 PM: info sync(): Unknown association group. Requesting more info.
092cc868-7ee5-486d-9562-5a88716e7faa 12:55:14 PM: trace sync(): Syncing.
092cc868-7ee5-486d-9562-5a88716e7faa 12:55:14 PM: trace parseAssocGroupInput(): Parsing Association Group Nodes: 1E:02

trying to set the groupID in hex, will result in a different error:

092cc868-7ee5-486d-9562-5a88716e7faa 12:54:53 PM: error java.lang.NumberFormatException: For input string: “B” @line 368 (updated)
but this is due to smartthings code not supporting hex for groupID, i guess.

of course, all the settings were taken from the manual.

any help is much appreciated!

thanks

i tried again today to create associations and for my surprise it went well for the MH-S412s with same command as the one above.
i’m still having issues with MH-S314, it doesn’t know any groupID which is weird. i get the same error for all the groupID’s
i will try tomorrow to power cycle this one and maybe …

I did a power cycle and I was able to set association on the last switch.
Now, i don’t need to use smart light app for having 2 switces command the same load.

Thanks for the great device handler!

1 Like

Is there anything different with the code that would for some reason not work in the new app? I tried to copy/paste the code from the .groovy into the ST IDE. When I click create, the following error message pops up:

No signature of method: script_app_metadata_6874ff79_4d85_4cf8_9b1c_7d7d4b0c3fc1.metadata() is applicable for argument types: (script_app_metadata_6874ff79_4d85_4cf8_9b1c_7d7d4b0c3fc1$_run_closure1) values: [script_app_metadata_6874ff79_4d85_4cf8_9b1c_7d7d4b0c3fc1$_run_closure1@6326d77d] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

I’m not savvy enough with the code to try to debug it. Is there something simple that I’m missing in this process? I’ve tried several times to make sure I’m not suffering a copy/paste error, but it’s always the same result.

Thanks!