[BETA] Z-Wave Tweaker (See post #209 for new V3 app version)

I am using the new one. Thanks for the info, I didn’t realise this. That puts me back to square one with setting the fade time on the light sadly. If anyone knows any alternative solution that would be great!

I don’t have a Aeotec Nano Dimmer so I’m not familiar with it. But, if you think Tweaker will do what you want, just download the SmartThings Classic app.

2 Likes

Such a simple suggestion, Classic app worked perfectly. Thank you!

2 Likes

I understand that Tweaker only works on mains-powered devices, but I tried it on a battery powered device (Monoprice Door/Window Sensor) and I was not able to get accurate information on it. My goal is to try to set up an association group with this device. What is the best way to do that if Tweaker doesn’t work?

Since this discussion will be offtopic for this particular thread, can you start a new thread, maybe something like “setting association for battery powered Z wave devices?” And then we can talk about the options.

https://community.smartthings.com/c/devices-integrations/connected-things

New Topic Started

1 Like

Total noob question: will the tweaker work on zigbee devices? I need to change the temperature reporting interval of the iris contact sensor. Thanks

Nope, hence the title of the DTH :wink:

3 Likes

Ha! Thanks

I have spent all morning trying to achieve an association between 2 fibaro modules with zero success, would someone be kind enough to take a look at what I am doing and work out where I am going wrong.

My scenario is I have a dining room light connected to a Fibaro Dimmer 2 FGD-212 which works perfectly and controls the light how I would like.

I then have a kitchen light switch which I have converted to a double light switch and connected this to a Fibaro Switch 2 FGS-223 again this works perfectly, S1 turn my kitchen lights off and S2 shows the value within the Smartthings app as on or off when the second switch is toggled. Q2 is not actually physically connected to anything as the idea is to use Z-wave association to use the S2 from the FGS-223 to turn on and off the dining room light connected to the FGD-212.

After a bit of advice and reading of the manual it would seem to is done by changing the device handler on the Dimmer 2 FGD-212 which is connected to the dining room light and going into tweaker and setting the Association Group ID: to 4 see below taken from the Dimmer 2 Manual

which I have done as can be seen below

I have then set the group members to 0A-ep2 (I have also tried just 0A in case the -ep2 bit was causing issues) see below which shows my device network ID’s and why I have set it to 0A-ep2

I have tried leaving the command class alone and auto but neither setting makes a difference.

I then save this and put the device handler back to the original Dimmer 2 device handler, but nothing seems to change all the devices still continue to work the same through ST but the S2 on the FGS-223 still has no control over the dining room light.

I am obviously doing something wrong, missing out part of the process or just not understanding this all correctly, can someone please help me understand and help me get this working.

I am not sure if I am missing something that I need to change within the Switch 2 FGS-223 within tweaker? So far I understood that I would leave the Switch 2 alone and the changes would all be made within the Dimmer 2 and tweaker?

Thanks in advance for any help anyone can offer me, if any live logging is required please let me know and I will post it up

Ignore my last reply laying in bed i think I’ve realised it is the association for the switch 2 i need to change in tweaker not the dimmer 2!

1 Like

I am trying to set up a TKBHOME TZ35D with the Z-Wave Tweaker to a second switch (works by association only) to control another Z-Wave unit.

I have managed to install the Z-Wave Tweaker fine and can view parameters and settings on the switch.

However all of this new to me. With a little assistance from a very helpful guy on this forum, I think I have managed to understand that setting a group as specified by the TZ35D manual and including the network ID of the Z-Wave device I want to control the switch will send the appropriate signal to the device directly and should have it working.

Group 4 gives me the functions I need from the switch (simple on and off commands)

These are the parameters I have changed

But the switch did not control the device, any ideas on what else I need to change would be useful, a screenshot of the parameters from a working one to give me a good example to follow would be great.

Also if anyone knows the base handler that is best, I am using “Z-Wave Switch Generic” but maybe that is not appropriate.

Any help much appreciated.

Tried to answer the question with the github documentation and the community forums but I’m not finding it. I just installed a GoControl WD500Z5-1 and companion WT00Z5-1 where a previous 3 way switch had been. I wired correctly, so that the 500z switches the load and the other is just a radio switch. I installed the z wave tweaker DTH and ran through setting up and syncing the association group (1 was the only option) and mapping it back to the 500z’s hex address. The 3way dimmer now, if pressed physically, turns the lights on and off (but no dimming). If operated in the app (back to generic dimmer switch DTH) it appears to do nothing. What have I done wrong? How do i enable the 3 way to dim and brighten as well? Thanks so much!

Association Group 1 is the lifeline group. It should only contain the your Hub’s zwave ID.
Below is from manual for the WT005-1. It looks like need to use group 3 for multilevel devices. From your post I can’t make out where you did the association. I think you did it in the WD500Z5-1 as that only has one group according to its manual. I’m not positive but here is what I would try:

  1. Use tweeker to put only the hub id in group 1 of the WD500z5-1
  2. If that does not get it work to restore ST control, then remove the device and re-add it to ST.
  3. Add the device ID for the WD500z5-1 to group3 of the WT00Z5-1.

Note: you can use the 4 tap method in the device instructions rather than tweaker setting up the association.

"The GoControl WT00Z5-1 supports three (3) Association Groups. Group
1 is the “Lifeline” group and must be assigned the Node ID of the Z-Wave
Controller to which unsolicited notifications from the WT00Z5-1 will be sent.
Group 1 supports a single Node ID. The Z-Wave Controller should set the
Lifeline Association automatically after inclusion. For instructions on how to
set Associations, please refer to your Z-Wave Controller instructions. Group
2 nodes will be sent BASIC On/Off commands and is intended to control
switches like the GoControl WS15Z5. Group 3 nodes will be sent Multilevel
Switch commands and is intended to control dimmers like the GoControl
WD500Z5. Groups 2 and 3 support up to five (5) Node IDs.
Associations can be created automatically without requiring the Z-Wave
Controller"

3 Likes

Scott,

Thanks for taking the time to reply. Sorry, been busy with real life until tonight. Re setup the dimmer (the 00Z, not the 500) with Tweaker and reset Association Group 1 to the hub ID. Logged out and put back in generic dimmer DTH. Tried the 4-tap and never got a blinking LED. However, I think they’ve associated as both are dimming and brightening from the switch. The 00Z (3 way dimmer) still does nothing in the app. This is fine for now as it works on the wall and I’ll always use the 500z to turn on and off from Alexa or in the app. It’s not setup all the way correctly but should work for my needs. Thanks for the good instructions.

Hi
I succeed associating multiple devices all linear, the thing there is one I keep getting this message
“parseAssocGroupInput(): Number of nodes and endpoints is greater than 1! The following node was discarded: A6”

I dont know what to do

Need the model number of your device.

3-way Linear Wd500z
And want to control
WD500Z

You may be a bit stuck. The WD500Z-1 manual mentions only association groups 2 and 3. group 2 functions with double taps on the paddle and group 3 functions with triple taps. Group 1 is not mentioned and likely does not work when you activate the paddle with a single tap. You may need to leverage smart lighting or WebCore to get your two units to work like a three way.

The newer zwave plus model WD500Z5-1 only has association group 1 which in Z-Wave Plus is used exclusively for lifeline to the hub.

If your other devices that you has success with are the same model then. I would try a complete reset of the device. Exclude it. Disconnect the power. Reconnect, and add into the network again.

I’ll try that but the thing is that I have at least 6 other devices, same models with associations in group one without any issues. The other thing I’ll try to do is to remove it and add it again to ST hub