[BETA] Z-Wave Tweaker (See post #209 for new V3 app version)

How about you, did you get this working?

No I have no idea what information to put in these fields =(

I think I may have figured it out, but I accidentally bought the wrong “companion” switch. I bought it from Lowe’s and they take returns. But I’m pretty fed up with tweaking, and others have recommended the Leviton switches. I have the required “traveler” wires, so I’m planning to just return the Eaton switches and replace them with Leviton switches.

1 Like

What are you trying to do? You don’t setup anything for a wired ‘accessory’ switch using a traveller. Zwave direct association is only for linking two ZWave devices wirelessly.

If you do need direct association, In group 2 of the controlling device in all but a few circumstances, you will put the ZWave network ID (in Hexadecimal) for the device you want to control…

Eaton Cooper doesn’t use traveler wires: their accessory switches control the master through Zwave direct association. Hence the Tweaker significance.

2 Likes

This varies tremendously from manufacturer to manufacturer. You need to look up how they have set the association groups for that specific model. For example, some will do on/off in group 2 but do multi level switches (dimmers) in a different group. Some use group 2 for tamper alerts. some Z wave devices use up to 14 different association groups for different purposes. So it’s tedious, but you do need to check the specs for each model.

If you can’t find them anywhere else, they are required to be filed with the conformance statement when the device is Z wave certified, so the information should be available on the official Z wave products site.

https://products.z-wavealliance.org/

For example:


Who was that question for? I understand that I don’t need to set up anything for a wired ‘accessory’ switch using a traveller. That’s exactly why I was planning to swap the Eaton dimmer switches out for Leviton switches (Leviton can use my traveller wire).

But since I haven’t yet removed the Leviton switches, I may try your suggestion. I did configure the controlling device, but not using “group 2”. I’ll take one more crack at it.

Meanwhile, it looks like @Corydon_Kintz could still use some help.

Beginning with Z wave plus devices, association group one is now reserved as the “lifeline“ group and in most cases should only have the hub in it. No other device. It’s used for important status updates, but not anything else.

It is allowed to also add the hub to other association groups, and this is often done so that The hub is notified as devices are turned on and off so it can keep the app status up-to-date. Again, though, check the specs to make sure you know what each association group is supposed to do for that particular model.

@nathancu is absolutely right that a common mistake is to open the Tweaker and just start adding things to association group one, and that’s hardly ever what you want to do. :thinking:

And, yes, all this requires knowing a whole lot more about the “plumbing“ then you should need to know to just get water out of the kitchen faucet.

Most Zwave hubs make setting up associations really simple. You open up the trigger device page, you pick the other devices you want it to control, and you’re done.

But from the beginning, smartthings has had this multi protocol design philosophy where they try to hide all the plumbing which is why the community has had to come up with tools for power users like the Tweaker. Which is a fantastic tool and has been very valuable over the years, but not really designed for non-power users.

As has often been said of smartthings, it’s very powerful, but not very intuitive.

2 Likes

It’s looking more and more like Home Assistant, to me. :wink: If I’m going to spend my days learning an automation platform, that (or Hubitat) would be it.

Jack

2 Likes

I am new to this. Just purchased all zwave switch (eaton) for my new house. However the 3 way switches will not work.

Short of manually updating the code has anyone found a way to make this work?

Justin, I had the same problem. I was using the Eaton wiring diagrams that are included with the switches. Somehow a Cooper wiring diagram was included in one of my switches. I used it and it worked.

Not sure but somehow Cooper and Eaton are connected. Maybe one bought the other out, not really sure

Joe

Cooper is owned by Eaton.

2 Likes

Eaton is the company, Cooper is the division, Aspire is the model line.

A device may be sold under any of these names or any combination of them. So “Eaton Cooper,” “Eaton Aspire,” “Cooper Aspire,” etc. :sunglasses:

Cooper Industries was originally founded in the 1830s. It was acquired by Eaton in 2012.

Hi. I’m not sure if this is the right place to ask about this but let me know if it isn’t.
I’ve previously used Z-wave Tweaker to set the parameters on a device (an Aeotec Smart Switch). However, the device recently stopped working and I had to do a factory reset and repair it with my hub and it now works fine again. However, I note (in the SmartThings IDE) that it is a cloud device rather than a hub device (I read recently that this change was going to happen). When I now try to change any of the parameters using z-wave tweaker, I get an error message in the log (Live Logging)

java.lang.NullPointerException: Cannot get property 'hardwareID' on null object @line 134 (initialize)

I also note that Device Network Id and Hub are empty on the device edit page. I can try and guess the Device Network Id but I cannot put anything in Hub as it gives me a permissions error when I try to save.

Is it possible to still use Z-Wave tweaker since the move to cloud based device drivers? Is there some other tool I could be using?

Also also see there is a new SmartThings dashboard here: https://my.smartthings.com/ but that doesn’t have any functionality to modify the parameters.

Any help appreciated. Thanks

What’s the exact model of the device?

I can’t help with the tweaker questions, so hopefully someone else will chime in, but a couple of other points on the new architecture that might help clear up some of the confusion…

  1. if you see odd entries or blank entries it probably means the device is using the new architecture. If so, it will be listed as “placeholder” in the IDE whether it is running local or not. See the following:

FAQ: Why does the IDE list “placeholder” for my device? Can I change that?

  1. the IDE will be going away altogether once the transition to the new architecture is complete, but for now there is a way to still get to it. However, as noted in point 1) information may be missing or incomplete for some devices.

FAQ: How do I access Smartapps, Devices, etc. from web (the old IDE information)

  1. if the device is using an Edge Driver, you may be able to get to some parameters that way, but that’s why we need the model number.

  2. there is a way to get the network IDs in the new architecture using the “CLI,” the Command Line Interface, but that’s a developer tool you have to download to a PC, not just a webpage like the IDE. So the process is a little complicated. I’ll leave the details to someone else since I don’t use that myself.

Hi @constantgraph

It seems that your device has been automatically paired with the edge driver Z-Wave Switch smartthings production.

You will no longer be able to use the Groovy-based configurator.

If you have made the DTH change in IDE the device may no longer work and you have to exclude it and re-pair it.

When paired, in the device menu, at the top right there will be a new menu option, driver.

In settings you will have the parameters that aeotec and smartthings have put for the driver.
Only those parameters will be available.
All depends of the switch model, as @JDRoberts says

I think that for August I will set myself the task of making a Z-Wave parameter configurator, it seems to me that it will be necessary and it does not seem to me that it will be difficult to do.

I hope they don’t steal my idea, hahaha… :rofl:

UPDATE:
Driver published

3 Likes

Thanks for the responses.

@JDRoberts The specific device I have is the Aeotec Smart Switch 6. There is not a lot going on in the driver settings:

Clicking Select different driver says “No results found”.

If I were to remove the device and re-pair it, could I somehow force it to be a local device (as opposed to a cloud device) again?

@Mariano_Colmenarejo if you could create some kind of parameter configurator that works with z-wave cloud devices that would be great :+1:

Your device paired with the Zwave Switch driver works locally.

This cloud information that appears in IDE for devices with edge driver are no longer valid.

Click on app device settings to see the parameters configuration that your device has available.

2 Likes

As @Mariano_Colmenarejo said, all edge drivers run locally. The information in the IDE is not valid for edge drivers: they are on the new architecture and it is on the old architecture.

This is covered in the community FAQ:

FAQ: Why does the IDE list “placeholder” for my device? Can I change that?

1 Like


I need more help. So I have spent alot of time and I am successful at connecting one of the switches to the master, but I am not able to connect multiples. See both screen shots.

I have committed a great amount of money to these switches but have recevied no answers from support or from the maker Eaton.