[BETA] Wink Relay - Custom SmartThings Integration

Go into the bios menu and after factory resetting, click reset to factory image

I would guess one of the app is not functioning properly or keep updating in the background. It happens to one of my Relay that I installed a weather app. Everything runs fine after uninstall that app and reboot.

Has this been updated to work with the new APP?

it works as far as I see. In the new app, the proximity doesnt show up, and the motion detector doesnt work as it is still being developed, and the temperature has the unit celcius when it actually gives the farenhiet reading, but it works.

1 Like

I just unbricked mine following these instructions. Mine was in bootloop that wouldn’t go past the wink relay loading text.

https://forum.xda-developers.com/showpost.php?p=78872114&postcount=52

  1. While your relay is LOOPING, cover up the Proximity Sensor and press the Top Switch Button.
  2. Doing so should bring you to Recovery Mode
  3. Wipe the Cache 3 Times
  4. Delete and Reset Device 3 Times
  5. Reboot device
  6. Your Putty screen will start printing a bunch of gibberish.
  7. Have the following copied to your clipboard : am start -n com.android.launcher/com.android.launcher2.Launcher
  8. While your Putty is updating - keep pasting what is in line 7, and keep pressing Enter on your keyboard.
  9. Hopefully, you will get lucky - and the Launch Screen will appear.

From here i used these instructions to push and install the soft buttons and apkpure

This allowed me to install Nova and once rebooted I could go straight into android and not wink.

NOTE: I don’t know if I actually needed to run that command through terminal or if I could have cleared the cache 3 times and ran delete and reset device 3 times to get the wink to finally load. It couldn’t get it to do anything until I did the the cache and reset 3 times each in the order above.

2 Likes

Thank you! I double checked and I did not have developer tools / USB debugging unlocked. After unlocking, and restarting, I still could not auto-detect the device. However, if I added the IP address manually (which still didn’t work, and the IDE log made it seem like it was having trouble downloading the XML file?) but then backed out back in to the auto-discovery page, it was able to detect the relay within a few seconds! I’m connected now, and super thankful for all of your hard work and support!

1 Like

Has anyone been able to use automations (not from the classic app) to trigger other actions based on button pushes?

I can see the ‘topButton’ and ‘bottomButton’ events in the IDE log, as well as all of my child device stuff:
device

However, the built-in automation tool of the new smartthings app only shows me these five basic options for the wink relay, and apparently you can’t make ‘routines’ in the classic app anymore:

Oddly, I get slightly different options if I try to use IFTTT, which includes relay-specific triggers:
ifttt

Sorry in advance if this is a silly basic question, but I’m new to smartthings (recently moved from Wink!)

I found Easy DPI Changer on APKPure. So far, the DPI change is persistent.

I can confirm density is 160 on older firmware (factory image contains the browser.) Setting density to 240 matches the newer firmware (no browser in factory image).

The DPI Changer apk and wm commands modify mOverrideDisplayInfo instead of mBaseDisplayInfo.

Any way to re-enable the wink app to get the update, I have 2 relay the one I allowed to update is having no issues at all but the other one the font is small, very sluggish touch response and screen is staying on no matter what setting I select.

I had the same problem until I figured out that you have to use a SmartApp called “Smart Lighting”. Add the smart app and you should be able to see the two switches. You can then control lights, outlets, etc. by going into the SmartApp and creating an automation there.

Hope this helps.

Andreas

Thanks for the suggestion. The only apps I have installed are APKPure (which I uninstalled), Firefox, Kingroot and Assistive Touch.
It works for about 1/2 a day (tuning off). Then it stays on.

I have done a factory reset twice, installing the above apps with the same result.

My other Wink Relay (which I set up the same way) works no problem.

Andreas

Set density to 240 using the wm command above or the “Easy DPI Changer” app available in apkpure. That should take care of the small font.

My older relay is also staying on.

Setting backlight to touch instead of proximity in the Wink Relay app fixed the screen staying on.

You can also try adjusting the Proximity Threshold in that same settings screen. Make sure to enable the display of the Proximity value on the main screen so you can get an idea of what values your Relay is reporting.

Thanks, I tried both setting the backlight to touch only instead of proximity in the Wink Relay app as well as adjusting the proximity threshold to 10000. Neither worked. The proximity values only shows 1000 - 2000 most of the time.
I have uninstalled this one relay for now. Will play a bit more with it on my desk when I have some time.

Thanks for all your suggestions, I will report back if I find anything.

Since you are seeing touch lag, have you tried the Motion Only setting?

A user in the Hubitat community reported something similar with his screen never turning off. It turned out his device was issuing ghost touches for some reason. He switched to Motion Only and uses an external motion sensor with a custom automation to turn the screen backlight on and off based on the external motion sensor.

1 Like

Joshua,
Thanks for the suggestion. I think I tried all combinations, I ended up uninstalling the Relay. I will set it up on my desk to play a bit more with it when I have time in the next few days. I will report back what I find.

Thanks again for your great work! I am definitely staying with SmartThings.

2 Likes

One thing I noticed. I set up two relays, one near my 2-band router and one far from it.

The relay near the router got a weak 5ghz wifi signal. I connected to it, and then I forgot that wifi on the relay. It wouldnt connect to my 2.4ghz band, so I reconnected it to the 5ghz band. That night and every night after that, it would disconnect from wifi, saying “Authentication error” but would connect when I did it manually.

The relay away from the router got only 2.4 ghz band, so I used that from the getgo. The wifi never disconnected or had any other issues.

I had to factory reset my relay near the router and set it up with 2.4 ghz. That fixed the issue.

Note: I did not delete the relay from smarttthings before factory resetting. When I fully re-setup the relay again, I could control it from my old device that I had left in smartthings. It saved me a lot of hassle of re-making tens of complex routines

In summary, when connecting to wifi, connect to 2.4 ghz to avoid wifi issues. The 5ghz band doesnt even show up unless you are a couple feet from your router, and it only comes at one bar from three feet away.

1 Like

Thanks for all your work! It is amazing how much better this is than Wink!

Just wondering, is it possible to use the zigbee chip inside the relay as a zigbee repeater?

Also, in the new smartthings app, why is it not giving any motion readings in the “motion sesnor” section? Is this still being developed or is this the relay’s problem?

Hey all!

I got a couple of these and have successfully installed the first one. One thing I’d like to do is instead of having my bottom button toggle the relay(which doesnt work on one of mine) I’d like to to toggle my connected bulbs on and off. I’ve googled a little and tried to figure it out but so far haven’t found something that works. Can anyone point me to somewhere that shows how to do that?