[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

You have to remove the batteries and unplug your hub for 20-30 minutes to rebuild the ZigBee mesh.

To make sure the bulbs don’t act as repeaters you may want to remove them while setting up the fan controller.

Not sure if this will help but worth a shot.

1 Like

I read that you can reboot through the IDE via “View Utilities->Reboot Hub”, and that will rebuild the Zigbee network. Is that not accurate?

Also, I have tried multiple times without the IKEA bulb as well.

@oldcomputerwiz is right. The hub has to remain unpowered for several minutes for zigbee devices to realize they’ve lost contact and go into mesh healing mode. Also the mesh rebuilding can take hours after that to complete, so you may not see immediate results.

It’s obvious that the fan isn’t using the repeater to pair for some reason. I would probably reset the fan. Rebuild the mesh. Wait 24 hours and then add the fan see if it will use your repeater.

I used a peanut plug I bought from Amazon and many others have used the gen 2 Iris plug as repeaters.

Hours to complete. Wow, I didn’t realize it would take so long. Z Wave repair seems so much more responsive. I was able to repeat a signal out to my garage in a few minutes.

I’ll give it a shot, and let you and anybody else who may be facing similar issues know how it went. Thanks

1 Like

Oldcomperwiz’s remark on the repeater not working made me think about the repeater I bought. I bought a Sylvania smart plug on Amazon, because the Q&A section addressed whether it was or not. The person who answered it though was not the manufacturer or seller, so I wrote Sylvania and they confirmed that it was not a repeater.

I’ve read on many forums that devices that are hard wired or plugged in act as repeaters, but in this case it is not true. I bought a Peanut plug, rebooted the hub, and added the fan remote. Now the ST app operates the fan and light like a charm.

It kind of sucks that I had to use a repeater, because I don’t really need one in the bedroom. However, I was able to buy the Hampton Bay Zigbee device for only $20. For anyone in Minneapolis/St Paul that would like to get one, I bought mine at MN Home Outlet in Woodbury. There were two left when I got mine.


Shortly after you posted this, someone commented in another thread that they are using a Sylvania plug as a repeater…turns out there are two versions of the plug, and only one of them repeats. Thanks Sylvania.

1 Like

Glad I was able to help. I added the peanut plug too even though I didn’t need it for anything else and I had to pay $50 for controller. Great find at $20.

I’ve done a bit more digging into the speed 4 / light issues some of us including @baboss and @MarkTr and I have been experiencing. Curious to hear if others have experienced similar symptoms as well…

First, I tried taking my SmartThings hub offline by unplugging it and found I still get the click, light goes off behavior when I switch to speed 4 with the remote. I think this indicates the cause is unrelated to Zigbee control, right?

Then I tracked what was happening in the logs when using the remote only to switch speeds (see screenshot below). Not sure it’s useful to anyone, but check out how there are switch events when the light goes off with level 4, and when it comes on again with level 3, but no level event when it goes off – only when it comes back on.

Great work on this device handler. I purchased a Gardinier fan and installed it in the master bedroom and have enjoyed setting it up using your handler.

Using WebCore, I am trying to add manual override logic to my piston but have not been able to figure out how to determine when the fan has been controlled from the remote. I setup a testing piston that monitored the fan for events and changes to the fan speed via the Smartthings app on my phone trigger a programmatic change but turning the fan on from the remote does not trigger anything within WebCore. I have logic that monitors both physical and programmatic changes. In the Smartthings IDE logging, I do see events there that the switch value goes on and off.

What have I missed in being able to detect when the remote has been used to turn on or off the fan or light?


Brian Scheller

It appears, based on many posts since webcore’s inception, that very few devices actually differentiate between physical and programmatic. I doubt you are going to get this to work. Sorry…

For all those that have to reset their controller periodically because it gets “lost” by ST. I have done a little testing and for the small dataset that I have I have had the best success resetting the fan by first turning on the light with the remote. So, if your fan can’t be controlled by ST anymore, these are the steps I take and it usually works on the first try. Also since using this method I have had fewer disconnects.

  1. Turn on the light via the RF remote control.
  2. Turn the light on in the ST app.
  3. Turn power off and back on by the breaker (or reset wall switch if you’re like me and don’t wanna have to flip your breaker all the time)
  4. Try turning the light off with the ST app. If it doesn’t immediately go off. Turn it on then off again by the ST app.

Every time I’ve done it this way it has resynced the first time.


Thanks. I’ll give it a shot next time my bedroom fan gets confused after a power failure.

Thank you, Mark. That was exactly the problem. I spent hours trying to get it to work and it turns out it was a 10 second fix. Derp.

1 Like

What’s the model of the fan you have now? Does it have a light kit? How is it wired?

Does anyone know if there is a way to purchase the Hampton Bay Universal Ceiling Fan Thermostatic Remote (or even the non-thermostatic version of the remote) or the Hampton Bay Universal Ceiling Fan Wireless Wall Control without the receiver if you plan to purchase one of each (a remote and wall control) for a single fan?

Well I have done it. I installed all the handlers and ordered my first controller. I am supposed to get it Wed. Wish me luck.

1 Like

OK so i was having some issues. My fan had fallen off of the network and wouldn’t work. I got it working again by doing the remote and switch method and toggling the switch and trying to refresh the app. But now I see 2 active items and one inactive item. I added this to smart things in NOV/17. Is there new code? Should I update anything?

If you look back at the OP, there is a link to another thread that explains how to order replacement parts from the manufacturer.

That’s what we were doing before the zigbee-enabled receiver was actually in-stock at Home Depot on a regular basis.

Not sure about the thermostatic remote or wall control, but it was possible to order the non-thermostatic remote direct from them.

Even if you can confirm that you can order the parts you want, it’s not super likely you’ll save much (or any) money by going that route, though.

I’m having an issue with both of my fans. they used to work fine but they have been very hit or miss for a while now, and do not turn on low, med or high when asked to through Alexa. I can ask “alexa turn on bedroom fan high” and it will just turn on the speed last selected in my smartthings mobile app, like “low” I have read through this thread again and modified lines 363 and 370 with the // and republished but this didnt help either. I also looked in my hub and the device handlers and they appear up to date. my versions are celing fan parent 0.2.170515 fan child 0.2.175015 light child 0.2.175015a. Do i have the latest versions? why wont the speed change commands work? can someone post up either here at the end or in the frst page of this thread all in the updated info and installation instructions? It has been more than a year since i installed all of this and i dont remember all the instructions. thanks or can someone point me to the page or link to what im asking for? Also here is a pic of what versions I’m running. Also there are no child devices showing up in smart things. Just the fan and the light, no speeds and in the past it showed speeds. Thanks