[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

I left my hub where it was when I paired. After putting the fan cowl up in it’s final place - that’s when my communication was lost.

I then added the Lowe’s Iris Plugs which are zigbee and everything works great. My fans were not installed at the same time. But when I added the second one, I skipped the troubleshooting and just started with a repeater.

My advice for your zigbee mesh would be to power off all zigbee smart bulbs, unplug your hub for 20 minutes, plug the hub back in, wait two hours, test your fans to be sure they work, then power back on any smart bulbs. If you want to try to get away with not adding a repeater, try this rebuild first. If you still have issues - I would recommend adding the plug below then rebuilding the mesh.

Am having trouble getting this to work. I’ve installed the controller hardware and the fan works as expected with the handheld remote. It also paired with Smartthings first time, appearing as a “Thing” with status “Please Wait”. I renamed it “Living Room Ceiling Fan”.

I’ve installed the three device handlers from Github (subscribed rather than copy/pasted) and all three show “published”. KOF Zigbee Fan Controller is in blue, the others are in black (not sure what that means).

I edited Living Room Ceiling Fan to the custom device handler.No matter what I do, the fan status is stuck on HIGH. I noticed that at some point a second device Living Room Ceiling Fan Light was created. If I push the on-off button on my Smartthings app on my home, I can see the event state change on the web interface between “off” and “on”. My fan doesn’t have a light so the blue wire isn’t connected, so I can’t see if it works, but if I control the fan with the handheld remote the motor turns, so I guess maybe the remote’s light button also works, and when I push that I see nothing change in Smartthings.

I’m finding the parent/child devices particularly confusing. In the main device list I see:

Living Room Ceiling Fan
Living Room Ceiling Fan Light

If I click on Living Room Ceiling Fan Light, I see Parent Device - Living Room Ceiling Fan
If I click on Living Room Ceiling Fan, I see the following Child Devices:
Living Room Ceiling Fan Comfort Breeze™
Living Room Ceiling Fan High
Living Room Ceiling Fan Light
Living Room Ceiling Fan Low
Living Room Ceiling Fan Med
Living Room Ceiling Fan Med-Hi
but I do NOT see Living Room Ceiling Fan Light.

Does anyone have any ideas how to troubleshoot this further?

Thanks

It doesn’t sound like the fan is communicating consistently with the hub. Try putting a repeater (Zigbee outlet) close to the fan or in a room above. You may need to reset and re-pair with the hub in the same room as the fan.

“Living Room Ceiling Fan Light” is third in your list of child devices above (the list is alphabetical). The child devices are there to allow voice control through an Echo or Google Home. Otherwise you’d have to say “Set Living Room Ceiling Fan to 50%” or similar, this allows for more natural communication. Anyway, they’re nothing to do with your current issues - you just need to fix your Zigbee mesh.

I’m not sure if people know this but, Home Depot seems to have a bit of stock of these items now.

Thanks MarkTr for the help and pointing out my oversight. I’ll try re-pairing, but the fan is not really far from the hub already and there are 7 rock-solid Zigbee lights in the same room, though I couldn’t guarantee whether they’re acting as repeaters or not.

Assume that Zigbee bulbs are not repeating:

The range on these controllers is awful and you really need to have something right there to have a reliable connection. There are several other threads in the forum about these controllers and adding a repeater is the answer to 90% of the issues people have.

Great info. Totally missed the point that I have two Zigbee networks - Hue and Smartthings being separate.

Well, with the cowl off and the hub right nearby, props to MarkTr who hit the nail on the head. It’s working fine after deleting and re-pairing. Thank you!

1 Like

Once you have it paired and your hub is in it’s final location, unplug your hub for about 30 minutes or so and then plug it back in. This is the only way to do a z-wave network heal like function for your zigbee devices. Once they go into abandoned or lost most they’ll try to look for the hub in the most efficient way possible. if you’re getting intermittent connectivity with the hub, it may not lose it long enough to look for a better “route”.

Don’t forget to take the batteries out too :smiley:

1 Like

I’ve got 2 switches that used to control power to my fan so I tied their wires together and capped the traveler wire in each gang box, and I popped a wireless wall switch in place of one of the switches. Works great. I assume it’s possible to have multiple wireless wall switches control the same fan?

Now that I have tied the previous wall switch wires tied together and have one wireless wall switch installed, when I use the handheld remote that came w/ the fan controller and come around to #4 speed for the fan there’s a loud audible click in the controller stowed up in the fan base and the light goes off. Click to #3 speed for the fan and the light comes back on. I’m pretty sure it wasn’t doing that when I just had the handheld remote controlling the fan/light. Makes me think it has something to do with the wiring up in the canopy where the power comes in…or maybe I’m wrong and it has been doing it with the handheld remote all along and I just have a 3 speed fan…

Can someone verify 2 wall switches controlling the same fan/light will work? Don’t see why it wouldn’t.

And has anyone experienced my weird issue when selecting fan speed 4 on the handheld remote?

As long as the dip switches are set the same way, the receiver in the canopy doesn’t know how many handheld or in-wall remotes it’s being controlled by.

I was seeing similar symptoms with one of mine - I wondered if maybe the remote was sending its last known status for both the fan speed and the light, and conflicting with what ST had set in the meantime, but it may have been specifically on top speed. Now speed #4 doesn’t work, from either the remote or ST - I hear the relay in the controller click on but nothing happens at the fan. Seems like a faulty controller but I haven’t gotten around to digging into it more yet.

That’s interesting. Speed #4 still works in ST for me, for now. I was going to go digging in the wiring in the canopy but it was a miracle I fit it up in there the first time and I since everything works in ST (and worked w/ the handheld remote before I messed w/ the 2 wall switches) I doubt that’s the problem. I’ll keep a watch on this thread and report anything I find out.

1 Like

I have an odd issue I have 3 of these controllers (2 installed waiting on an 8 ft ladder for the last one) well the one furthest away keeps cloning the light. so right now I have 3 light controls and none work but when delete them the last one left works fine. What could be causing this … Now I do have 2 Zigbee repeater plugs between the fan and the Hub. Any ideas… Thanks
AND FYI my other one (Closest to the hub)does not clone itself.

Hal

Love this functionality! Got things hooked up a couple of days ago but running into trouble similar to others.

All using the handheld remote, I experience the following issues intermittently:

  • If I switch to speed 4 with the light off, I hear a click.
  • If I switch to speed 4 with the light on, I hear a click and the light turns off.
  • Then if I try to turn on the light, it flashes on, then clicks and turns off, or sometimes it clicks quickly and doesn’t flash at all. Try toggling the light enough times and it finally stays on.

I haven’t had a chance to really dive into this and try to determine results in all cases, but I’m happy to perform more tests if it would be helpful. Just lemme know. It feels to me like when I switch to certain fan/light modes with the remote, something (in the controller hardware itself or KOF Zigbee Fan Controller) notices the mode change and reacts with a follow-up (undesired) attempt to change the mode…

2 Likes

I installed the receiver, have the fan and light working, installed the custom device handlers, disconnected the ST hub for 30 minutes and then reconnected it, but I still can’t get this to pop up when I go to Add a Thing. Am I missing a step or something? Total noob here.

The receiver may have timed out of pairing mode. If it hasn’t paired yet, flip the switch/breaker off and back on and immediately look for it in ST. Are you using the Classic or new app? It probably won’t work in the new app.

2 Likes

Has anyone else had an issue with power outages (storms)? This is the only device that hasnt accepted commands via ST or Alexa. It still shows connected as a device, but it wont respond. When I send command through Alexa to turn the light off, she says “OK” and in the app recent activity for the light, it shows up, but the light doesnt change.

Short of getting into the canopy to disconnect the device and reconnect, what should I troubleshoot?

I have had this same issue twice on one of my controllers. The controller that uses a repeater to get to the hub.

The first time I was able to get the controller working by turning off the breaker a couple times.

Last week power cycling the breaker didn’t work. I found that the controller had dropped off the network. I turned the breaker off/on and then immediately had ST look for a new device. It took a little while but eventually found the fan. The only thing is I ended up with 2 child light devices. They both work and I haven’t tried deleting the new one yet.

I am using the classic app.

1 Like

Thanks, @oldcomputerwiz. Ill give that a try tonight. Its so annoying to walk across the room to turn the light on with the remote. #firstworldproblems