[BETA] Lutron Caseta Integration using Raspberry Pi (Pro or Standard Bridge) [DEPRECATED--See new Release thread instead]

Thanks i don’t think Homebridge/St uses MAC address just the IP. To be safe I will just use another windows laptop.
I will also give it a shot on the old Apple Mac laptop.
My caseta hub is non pro so I will be good. Also is the anyway to also intergrate the remotes?

The Pico’s can be integrated and will be very soon but ONLY with the pro bridge unfortunately. I have it working and am just making sure it’s stable before I release it to everyone.

1 Like

Great thanks and keep up the good work. I will work on this tomorrow and will keep you updated.

1 Like

Yay for the Picos! Will I be able to use those to control things other than Lutron switches?

Yes, they can be used like an aeon minimote to control whatever you want. You can use a button controller smartapp to tie a button to an action. It works pretty well.

2 Likes

I have updated this integration and created a new thread to continue the conversation. Please take a look. For those coming from the beta release you will have to remove everything and start over should you choose to upgrade. I know that is a huge hassle but there were a number of changes made that necessitate it. Thanks!

How did you install Twisted and Paramiko after Python 2.7?

I’m sorry, you are going to have to be more specific. Firstly what OS are you installing this on? Judging by your previous posts you have both Apple and Windows devices. If windows then see my early posts near the top of this string and let me know if you have any questions.

Sorry at work so sneaking and doing it remotely lol. I am installing on a windows7 x64 machine. got python 2.7 installed
but when I tried to do a pip install Twisted in the python cmd shell it errors out at install. I did install pywin32 also.

Great, well there are a few things to keep in mind.

  • If you installed any other versions of python (including the 32bit versions). Remove them ALL (including 2.7 64 bit) and then reinstall 2.7 64bit.
  • Then install pypiwin32…ensure it is the right version of this as well…(pypiwin32-219.win-amd64-py2.7.exe)
  • You may receive an error installing pypiwin but everything still worked for me anyway
  • pip install twisted
  • pip install paramiko

Thanks I will just remove everything and start fresh. Will do this later this evening and keep you posted. Thanks for your help.

In case you missed it, @njschwartz released the 1.0 version. Once you get python and everything set up, make sure to use those device handlers and script! [Deprecated] Lutron Caseta Connect V1.5

Yeah I saw that this morning. Will definitely do that . I have the non pro so picos is out of play for now for me.

I have started from fresh, Installed python 2.7 64bits and pypiwin32-219.win-amd64-py2.7.exe.
still get syntax error when I run "pip install twisted from python cmd…what am i doing wrong?

Post full error. Someone with python experience might be able to tell you what’s wrong.

Will do so in a few. Restoring the PC back to factory.

LOL i was running it from the shell, just realise I have to run it from the cmd prompt from the python directory

Aw well running it from C;\python27\scripts ( pip is not recognised as a command…)

You can (and should) add the python bin directory to your path. I believe there is an option to do that during the install, but you can also do it post-install - the method varies depending on Windows version. That might help you with some of the problems in the future, too!

PS, just remember this whole process is a learning experience and the next time you do something it will be easier.

I did add it to my path. and I guess you misread, its still not installing from the cmd prompt