[BETA] GE/Jasco Z-Wave Plus Dimmer Switch With Double-Tap

I tried making that change, but it didn’t result in a different behavior.

I did try changing my Core piston to use some different actions, with some success. Instead of using ‘Set Level’ as I was before, I tried using ‘Fade to’ and that seemed to mostly work, although it wouldn’t go all the way up to 100% (it stopped fading up at 75%). Setting the lights to flash also seemed to work (although again, the timing wasn’t the best).

So I’m not sure if there is something wrong with using the ‘Set Level’ in Core, or if that command is broken for these switches.

So I solved my issue - setting the level to 100 (either by using ‘Set Level’ or ‘Fade to’) doesn’t work - but setting the level to 99 does.

I found what was causing this problem, updated code on GitHub should allow setting to 100%.

What firmware(s) support double tap?

You can see the firmware versions in the fingerprint section of the code:

    // These include version because there are older firmwares that don't support double-tap or the extra association groups
    fingerprint mfr:"0063", prod:"4944", model:"3038", ver: "5.26", deviceJoinName: "GE Z-Wave Plus Wall Dimmer"
    fingerprint mfr:"0063", prod:"4944", model:"3039", ver: "5.19", deviceJoinName: "GE Z-Wave Plus 1000W Wall Dimmer"
    fingerprint mfr:"0063", prod:"4944", model:"3130", ver: "5.21", deviceJoinName: "GE Z-Wave Plus Toggle Dimmer"
    fingerprint mfr:"0063", prod:"4944", model:"3135", ver: "5.26", deviceJoinName: "Jasco Z-Wave Plus Wall Dimmer"
    fingerprint mfr:"0063", prod:"4944", model:"3136", ver: "5.21", deviceJoinName: "Jasco Z-Wave Plus 1000W Wall Dimmer"
    fingerprint mfr:"0063", prod:"4944", model:"3137", ver: "5.20", deviceJoinName: "Jasco Z-Wave Plus Toggle Dimmer"

So if we have the version with model “3038” with ver: “5.08” how do we get them to update the firmware? The new Zwave plus versions do allow for firmware updates correcT?

Of my 12 new Dimmers, 11 have the 5.08 firmware and 1 has the 5.26.

That is supposed to be one of the features of Z-Wave Plus and GE/Jasco list it as a feature of their plus devices but when I talked to Jasco I was told they were not going to release a firmware to update the switches without the double-tap feature but I was not given a reason. Maybe if enough people called and bugged them they would change that decision. Or maybe someone smarter than me can hack a newer model and get the firmware off of it and release it to those of us unfortunate enough to end up with an older model.

Well that sucks.

How does one determine the ID of the switch you want to add to the association? I know how to convert just need to know how to find the value.

EDIT: It is the “Device Network Id” field. It wasn’t working for me because my IDs were 75 and 76 and I didn’t realize they were already in HEX format.

I have to be missing something (and I’m new to CoRE), but I don’t see an option to create a piston for “button #1 is pushed”.
I select “simple” -> If -> Condition -> Capability ->
I’ve tried button (says “You can’t currently add this”)
I’ve tried Dimmer, Switch, etc., but nothing gives me the option to say “if a button is pushed”…

I’m also trying to configure double tap up sets to full brightness.

Am I missing something simple?
Any assistance is greatly appreciated!

**Edit: Figured it out. Tonight, I learned to edit devices to change their “Type” to a defined device type that I’ve added.
My Devices -> Select Device -> Edit -> Change “Type” dropdown to the installed “DeviceType”.

I’ll play with this more in the next few days… Thanks for all the work you’ve done with the GE switches!

Chris,

I’ve got some on/off and some dimmer switches installed – all the new GE z-wave plus models – using the respective handlers you’ve made via GitHub integration. The dimmer switches all send the commands from the app just fine, but they never update the status in the app. For example, if a dimmer is off and you tap to turn it on, the SmartThings app constantly says “Turning On”. If I hit the refresh tile, it will refresh as expected. The on/off switches do not have this issue. Within a split second or so, the status updates as expected.

Any ideas on why there would be a difference between the two? I’ve tried excluding the dimmers and including them again. I also ran a z-wave repair before and after that process.

3 Likes

Where do I go to find the values to put in these two fields? Association Group 2 Members and Association Group 3. I have the dth installed and I have the GE 26933 switch and the GE 14295 a z wave + toggle switch. I’m not technical. Could someone provide a screen shot with a working example. Thank you.

I have noticed this behavior with one of my dimmers as well (but others work fine). I am thinking I just need to up the delay between the on/off command and the request for status command but I have been totally buried at work for the last month and haven’t had time to even think about it. I am hoping to get to it over the long 4th of July weekend.

2 Likes

You can get them from your device list in the developer portal https://graph-na02-useast1.api.smartthings.com/device/list just login with your SmartThings account. The value you want is in the Device Network Id column.

Thank you. I have two lights, ‘Table’ (ID=16) and ‘Driveway’’ (ID= 15) and I’m using ‘table’ Device Network ID and putting this value under ‘Driveway’ Group 2 in the IDE and vice a versa. When I toggle up just once it turns both lights ON and toggling down once turns them both off. Can’t get Double Tap to work or am I doing something wrong?

Group 2 is turned on/off when the switch is turned on/off (as if both devices were connected to the one switch). For double-tap you want to use group 3.

Thanks nuttytree that worked. Doubletap doesn’t update the devices on/off status for me in smh. I have to click on the refresh button on the device in smh to see if it turned on or off.

I tried increasing this delay value up as high as 5000 (your code has it at 100) but it didn’t seem to change the behavior any for me - the app still shows “Turning on” for a long time until I press ‘Refresh’. The lines I was changing are 500 and 507.

I changed lines 500, 507, and 523 to 1000 and it does seem to be working for me now. However when I initially increased it to 500 I was observing that it would update to on but at random levels all less than it was last time it was on but a refresh would show it at full brightness. This leads me to believe that if it gets the status request as it is ramping up to full brightness it will report the level it is currently at. I have my Z-Wave Steps and Delay options all turned down as low as they can go. I plan to experiment tonight or tomorrow with increasing the Z-Wave Steps and Delay options but leaving the delay in the code as 1000 and see if the random level reported issue returns. If it does I am going to have to add logic to increase the delay based on the Z-Wave Steps and Delay settings. Hopefully I can have something ready to publish tomorrow.