[BETA] GE/Jasco Z-Wave Plus Dimmer Switch With Double-Tap

@Another1 , try deleting the Nuttytree DTH and just use the one I posted at the link above. They both have the same name abd having both installed may create a conflict. You may have to temporarily reassign the device to the stock DTH to remove the duplicate handler. Then from the IDE, select the ge/jasco dimmer and assign it again

@michicago the handler needs to be updated with the new settings. The two switches have totally different configuration parameters. I posted links above to those parameters on the zwave alliance page. [BETA] GE/Jasco Z-Wave Plus Dimmer Switch With Double-Tap

One would have to update the selections in the preferences () method, then pass those variables to the updated() method to send the zwave commands, and possibly fix/update other methods. I can try posting something as a starting point, but it will take a little time to work up.

I tried making a new handler for the newer 46203 to set the advanced config parameters. Again, I don’t have the switch to test it. THIS IS A BETA TEST. If it fails and messes up your parameters, be prepared to factory reset the switch.

If anyone wants to try it the code is here https://github.com/mwav3/smartthingscode/blob/master/devicetypes/mwav3/ge-46203-dimmer-switch.src/ge-46203-dimmer-switch.groovy or import from mwav3 smartthingscode master
PR’s to fix errors are welcome. So far, this attempt is to be able to set advanced parameters. If that works, I’ll move on to trying to get double/triple tap working.
Preferences/parameters on the newer switches are this per the info on the Zwave alliance site:

Edit - oh yeah, the switch should turn on and off and set levels. That’s kind of important too.

Man, I wish I had the skills to write a DTH but I just don’t have the background to do it> I’ve figured out enough to write some pretty elaborate pistons in webcore, but DTH’s are just beyond what I can figure out by reading and making changes.

I’ll install the DTH above on one of my switches tonight and will let you know how it goes. Can’t thank you enough for taking a crack at this! I’ll have to run a compare to the old DTH to see if I can figure out where you made changes based on the new configuration parameters.

It works!!! I can’t thank you enough for this, what a relief!! You’re awesome for helping me out - and a lot of other people - that would otherwise be stranded by Jasco’s ‘support’ of their own products.

Functions: (I’ll update this when I have time to check more)

On/off - working
Dimmer - working
LED Indicator - working
Use as Switch - working (SOOO nice not to hear the fluorescents hum as the switch ramps up!)
Ramp Level When Setting - working
Min Dimmer Threshold - working
Max Dimmer Threshold - working
Two notes on min and max thresholds:

  1. Dimmer will always report a range of 1-99%
    If your min is 40 and your max is 80, then your dimmer will report 1% when the bulb is illuminated at 40 and 99% when it is illuminated at 80
  2. Default brightness sets the level between your min and max levels
    For example, if your min is 40 and your max is 80, and your default brightness is 50%, your light will be set at the equivalent of 60% (halfway between 40 and 80).

Default Brightness - working - note this only works for manual switching - a Z-Wave ‘switch on’ command will still turn the light on at the previous dimmer setting
Double Tap - working
Triple Tap - Not working

1 Like

Excellent news, glad its working.

I still have to update some things for double/triple tap but I wanted to make sure everything worked before moving onto other settings.

1 Like

The new 46203 switch DTH has been updated to support double and triple tap (hopefully).

This is only for the newer switch. Original DTH should continue to be used on the older switches.

Link is here or import from mwav3 smartthingscode master

To update to four buttons, you will need the switch to “refresh”. On android, pull down in the history menu, or just change a setting in preferences and change it back.

Please let me know if it is working or not.

1 Like

It’s coming. :wink:

2 Likes

Oddly enough I was just coming back to confirm the prior one was working for double tap (buttons 1 and 2). Not for triple tap though, as expected.

I’ll give this version a try later tonight and will let you know how it goes.

Not sure if this switch supports the ramp rates (there were step times and percentages on the older switches), but those are not showing up as an option if you were expecting them to.

Ok, if the new one doesn’t work I’ll just roll it back. I think most would be fine with just the two buttons.

Jasco went away from setting the ramp rates on this one and it can’t be set anymore. Now it’s just a toggle where it ramps or doesn’t, and only at the switch. It’s odd what they change and keep, and confusing there are so many versions of these that look exactly alike. I mean that’s good for matching, but bad for setup and coding, especially with their non-existent support.

The Inovelli switches allow for much more parameters to be set and are cheaper. I buy those now. The only way I would buy a Jasco was if it was in a bank with other ones to match it.

1 Like

Yeah, unfortunately neither the double-tap nor the triple-tap works on the revised one. I’m sure they buried something confusing and half-ass documented in there somewhere that’s making it difficult.

I just bout more than 30 of these things and REALLY wish I had gone with Inovelli. Jasco hasn’t been responsive on calls (their solution is “you need to call Samsung for that”) and e-mails are just flat out ignored. Feels good after spending that kind of money on their products. Hopefully others learn and Jasco reaps what they deserve.

I should clarify, too: when it worked on 0.1, it worked from the switch (I could see button 1 or 2 being pressed in webcore). However, there are no button 1, 2 or double-tap up/down tiles shown in the new Connect app. I also don’t have my hub added to group 3 for any of my switches.

Ok just rolled back the production version for the 46203 on Github. At least that one worked for double tap.

This newer switch supports double and triple tap through central scene control. That basically means the switch sends commands directly to the hub when the switch is double or triple tapped, without needing an association. I tried to capture that through code provided for a related switch from Sergei Bobyr, but unfortunately it’s not working. They might be different then the other switch. If I had the switch and could access the advanced live logs, I probably could get it working, but I won’t be able to without it. I saved a copy of that code in my Github under projects if anyone wants to take a crack at it - its under mwav3.

The old DTH from Nuttytree, that I modified to work with the new app and other switches, still supports double tap by adding the hub into association group 3, which thanks to @michicago, we know will still work with this newer switch. So if double tap still works that way, we’ll go with that for now. The hub won’t show in association group 3 in the preferences, but its added in the background of the code.

There won’t be, that will require a custom capability to be added and is unavailable to stock button capabilities. Writing custom capabilities is brand new through the CLI, which is still in Alpha release, and advanced coders writing on here for years are having trouble with it. Until all the bugs are ironed out, I’m not attempting to mess with the CLI at all.

That’s ridiculous, it would be like Epson telling you to call Dell to make a driver for THEIR printer. What a way to pass the buck.

1 Like

Hi Tim, Just to close the loop on this one my primary issue was lack of recognition that ALL DTH are not in alphabetical order I had to go to the very bottom of the list to find the custom DTH they were not mixed in with the built-in ones. Thank you.

1 Like

Yes good point, custom DTH’s will always appear at the bottom of the list and are not mixed into the stock ones.

To be fair, originally device manufacturers sent a physical device to smartthings, smartthings worked with it themselves, and created the DTH themselves. The manufacturer didn’t get involved in the code. That was how devices got the WWST Logo to put on their boxes.

Jasco was one of the first participants in this program for their GE brand devices, and all of the first three or four generations of GE switches had DTHs created by smartthings. Not Jasco. In fact back in 2015 smartthings even sold the GE switches on their own website.

That’s not how DTH development works now, in 2020: the device manufacturer is supposed to create it and maintain it. But I think it’s understandable that Jasco, never having done it that way before, isn’t yet set up to participate in that fashion now.

1 Like

Too funny, this is part of the e-mail I sent to them after I got off the phone with them: I just completed my call to the number provided below and spoke to Derek and Lisandra. In the end, I was given the guidance to contact Samsung to ask them how to set the parameters in your device for the features I am currently lacking. When I offered the analogy that’s like HP selling me a printer with no driver/software, and telling me to contact Microsoft to ask them how to make it work on Windows, I was told “it’s completely different.” Only, it’s not.

Again, though, from 2014 to 2019 it was completely different for the participants in the “works with smartthings“ program, which included Jasco. They sent a physical device to smartthings and smartthings wrote the official DTH. The device manufacturer didn’t do any code and didn’t support the code. That was how they got permission to use the WWST logo.

The process changed last year, and now it’s supposed to be the manufacturers who do the coding and supply the DTH, but Jasco hasn’t made that change and I don’t know if they are intending to.

Their devices are certified Z wave devices and so they do work at the basic level with all certified hubs. When it comes to the advanced features, in terms of the industry it has usually been the hub manufacturers who handled the code for those. That was why different features were available with different hubs.

So in this particular case, I don’t blame Jasco. If they want to provide a DTH, they can, but it is true that they never had to before.

Which might be relevant if I purchased the switches between 2014 and 2019. But I bought 32 dimmers and 24 add-ons at the end of July. And I bought them based on the features advertised by Jasco and the WWST logo on their products and website. No mention of only working as an on/off/Dimmer switch and having the LED indicator be inconsistent across switches with no way to change it.

Since you’re not out money and time for a product that is falsely advertised a year after Jasco had time to revise their approach OR advertising, it’s inconsequential who you would blame.

I definitely agree the WWST Program has always been misleading and frustrating for consumers. :rage:

All I was responding to was the printer driver analogy. Because it has been different.

In terms of a device being advertised with features that you then can’t use, though, that’s a separate issue. And I think the migration has broken a lot of features for a number of different devices and integrations in an extremely annoying way.