Beta Edge Drivers Z-Wave+ for Homeseer WD/WS100+?

I’ve got a significant investment in my house, consisting mostly of HS-WD100+, HS-WS100+, and HS-WA100+ switches (40+). I’ve been combing the forums for some time, and seem to be SOL when it comes to finding anything that would give me hope an actual Homeseer driver appearing in the new App. So has anyone found a generic Z-Wave Edge driver that they’ve gotten to work? I had previously run with Darwin’s DTH groovy code with the pleasure of the Multi-Tap functions for single, double, triple tap and hold. However, at this point I’d be happy with the dimmer and on/off functionality.

I still hold hope that ST will release a generic Z-Wave/Z-Wave+ Switch/Dimmer driver, but in the meantime I thought I’d ask if anyone has found a solution for the Homeseer 100 family of switches. I’m sorry if there’s been a post about this, but my Neanderthal search attempts have come up empty.

For the record I have tried to add the Generic Z-Wave device. Interestingly, it says it added it, but when I look to see the room I added it to, no device is found. To add insult to injury, Alexa notification appears and I can control the dimmer for my Alexa app, but not ST app, as it is not found. I also tried the GE Z-Wave, with similar results.

Lastly, not really germain to these switches, but more to the frustration of the new app, I have tried to add out of the box devices like my Ecobee 4 w/Alexa and my Ring Door Bells and Cameras. I experience the same shenanigans with the device saying it was successfully found and added (connect to the ecobee and Ring accounts) to the appropriate room. However the devices never get listed any where, but Alexa now says it discovered a new device and I can control them from Alexa App and using my voice commands.

Don’t know what to think, but it is a wild ride for sure. If you’re curious I’m using a US-V2 Hub and Android App (latest release on the Play Store) on a Samsung S21 FE mobile phone.

I haven’t seen any drivers for Homeseer switches. ST does have a generic zwave-switch driver in their beta channel though, which I expect will give you on/off/dim, but no configuration or multi-tap. Your switches should match that driver using one of the generic fingerprints. I’m not sure how easy/possible it is to get a device to pick up an edge driver using a generic fingerprint right now.

There are certainly paths to getting full functionality for these, ranging from begging Homeseer to write a driver to writing it yourself.

1 Like

Over at the Homeseer forums an admin stated that the devs are working on a driver for the WD/WS200 series. I requested an edge driver for both the WD/WS100 switches as well as the FLS100+ Motion Sensor in their respective forums. I haven’t had any response yet.

5 Likes

I looked at the DTH for the WD/WS100 and didn’t see anything tough about it. Ideally someone that has the devices would tackle the driver, but if someone who has one is willing to get CLI logging running then I can look into it in a week or two.

3 Likes