[Beta] ) Edge Driver Zigbee Temp Sensor and Thermostat Mc:

it is very strange that routines disappear alone.

If you make any change from driver to another driver that does not have the thermostat capabilities, all the routines that are made for those capabilities are deleted.

This is a problem that has been reported and I don’t know if it will be resolved or not.

Routines are also deleted if the device is uninstalled and reinstalled

1 Like

OK good to know. Now I am all set up. I added just two routines to work with thermostat functionality, now let’s see what will tomorrow bring. Thank you for your time and support. I appreciate it :+1::+1:

1 Like

Mariano, so I have the situation like on the picture below. Two other sensor are about the same, aqara telling me that it’s hotter in my living room than those two sensor shows.
I noticed that aqara obviously has very looong respond time to temperature changes. This is probably the nature of the sensor itself right?

Sometimes it doesn’t react at all for like half an hour or even 1 hour, although the temperature has changed. If I then blow some air into the sensor , it instantly reacts so its working :slight_smile:



Hi @Spektr

I have no experience with aqara temperature sensors, but I’ve seen on the forum that it reports being difficult to configure.

I use srnsires Sonoff SNZB-02 and smsrttings, aeotec(samjin) and they work and the reports are configured very well for ysar comi Thermostat.

They report changes of 0.1Β°c, every 5 minutes if there is any change.

The fact that it does not indicate the same as other sensors is normal.
correct the temperature in preferences to what you think is correct.

If you refresh the device does the temperature update? If it does you could try to use SharpTools to force an update on a frequency of your choose. You could try every 5 minutes. This will likely decrease battery life

No it’s not. It gets updated when the sensor thinks there is a change i guess.

I am waiting for my Sonoff temperature sensor as well. Maybe it will be better fit with your thermostat function, which is great by the way :slight_smile:

1 Like

Marino, would it be possible to put thermostat temperature buttons to the main panel also?

Hi @Spektr

It is not possible, the capabilities stock thermostatHeatingSetpoint and thermostatCoolingSetpoint have no actions defined for the dashboard view.
It could only be put to show the value, but then others would have to be removed from dashboard because only a maximum of 5 groups are allowed on the dashboard

1 Like

Could you pleas add this device to the fingerprints? The model RH3052 is already there, but - as always with Tuya devices - the manufacturer code is different…

Data

  • application: 49
  • endpointId: 01
  • manufacturer: TUYATEC-yg5dcbfu
  • model: RH3052
  • zigbeeNodeType: SLEEPY_END_DEVICE
    Raw Description 01 0104 0302 00 05 0000 0001 0003 0402 0405 03 0003 0402 0405

@frayer

Added to this driver version

───────────────────────────────────────────────────────── 
 Name         Zigbee Temp Sensor and Child Thermostat Mc 
 Version      2022-11-27T17:07:40.54108596
─────────────────────────────────────────────────────────
  - id: "TUYATEC-yg5dcbfu/RH3052"
    deviceLabel: Tuya RH3052
    manufacturer: TUYATEC-yg5dcbfu
    model: RH3052
    deviceProfileName: temp-humid-battery

Thanks a lot!

Mariano, what could be the cause that aqara sensor from time to time returns 0 degrees Celsius?

Sorry, I don’t know what could be causing that.
That case has not occurred to me with other brands of devices

Cold weather :smiley:

1 Like

Hi, can you please add this Aqara TRV?


Thank you.
Ondrej

Hi @sparks5737

Sorry, this driver does not support this device types