[BETA] Community SmartApp Installer

Same problem here, just installed via GitHub integration and can see the app list and search but nothing happens when I select an app. I’ve tried using the embedded browser and the mobile browser, on iOS and Android.

Hi,
I am having the exact same issue: The available apps show up with 0 views, 0 installs, and 0 ratings. Nothing happens when I click on an app.

I have the community installer files in my home location. I have enabled OAuth. I have also tried canceling everything including my GitHub authorization and staring again, It did not work. I also tried installing the community installer using the non-advanced installation method and it still did the same thing.

I live in the UK and I’m on the euwest server don’t know if this is useful information or not.

Thank you for your help with this current matter.

I’m new to this but I was able to get installed. However, like others have commented, when I tap on one of the apps to install (specifically Echo Speaks), it does nothing. Also, I noticed that on tutorial screens, when they show the phone view, each app has a total # of Views and total # of Installs and they have numbers. On my phone, each app has 0 views and 0 installs. Clearly I took a wrong turn somewhere. Can anyone help me?

Having the exact same issue :frowning:

Same issue here. Trying to install MyQ Lite.

I have the same issue, any hope this will be fixed? Thank you!

Same problem here. Updated from repo. OAuth enabled. ST Classic app. MyQ Lite. Frustrating.

Same, same, same. @tonesto7 any luck/feedback?

I guess we can always install via GitHub and manually.

Sorry, I haven’t been checking the community forums as much lately. I will try and look at this right now

2 Likes

Thank you!

@tonesto7 workaround for issue stated here:

  1. Install SmartApp manually via code or GitHub integration
  2. Now, “Community SmartApp Installer” will allow you to click the SmartApp and install updates.

Note: still no “Views”, “Installs” nor “Software Rating” being populated.

I am having the very same problem. Installed with Github and also manually with same results.

Any help would be appreciated.

My workaround did not work?

No it did not.

Not sure where your workaround link takes me.

Not sure how far into the process you are but I had never had this up and running previously.

I tried the manual install instructions for MyQ Lite and finally got everything working. If you got the Community Installer to show up in your apps list you shouldn’t have any issues manually installing the MyQ app, it is the same steps. You do not need the Community Installer for just that 1 app, it just makes it so you can 1-click install apps such as MyQ.

Wow. I’ve been away for awhile. I will look into this and try to get.some fixes out

2 Likes

I hope this is ‘new’ news to the above problem…

I tried to install the Community App Installer in the new Android App, now named ‘SmartThings’; and kept getting the message: We’re having trouble connecting. Check your network connection and try again. Gave up and tried to install it in the Classic App (now named ‘Samsung’) and it successfully installed. However, I have the same problem as those recently mentioned above.

With it now installed in the Classic App I went back to the new App and it, surprisingly, now installed; but still with the same problem.

I hope this added information helps.

UPDATE NOTICE

I just pushed out some back end fixes to the scripts. You won’t need to update anything on your end.

The issues was a silly one and I apologize :slight_smile:
Basically, the Firebase JavaScript file for the database was removed from the CDN because it was outdated.
I had to update the code to use the new Firebase format and now all is well again.

Thanks Tonesto7, really appreciate the work you’ve done! I did a manual install of the smartthings which worked.