SmartThings Community

[BETA] Community SmartApp Installer

Very excited about this but I can’t get to the final step that saves the install. What am I missing? I’ve tried in both classic and new apps. I’m not sure if the first image is anything to worry about, it flashes super fast and then the menu loads. The 2nd one is after install but there’s no back/save that seems to work

1 Like

I think I figured out the issue… I had to disconnect and reconnect my repository. Once I did that everything worked perfectly.

3 Likes

Which repository did you have to disconnect and reconnect? The one for @tonesto7? I’m getting error messages too immediately after logging into installer site.

Mine hasn’t worked since I posted here. I tagged @tonesto7 but never saw anything. I tried disconnecting and reconnecting completely and still no solve. So I just uninstalled it.

I’m not able to duplicate this issue. I will continue to see what I can find though.

I have the same issue. Creation and Oauth steps went off without issue. Began scrolling down in Classic app and had same screen as @GRClark. @tonesto7, any advice?

try sending yourself the link to the community installer from your mobile device and use it on your desktop or laptop and see if you still get the same error

When I try to install Echo Speaks with theST Community Installer smart app from the Classic SmartThings App the install progress hangs up when Analyzing Repos. I have deleated and reinstalled the ST Community Installer but I have the same problem. Any help would be much appreciated.

I get that too but it seems to still work correctly. I’ve been ignoring it.

it might be time for me to overhaul the installer with my latest javascript skills…

i’m going to publish the code as well for others to use.

That would be awesome.

I wonder if disconnecting your github account in IDE and re-Authenticating to it will resolve your issue.

The instructions for installing the Community Installer does not require a login to GetHub. Links to the code is provided.
Thanks for replying.

LOL I am certain you need a github connection in order to use the app to install other apps. A github account is not needed if you are only manually installing the code for CSI. So I can see where you would get confused. The developer @tonesto7 can confirm that detail for you.

1 Like

Yes you need to have github integration working in the IDE.
In order for the update from repo features to be activated you are required to enable the Git Integration which means you will need to have a GitHub account.

1 Like

@tonesto7, Seems like I chose the wrong browser type. When I chose Mobile Browser it worked without the error.

Thanks.

1 Like

When I try to add the repo it’s telling me I don’t have access to it?

try disconnecting your github account and reconnecting it

1 Like

That did it. Thanks!

1 Like

Hi there,
I am trying to install the Community SmartApp Installer in order to install Echo Speaks but seem to be having a problem.
I have followed all the instructions right up to the OAuth instruction but I simply can’t find the “Welcome to Community Installer” screen.
Here are a few screen shots:

Any help would greatly be appreciated.

Many thanks

Tony