SmartThings Community

[BETA] Community SmartApp Installer

I just installed the Community SmartApp Installer. It noticed i already had the Ecobee suite installed and asked to update it. When doing so though it appears it not only loaded the apps from their Github repositories, but also published. That isn’t exactly a good thing for the various child apps that were updated.

That’s part of the install manifest that’s hosted/managed by the developer to choose whether a child app is published or not

I’m curious about the update feature. I went through and checked my instance of the NST manager on the api.smarthings.com site and I’m on 5.3.8. Looking at the installer it is showing 5.3.9 is the latest version. I see no update option. Is this because I had previously installed the NST Manager before installing this installer? It shows everything seemed to be installed correctly, its just not allowing me to update.

I’m still seeing the same issue only now with the 5.4.0 update. I see “Installed” when in fact I’m still back on the 5.3.8 version.

This usually means something was installed on a different server. The installer sees what ever is installed on the ide you are logged into. It can’t show incorrect data

Sorry for being daft but I have followed the instructions on the Wiki page and get to enabling OAuth, i click “Update” and get the error message “Access to graph-eu01-euwest1.api.smartthings.com was denied”. What am i doing wrong?

@tonesto7 HELP!! Your ecobee3 “walk through” video (or link or whatever) is broken. Can you please fix it? I need it! :slight_smile:

Hey matt - Like sumguyatvt, I just got my hub and I followed those same instructions. I’ve updated everything (handled the Oauth stuff juts fine I think), but for whatever reason, in my Smartthings app (I’m using the new one, not the classic), I cannot access the marketplace. I too am looking into integrating my NEST, but when I click on the “Automations” button at the bottom of the main nav bar in the app, there is no reference to “ST-Community-Installer”. All it asks me to do is create a new automation, and when I do that, I don’t see any reference to ST-Community_Installer.

Any suggestions?

FWIW, I can see the "ST-Community-Installer in my IDE under “MySmartApps”. It says it is published, and when I head into the Oauth everything says that it is enabled.

Thanks in advance!

You need to install the Classic app and use it :slight_smile:

2 Likes

DOH! I must have misunderstood and thought it was possible to use the new app. I appreciate the extremely quick response though! thank you.

You can use both apps. But there are some apps and device handlers that do not currently work in the Samsung Connect app.


Awesome - thank you again jkp. I’ll get there eventually :).

I was able to get the Nst Manager app to install (yay!), now apparently I just need to create a Nest developer account to be able to log in.

1 Like

Everything’s up and running now (sweet!). JKP - again thanks for the help!

1 Like

You should be able to open the smart-apps under the new Mobile app once you install it using the classic app

1 Like

Hello,

So, I have the ‘Community SmartApp Installed’ installed. Using the original Smarthings app I can see it, I can run it, I can see the manifests(SmartApps) BUT…

I select one ( Echo Speaks )
I then get all the information and the option to install…

I pick install, I then seem to get stuck on ‘Analyzing Repos’… constant spinning… Below I have green checkmarks on 'Smartthings Authentication (Even though I I selected Samsung authentication) and a green check by the repo (echo speaks) Not Added…

Any ideas anyone?
Thx…

1 Like

during installation, when I enable OAuth, the keys are “auto-generated” and when I hit Save, I just go to a white screen and it did not take. Is that something that I can work around?

I’ve noticed this issue while using only Chrome browser… Try Firefox or Edge

I was on Safari and when I used IE, it worked fine. Thanks for responding.

Brian

Can anyone help with getting the walk through video working (or point me to it)? I would love to have this option for updating my Apps, but, at this point I’m pretty confused concerning the community installer. I have to delete and add code to the SA/DH.

I’m experiencing the same issue, did you find any resolution?