[BETA] Community SmartApp Installer

Hello

Im new here and really wan to get your app working. When i try and enable Oauth the below happens

Yeah that happens with chrome. Try enabling incognito mode or use Firefox or edge browser

Thank you

this worked.

1 Like

If you are asking me if I oauthed the app, yes I did. This seems to be the only smartapp I’m having this issue with.

Hi I am having issues when adding the Net Manger on my smart things. I have tried the new app and the classic but i am getting different issues.

  1. using the latest app (smartthings) - When I am trying to select to Log in to Nest it is just showing blank automatically going to accounts.google.com, just stuck with that page.
  2. Using Smartthing classic - I am getting the error below that i have migrated your account. I cant find any option to login using the google account and if i use the google account email it doesnt work.

    Any thoughts about this issue? Thank you!

Nest no longer integrates into ST. Google changed the old Nest API in August. You can find more details in the following thread…

1 Like

Mark,

Did you ever get past the “Analyzing Repos” issue you posted about. I also encounter this when attempting to install any apps. Thanks for any assistance.

Hi everyone,

I have an issue with connecting to the second ecobee account.
I have ecobee in two different locations. Each location is managed by separated Ecobee account. As Ecobee has only options to manage locations but not allows to have multiple users for the same location.

On SmartThings I am using the same account for both locations.
I was successfully install Ecobee Suite manager v 1.7.44 for one location but I attempt to install for the second location failed.

After I entered Ecobee API Authorization successfully, I am pressing “done” in the main menu and getting “Network or sever error occurred. Try again later.”

After this When I opening again smartapp I see the same window where I need to enter Ecobee APi Authorization.

I have checked the Ecobee website for an account with which I have the issue. It shows authorization for “Ecobee Suite for SmartThings”

How can I manage two locations from the same device with the same smartthings account?

Max

Hi Everyone,

Tried to install this but when i click to add the smart app it says Network or Server Error Occurred, i have OAuth enabled and it is published.

Any solution for network problem? (I´m in new Smartthing app)

Yes same issue here.

I’m having the same issue trying to install. “Network or Server error occurred. Try again later”

I also have been getting this error. Does it have anything to do with ST having switched from Classic to New App???

It does, i switched to the classic app and that fixed it

Disconnecting and reconnecting my github account in the samsung IDE environment fixed this for me.

I’m still getting this same network connection error - I’ve tried everything mentioned on this thread (except switching to the classic app - I don’t want to go back).

What else can I do to get this thing to install?

[UPDATE: Well, I did go into the Classic app and installed it without any issues. Immediately after that, I went back to the new Smartthings app and tried to install and voila! Installed without a hitch!

@Ian1210 - it did the trick. Thanks!]

This fixed the issue for me! I didn’t realize that the Community Installer required the GitHub integration. Using these instructions: http://thingsthataresmart.wiki/index.php?title=Community_Installer_(Free_Marketplace)

Thanks again!

1 Like

When trying to install this app on the new ST app, I get a message asking me to check my network connection and it kicks me back to the App Store main screen. Thoughts on how to t-shoot?

1 Like

May have to use the Classic App to get it installed:

Well…it’s a bit silly to have to install an app I don’t need on my phone just to enable this to work proper. Guess I will be installing my apps the old fashioned way.