[BETA] Advanced Button Controller (ABC)

I wish I could help with this question, but I think you would be better served in the thread dedicated to the Homeseer device. There will be lots of folks with this particular device, including @Darwin, that could assist you there. Same for below.

Understand, thanks for your help. FWIW, I just tried setting up a second WS100+ device and it worked like a charm (both the DTH and your smartapp) regardless of whether the on/off was triggered by the iOS app or a physical tap. Makes me think I have a defective device. I may go for the exchange route next.

Again, thanks for your help.

I installed the code, apps opens but when I click on New Mapping - I just get a spinning circle. I have tried force closing app and does the same (iOS). OAuth is added to the app via Repository

Fixed – needed to click DONE first, then app installed. Go back to app, then add New Mapping

I’m using this SmartApp with the Homeseer Wd100+ switch on firmware 5.17.

It works great, but I have one GE dimmer that when the scene goes on, it does not turn on that light at all, also when I press down it does not turn off this particular problem switch either. This GE switch works fine in any of my other scenes/automations. Any ideas how/where I can start trouble shooting?

Post a link to the DTH u are using for this device and I will look into it when I have some free time.

I’ve got a horrible feeling that this is something I’m doing, but when you first add a Homeseer WD100+ to ABC, is it normal for it not to get the number of buttons?

ABC Version: v0.1.170620 - should be up to date as of 10 Oct 2017
WD100+ DTH version: 1.02 - should be up to date as of 10 Oct 2017 (this commit)
WD100+ Firmware version: Appears to be 5.17

EDIT: Stranger still, I have one WD100+ that does report how many buttons it has, but another that does not.

This can happen if you add the switch to the hub before installing the custom device handler for the WD100+ or if SmartThings somehow misses a configuration update when adding the switch. If you hit the configure button for your WD100+ on the mobile UI (bottom right next to the firmware version), that should re-send the configuration updates and set the number of buttons correctly.

Seems like that worked. I did it some time before your post but remember doing so and now it’s fine. I also power cycled the switch a few times at the breaker (was installing yet another one).

Thanks for this and all the hard work from you and all the community devs who are making this possible.


Not sure if I’m in the right place…but I’m just looking for a pretty simple smartapp to control a few things with my Xiaomi button…will this smartapp Work with that?

I’m running vers 1.02 of the device handler with WD100+ dimmers and ABC smart app. It’s all new to me but I’ve programmed the virtual buttons in ABC for double tap events, but the physical HomeSeer wall switches don’t respond to a double tap.

Should the app be syncing up with the physical switch capabilities? Or does this functionality require HomeSeer software/hub?


Great smartapp - much better than stock!

Is there a way to map the same smartapp to multiple remotes? As an example, I have two minimotes in our family room with identical button mapping. It appears right now that I have to separately configure an app for each remote, and then when I want to change what a button does, change it on separate smartapps for each remote?

Thank you, Carl.

Not sure what you mean by separate smartApps…but you need to have a separate child App for every remote you configure.
As you can see in the picture below, I have a separate configuration for each remote. Unfortunately that is necessary.

You should NOT have separate smartApps for each remote. Just once instance of the ABC smartApp with multiple child Apps for each controller.


You hit the nail on the head. I have only one install of ABC, but was wondering if there was a way to apply the same child app to multiple remotes, and it sounds like there is not.

Thanks for your response - fortunately my settings are not all that complicated to re-create for each remote.


i’ve installed darwins device handler: HomeSeer HS-WD100+ and more (Simple DTH in post 27, advanced feature DTH in post 32)
which works. double tap and tripple tap register for the device in the ipad app.

i installed ABC app: [BETA] Advanced Button Controller (ABC) but when i hit “New Button Device Mapping” the app appears to lock up, the spinning wheel doesn’t go away!

I think this is a bug caused by new app, but if you hit the line above new button device mapping and create your first mapping your good…

i’m using dragon tech switches.

this is nit-picky, but app shows the dimmer switch rather then the switch icon when device is a switch, app needs a conditional statement to show the correct icon (very low priority to fix).
i do like that ABC allow me to program scenes for single press.

Not a problem. The icons for the HomeSeer devices were created by @dalec (muchas gracias Dale).

I actually planned to rewrite some of the code for efficiency and add a couple more features but decided against it because of all the upcoming changes to the API. I don’t know if all the custom smartApps like this one will remain fully functional so I don’t plan on investing any more time into my existing smartApps. We’ll have to wait and see what Samsung has planned for the future.

That being said, If you provide the icons I could easily add them to my github repo and they will automatically appear in the smartApp.

This is happening to me too.
(Darwins DH and ABC app installed; HS-WD100 hardware)

@bellevino @RottenMutt, does this lockup happen every time you click on New Button Mapping? If so, please try again while you have live logging open and let me know if you see any errors there you can share. Also what phones are you using Android or IOS?

Ok guys, I was able to replicate the problem. Luckily I have an IPad for my son that I was able to test with. I had to completely delete the ABC app and start over.

It looks like if you are setting up the App for the first time on an IOS device (android works fine) it locks up as described. I don’t believe this happened before the recent smartthings app update.

It only seems to happen the very first time you try to create a new mapping directly after installing the smartApp. After the initial lock up everything runs fine for me.

I will dig into this and hopefully it’s something simple.