SmartThings Community

Battery Operated 3 Toggle Switch for wallmount or table top use (SmartenIT ZBWS3B), Long Install FAQ

dth_remotes

(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #21

We might be able to modify the Device or SmartApp to support “double-tap” (but “held” is unlikely).

Detecting two presses within a short period of time could be linked to a special action.

But doing this detection can’t be super reliable.


(Brian Smith) #22

What I would really want is to toggle between modes with the same button. I mentioned this in another thread, but movie mode is a great example. Press once to enter movie mode. When you are done watching the movie, you press the same button again and it returns to another mode, since it knows the mode it is currently in. Could be very easily done with the SmartRules iOS app, once Bryce is able to support the individual buttons. But, that might be a ways off as there are other things that are higher on his list (and rightly so).


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #23

Cycling through Modes or Hello Home Phrases is really just an extension of the “toggle” concept, except toggle is the easy binary case.

We’ve almost entered the realm of “Scenes” again here… But, whatever.

Mapping one or more SmartApps with lists of Modes, etc. and simple sequence and/or time rules is very doable, and, frankly, I’d enjoy writing it if we clarify the specs / wish list a but more.


Calling all community members: New SmartApp Ideas
(Nick Konsta) #24

I get :

Org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: script1431538969007773079123.groovy: 1: unexpected token: * @ line 1, column 1. * 3 Button Remote Zigbee ZBWS3 ^ 1 error


#25

See Step 5) in the FAQ above. You’re probably missing the very first line. The instructions are in the FAQ where it says “Check it after you paste it in.”


(Nick Konsta) #26

It took me 10 minutes to set it up! Works perfect !! Thank you for your detailed write up ! The details helped a lot !


(John Rucker) #27

I agree @JDRoberts has been a huge asset to this blog! Keep up the great work JD


(Luis) #28

This is exactly what I have been missing with smartthings, a simple method of control without the hassles of taking out my smartphone, entering the password, opening the app, ect. So simple, press a button, things happen :smiley:

Thank You for creating the code and sharing it with the community.


(Mike) #29

Now that folks have had this for a while what kind of battery life are you seeing? Please give an estimation of your usage (x button presses per day) if possible since I’m sure everyone uses it a bit differently.


#30

We use it several times a day, and battery life seems comparable to the Mnimote. I haven’t had to change the batteries in it yet. But I don’t do any polling on it. Status polling will kill The battery life on a device like this.


#31

Amazing How-to, thank you so much for this. I managed to get my first device set up perfectly. I have a question before I start with my second one. Do I need to create a second Device Type? Is there something I will need to consider? Thank you


#32

You only need to publish the device type once, then you can assign it to multiple devices of the same type.

So in the instructions above, for your second switch just skip steps two through seven. Then in step 12 make sure you give the new switch a different network ID then you gave the first one.

Everything else will be the same. :sunglasses:


(Nick Konsta) #33

I just moved to V2 hub and I have hard time to get it communicating.
I did ad the My Device Types > thegilbertchan : 3 Button Remote (ZBWS3) device, saved, published, installed and atatched to the “Thing”. indeed, i renamed the “Thing” to thegilbertchan : 3 Button Remote and type to “thegilbertchan : 3 Button Remote (ZBWS3)”

I have a Zigbee ID and a network it… and linked with the “BNutton app”

BUT

It will not fire anything … is like SM wont get any communication from it…

What did I do wrong ?


#34

Did you reset it before you tried to pair it again?

It sounds like it may be asleep and needs to be configured. There Have been some IDE changes since the last time I did it, I’ll take a look tonight and post tomorrow if anything has changed for V two.


(Nick Konsta) #35

Yes, I did reset before pairing it again.
For some reason ST wont accept any commands coming from the switch …


(Luis) #36

Have you followed steps 14 through 16c?
I had a similar issue as I forgot to do those steps. Once I went back and did them, it works perfectly on V2


(Eric) #37

Is anybody else having trouble keeping this 3button alive? Mine stopped responding 4 days ago for the second time, and I’m not sure it’s worth the effort to re-install.

For $50 I expected better. Doesn’t understand HOLD, feels cheap and flies apart with the merest kiss of concrete. No battery indication either.

LATER - NOV13 - Well it worked last night with no reset necessary, like it didn’t go full-stupid for a month. Soooo I’m trying to get her to use it too. Theoretically it’s easier than turning off the lamp at the bulb.


(John Rucker) #38

I have had problems with mine. It now just sits on a shelf and I pull it out form time to time when I need to help someone with a problem.

I know I have more problems when its parent is not the SmartThings hub but instead some other ZigBee router on the network. I think whats going on is some routers will orphan the 3button and it doesn’t do a great job of reconnecting or the routers wont let it reconnect. My one suggestion is try using it in close proximity to the hub and see if it works any better. I have found mine works much better if its parent is the SmartThings hub.


#39

Thanks, John, that’s good to know. Mine is being used with the hub as the parent, so that could be a difference. All my zigbee devices are battery powered or ZLL bulbs except for the hub, so I don’t have that kind of routing issue.

I have heard from other people that ZHA bulbs make problematic parents. So if you have zigbee bulbs connected directly to the hub, that could be an issue for some battery-operated devices, not just this one.


(John Rucker) #40

Yea that wouldn’t surprise me. My direct connected bulbs are just routers outside in the landscaping. They are too far away from my battery devices to be parents. I have a utility from Digi that maps out my ZigBee network and diagrams what child belongs to what parent.

I suspect the problem is around the cyclic sleep peirod setting of some ZigBee routers. That setting controls how often the router expects its child to check in. The SmartThings (hub V1 anyway) seems to have a very high threshold allowing devices to take a good long time between check-ins. I think the 3 button switch just doesn’t check in with its parent that often and some routers wont put up with that and drop it. Normally that shouldn’t be a big deal end devices are supposed to just find a new parent if they get dropped. The process of “re-parenting” seems to be when the problem occurs.

The Hue’s Mac address all start with 0x00178801 and you can see in my diagram that I have 4 bulbs at the bottom of the screen they are out on a foot bridge in our back yard. I only have two end devices and one is connected directly to the coordinator and the other to a ZigBee router. Just thought I would share my network’s routing.