Bali Blinds & Smart things

I have searched, and I have read many of the other integration topics on this subject, but I’m having problems with the solutions of most of those.

Background.
I have 3 bali blinds that I had connected to Wink (and alexa) and was using successfully for the last year or so. I really didnt like the sudden Wink subscription approach, so decided to switch to smartthings.
I just received the new hub, got it hooked up and connected.

I am following the steps to connect the blinds, but its failing to find them.

Process I am following:

  1. Press & hold button on blinds until it turns orange to reset.
  2. Add device through smarthings app (using scan nearby)
  3. Press & hold button on blinds until it starts blinking green.
  4. Wait for light to turn solid green - this never happens. It just stops blinking after about 30s. Takes a bit longer for the app, but that eventually comes back just saying no device found.

2nd process I tried was selecting manually. I did find an “Automate Shades V2”, then selected Window Treatment - but when I click this I just get the following error in the app
“Internal Server Error”.

Not sure where to go from here. I recall it being a very simple set up in Wink.

Appreciate any help or advice.
James

I recently did 6 of these, and it went fairly well. Actually the ST integration was much was much easier than the manual blind adjustments and remote pairing that you need to do. As I recall, the process is to unlink groups from remotes, manually set the top/bottom/pre set points using the remote, link the blind to ST, and then re-pair the remotes as a group. At the link to ST step, I just used the “add device” for Bali roller shades (for the ones I have) and ST walks you through the process. As I recall, the biggest challenge with any of these steps is to push the awkward to reach button long enough so that it works correctly, but not too long. As I recall ,the ST pairing does not go orange. just a rapid green flash. after 3-7 seconds? On the blinds, I think orange is reset.

Thanks for the response. I do have a few follow up questions on that…

  • I have remotes for the blinds, but I’ve never used them (always used Alexa or the buttons). I dont think I ever actually set them up.
  • Are you saying there is a specific device selection in the smartthings app for bali roller shades? I do not have that in my list. Bali is not on the brands list or on the device type list.
  • What awkward to reach button are you referring to? The reset/pair button for my blinds is right at the front right on each of the blinds. Is there another button, or are my blinds just a different version?
  • Yes, the orange light is on the bali blinds and represents resetting the blind (and disconnecting from WINK etc I assume). This is supposed to be done prior to the pairing, which is the green blinking.
  • I don’t use the remotes a lot, but nice for those who don’t get into ST. Note required for ST integration, but they are used to set the blind limits.

  • Yes- there should be two options for bali. Are you in the USA? Perhaps this is different elsewhere.

  • yes, the reset/pair button. The button on my blinds is usually on the right (one one of them it is on the left, after I was told they were always on the right…), but sometimes hard to push further back or covered by the shade (on one blind , I had to physically pull it apart and rotate it, as I could not get to it- I think it was an assembly error).

  • Agreed on the status lights.

Okay, thanks for clarifying. so sounds like I’m doing it right, but for some reason my smartthings app does not have Bali as an option.
Do you have the latest version of the app? Maybe it has been dropped from it for some reason. I assume there is only one smartthings app. There are 12 blinds options within the device-window treatment section, but non are bali.
But regardless of that, doing a manual search should locate it anyway right?
Since thats not working, I’m concerned I’ve missed something here. Is there anything else needed other than the blinds themselves, the smartthings hub, and the app? Is there anything I need to do on the hub, does the hub need to be near the device when setting up? etc etc.

Thanks again, appreciate the help.
James

I did go through the process of unpairing the remotes, even though I dont think I ever paired them, but unfortunately it didnt make any difference.
Only other thing I can think of is to move the hub closer. I have the hub set up on ethernet and it’s downstairs, so will reconfigure to wifi and try that tomorrow.

Do the Bali blinds use zwave?

Yes. And I’ve tried the generic zwave device option on smarthings too. Still doesn’t find the blinds.

Look for Springs Window Fashions in the brand list.

Did you try excluding them?

That is not there either.

Okay, this may a be the answer. I thought the reset process did the “exclusion” part of it, but from reading online that is not the case. I need to manually exclude from the existing system.
The problem is, exclusion mode option on the WINK hub is a subscription service, so I can’t do it right now. Looks like there is some workaround to it, I’ll do some research and give it a go later.
Thanks.
James

You can do a general exclude from your ST hub.

The options for bali/springs home fashions, etc. should come up easily, even if you are not in the pairing mode. My hub firmware is 0034.00011 with 2.1.19-11 controller version. I installed these about 6 months ago, so older versions had this. I’d try to chase this down first and see if having this solves your problems.

You can exclude from SmartThings. Instructions at the very bottom of this support article:

Only got around to looking at this again this evening.

First point, I have the exact same firmware and controller version.
But no Bali or Springs home fashions. The first brand I have starting with B is Bardi, then Belkin and onwards. No bali.

Okay, we have it sorted.

It was the exclusion. I eventually found instructions on how to exclude the bali blinds (on zebrablinds website) and it worked instantly.

Thank you everyone for the help in getting it resolved. Looking forward to having Alexa opening my blinds in the morning :slight_smile: