"AUTOVOICE" issue Voice Control


(Jack) #1

Hello,

I have been working around with the tasker, autovoice, sharptools, and smartthings apps to get voice control working. I have successfully reached this point, but unfortunately everytime I turn of the screen on my phone, the autovoice - “Google Now Integration” (in the app) says: [Warning: AutoVoice Accesibility service not enabled]. I am forced to turn this setting on in the accessibilty area consistently again and again everytime I close the screen and then reopen it. This gets very annoying and time consuming and makes the voice control a struggle. I would really appreciate any help from anyone.


#2

Tagging @joshua_lyon


(Joshua Lyon (SharpTools.io Dashboard)) #3

What type of phone are you using? On some of the Samsung devices, I’ve found that the Samsung Optimization features have to be turned off completely or at least disable it for specific apps (eg. AutoVoice, Tasker, etc).

If it’s a Samsung device, you can find the “optimization” feature I’m referring to at:

Smart Manager → Battery → App Optimization

If it’s not a Samsung device, I would check to see if your phone has a similar sort of app optimization, battery optimization, task killer, or memory manager type of feature and disable it. Similarly, if you have any third party optimization, task killer, or memory manager features I would try temporarily disabling or uninstalling those.

Additionally, since this seems to be an issue that is specific to AutoVoice, you’ll probably get the best support directly from the AutoApps developer/community: