Automations Show Unknown Devices - February 12th 2021

Woke up this morning to find most of my devices in Automations and Scenes show as Unknown D evices.

When trying to add a device to an automation the “Control Devices” option is greyed out, also the same for adding devices to scenes

The same devices still show within all other areas of the app/IDE.

Location: United Kingdom
Firmware: 35.4 (Beta)

Screenshot_20210212-053712_SmartThings|165x500, 100%

Has anyone else ever had this, I have tried everything,

I cannot create/edit scenes or automations

@Brad_ST @jody.albritton @ady624 @nayelyz

I have posted an error report, however got a reply saying it has been forwarded on to another team.

Any help would be appreciated.

If I access SmartThings from another phone all the automations and scenes show the correct devices.

To try and correct this I have tried:

  1. Factory reset the phone
  2. Reboot the SmartThings hub
  3. Login to another Samsung Account
  4. Remove the device from my Samsung account

Once I factory reset the phone I could then edit and add scenes however this stopped again once the app updated

There is an internal ticket for that fix - and the fix is in a testing environment at this time. It looks like you have a device that uses components that are not unique - most likely a multi button remote of sorts - it defines button1 and button2 twice as components - that’s what is causing an error that is preventing the phone from getting the list - as far as why another phone works, I can only shrug harder. :smiley:

1 Like

AHH ok that makes sense I have 4 IKEA Tradfri On/Off switches and 1 IKEA Tradfri 5 button remote which all have pressed/held functions on buttons with component names like “buttons”

Will this be part of a firmware release or app update.

After fully resetting my hub to start from scratch I have lost the ability to create any local automations, strangely enough even my rules created in the RulesAPI are all reporting cloud also.

Do you have any idea on how to get local processing back (where it is currently applicable), I can confirm the device is on firmware 35.04 and I am part of the Beta.

Thanks for your help @ady624

Ok, I believe the local execution was already fixed - and no, that fix is not a firmware, nor app - it’s a cloud fix, so it will be in faster than the typical fw/app release cycle.

Thanks @ady624, yes correct that is fixed now, I had written this before your reply on the other thread…
Thanks again for your prompt action.

That’s great to hear that it’s a cloud fix (one of the big positives about cloud services)

FYI: I found myself using the Webcore for RulesAPI today which helped me greatly in getting one of my rules formatted correctly… It would be great if this could be added into the cli Rules helper which Jody has been working on.

The reason this was helpful is due to no documentation for adding a “switchLevel” in the “Then” part of the statement.
The only examples I could find were for the 'if" segment.

Anyway I have took up too much of your time already but again your help and hard work to get Rules off the ground is very much appreciated and I look forward to the future of SmartThings.

The reason there is seemingly no documentation on switchLevel is because Rules API works with the Capabilities infrastructure we already have. See Capabilities Reference — SmartThings Classic Developer Documentation for more information on what attributes and commands are available for each capability. Setting levels takes one argument for level, which is an integer, so you would set the arguments of the setLevel command to:

arguments: [
    "integer": 100

The arguments property is an array of Operand, so you’re passing a single IntegerOperand to it.

Hope this helps,