Automations on mode A only still running in both A and B modes?

Once mode is changed to B the automation should not run when it is conditioned to run only in mode A, but it still runs.

For my Sengled Element motion detecting Floodlight’s I have automations turning them off after 10, 11 and 12 mins in mode A as it does not always turn off after 10 mins alone. I also have a scene setup to turn them on permanently by changing the mode to B to stop the mode A automations turning the lights off.

But when the lights are already on and I run a scene to put permanently on and change mode to B, they are still turning off a few times.

It must be when they are triggered on by motion setting the 10, 11 or 12 mins in action that tyen changing the mode to B does not stop this automation when it should.

So I have to hit the scene to keep on 2 or 3 times in the first 13 mins, very annoying.

Any suggestions how I can better configure this or just a bug with smart things?

It can be for several reasons:

  • Check that in the automation you have activated the location mode as “precondition”. This only triggers the automation with the desired mode.
  • If you do not have the mode precondition activated, check that “When all conditions are met” is selected.
  • The function of automatically turning off after x time makes the stopwatch start when movement is detected, but it does not stop until the light goes out. Therefore, if you change the mode when the timer is running, the lights will turn off.

You can also do two automations, this would work better:

  1. To turn on the lights if the mode is A and motion is detected
  2. To turn off the lights if the mode is A and when no motion is detected for x minutes.

Update-1:
If you want to make sure that when you change from B to A mode the lights turn off, you can add to the automation or scene that changes the mode: “Lights x,y… turn off”

1 Like

The mode is checked before the automation starts, so if the turn off automation has already been triggered, then changing the mode after that moment will not change what the automation will do. It’s already in action. That includes events set with a delay.

So the mode will only be checked before the automation runs. I don’t know if that’s what you were seeing or not.

Can you post a screenshot of the automation? Some of the smartthings settings are just not intuitive as far as how they work. :thinking:

1 Like

Thanks for your reply Mariano, I believe I have set it up exactily as you have described.

JD, thanks for getting back, yes I think you have described exactily what is happening. Once the turn off timer is set in motion changing mode does not stop it executing which is unfortunate.

Two screenshots added, one of one of the turn off timers in mode A (home) and the scene to change mode to.B (automations off) and turn everything on.

I wonder what workaround I could do as this is just not working well at all, was thinking of dumping my investment in Smartthings & Sengled and changing to hue floodlights to get this working.


@Stavros99
Both are the same capture

I’m not that familiar with the app right now because it’s not very voice-friendly, but there may be a way to cancel the delay timer after it’s started, I’m just not sure. Hopefully someone else will know.

Tagging @Automated_House

Does this type of motion sensor floodlight turn the light on automatically and you can only control on and off?
The motion sensor does not send events to do automations?