Automation Routines - additional settings with two conditions?


#1

I’m new to ST, tried searching for answers to no availability for one particular thing I’m trying to accomplish.Goal is to have my front door light turn on when someone rings my Ring Pro doorbell, only after sunset.

So I’ve chosen, under Additional Settings, “Button is pushed or held”, my Front Door bell, and added another Additional Settings called “At sunrise or sunset” => SUNSET, and chose 4 hours after sunset for the trigger to occur.

For the condition that I chose, no matter what time of the day, light gets triggered when the doorbell gets pushed. Is this normal behavior it is meant to be that only one “Additional settings” can be chosen?


#2

How are you setting up the automation? SmartLighting?


#3

By choosing, under “Turn on these lights or switches”, outdoor light. Hopefully that’s what you mean.


#4

No. Where are you selecting that?


#5

Just to make sure we’re all on the same page…

One) which smartthings hub do you have? There are a number of different ones at this point and there are some slight variations between them.

Two) which smartthings app are you using? There are several at this point, including SmartThings (Samsung connect), smartthings classic, and a couple of others.


#6

Reminds me of the series of books from the 70s. To avoid danger and to go through the evil forest, turn to page 395. To stay and fight, keep reading. :grin:


(Jimmy) #7

In addition to what JD said, have you set your location so SmartThings knows your location and time zone?


#8

I have a 2nd generation. I’m using SmartThings Classic, running the latest update. And to answer “prjct92eh2/Jimmy”, yes my home location is set, and I’m in the correct time zone.

So is it a bug, does the sunrise/sunset feature work for any of you guys? I even tried, as a test, to simply have a hue light turn on, while I manually turn on another hue light, which behaves the same way as my other doorbell related routine. No matter what time of the day, the second hue light activates every time.


#9

No other ideas? Does it not work for anyone?


#10

So, let me see if i understand correctly. You are trying to set up a routine that will turn on a light when your doorbell is pushed that turns on lights but only after sunset? And you’re doing this as a routine, not as “SmartLighting”? It doesn’t work like that. When you go into “Perform Automatically” and select multiple triggers, it will perform the routine whenever ANY of those triggers happen. Think of it as an “OR” not an “AND”. What you want to do is look at either using SmartLighting or WebCore. I would suggest WebCore since you’ll also want those lights to shut off automatically at some point too and WebCore is the easiest way to do that. Routines isn’t really built to do what you’re trying to do.


#11

Ryan, thank you so much. You are right, mine’s a routine. Just installed WebCore.