August Pro no longer responding consistently to SmartThings

Just to confirm, lock/unlock commands via the SmartThings apps works from the device page. The lock is only failing to lock/unlock when the command is from an automation. Is that right?

No, the August doesn’t respond to Z-Wave at all while idle. This includes commands sent directly from the device page and automations. When you look at the log results, it looks like SmartThings tries to send the command and just doesn’t receive a response, so it times out.

1 Like

No, that’s not right - automations and manual operation from within SmartThings both fail.

If you operate the lock from within the August app, manually by hand (twisting it on the door) or via HomeKit, it will respond to z-wave again - for a little while. But after some amount of time (for me a couple hours) it will not work from SmartThings at all - either from the app or from automations.

You’ll tap the “LOCKED” icon and it will show “UNLOCKING” but then go right back to LOCKED. Live Logging shows that the command was sent but it seems no response is received/command is ignored

1 Like

There’s one detail I saw because I wasn’t filtering by thing. I may be wrong, but there seems to be a related debug log where it says there’s an invalid token:

528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug getLockProperty: getLockStateCommand response: [lockState:LOCKED, applianceResponseTimestamp:2019-06-04T10:38:56.868Z]
528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug in getLockStateCommand
528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug in getLockProperty
528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug Property Changed event lock: locked (source: DEVICE)
528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug handleLockEvent - token is invalid - sending as PSU
528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug isCorrelationTokenValid? false (null; evt 1559659636358; tok 0; 60)
528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug Is ctData not null? false; Is ctData.token not null? false; token timestamp age: 1559659636358
528a27ed-dafa-409f-8f6a-e4ff100777ac 10:47:16 AM: debug handleLockEvent locked on Driveway Deadbolt (536c881f-3bac-4dea-85a3-7b38ec22a1cc)

Understood. It does seem like a lock firmware issue potentially. Manual operation from within ST works fine for the lock running 1.59.0-1.12.6 firmware.

EDIT: Tried a routine set to lock at a specific time and that worked as well.

1 Like

Hey Brad, just to make sure you understand – this is an inconsistent issue. If the lock is “awake”, it responds to SmartThings Z-Wave commands without issue. The problem is if the lock has been sitting idle (somewhere between 15 minutes and two hours seems to be the cut-off point), then it just completely ignores ST and only responds to the August app.

Using the August app or manually turning the lock, though, will “wake” the device and it will respond to Z-Wave, again for a short time.

You’re correct, this is most likely a problem with August not following Z-Wave spec but maybe your team can help them figure it out.

Some minor good news: support has relayed this forum thread to their engineering team. So whenever one of you reaches out to them and mention it, they should be able to track affected users.

1 Like

I’m still working through the usual boilerplate level 1 questions - have you done all the things you already told me you did, like put in new batteries, etc.

Did you get any kind of issue tracking number once the problem was escalated?

I waited 2.5 hours between using the August app or the ST app to control the lock. I was still able to unlock it on the first attempt via the ST app.

Unfortunately not. I’ll ask explicitly and see if they give it.

Also, did you update your smart lock to the latest firmware we all have, or is yours still on the older version you mentioned above?

I got the same reply just now - it’s been escalated to engineering. We will see how that goes.


Still on the older. I can’t update it remotely but can update and re-test later.


Bingo bango. It worked for all of us perfectly before the latest update as well :slight_smile:

If you do that update on the lock I bet money it craps out like we’re all seeing.

The support rep got back to me. They’re not going to give me their internal bug tracking ID, they only gave me a ticket # for my support call, which isn’t of use to anyone else.

Yeah, same. Hey, maybe we are enough of a hassle it will get fixed quickly.

It might be of use if it means that other customers can give that ticket number to August support and August support can look up the notes on your case.

1 Like

I have two cases open. One from August and the other with smartthings. No one has come back to me about the issue. Both said it is with development. I think it is a firmware update with the lock. August provided me with a new lock same issue. It was working perfectly until recently. If just open the August it will work until the application times out then the lock is unresponsive until something wakes it via BT. I have provided logs to both that confirms it.


Just checking in, has anyone else heard anything more or seen any behavioral changes? August hasn’t responded to me in a while, and things seem the same for me.

They responded to me earlier this week when I asked if I could downgrade my firmware. They basically said “they’ll look into it.”

Just adding myself to the thread. Having the same issue. Z Wave works inconsistently. I’ve been using August smart lock pro and ST for a month only. Intended to use Tasker app to lock/unlock the August via SharpTools and ST as Auto unlock is pathetic. Before I came across this thread I set up Monoprice repeater (recommended by @RBoy), that did not help.