Aspire Cooper RF9500 Device Type (basic DTH in post 6)

i added this device type using lgkahns code, but when searching for devices in smartthings, it comes up as ‘z-wave device’ not cooper rf9500. when adding this device as z-wave device, button controller doesn’t find it since it doesnt know its a button controller. any ideas?

I think that I had to change mine in the IDE over to the device type after it was added then all was happy

that worked, thanks! so how many buttons do i set up in button controller? 1/2/3/4?

dimming doesn’t seem to work (i have 9 hue white bulbs directly connected to smartthings and set up button control with this switch to turn them on/off. pressing the dimming button just turns them on off.)

also might be better if this was a momentary tile instead of a button, since sometimes the state of this button says ON when the lights are off and vice versa.

So there are actually 3 buttons on it. The main light switch button is just 1 button. Then the dimmer is 2 for up and down. So what I did to control this is I have this in my guest room and I have 2 lamps one on each side of the bed. I wanted a way that when a person would come in to have the button control the bedside lamps. So I got 2 leviton dimmer modules and stuck them in there and hooked the lamps up to those. Then I setup the button. Once all of that was done I used the DimWithMe app and configured it so that the button was the master dimmer and then the levitons were the slaves. So now when we do anything with the button the bedside lamps act accordingly. Only wish I could figure out the code to flip the buttons around since I put my switch in upside down :slight_smile:

hmm, ok, so doesn’t seem like i will be able to dim these lights then just using button controller and smartthings unless i use the dimwithme app.

i also got a phillips hue dimmer remote that works just as good and was like half the price haha.

Lol in my place I was getting rid of the wall switch but I wanted something that still looked like a switch so that was why I went with this device.

Lgkahn, I would be interested in seeing your change. Thanks!

There is a link to it in post 25 of this thread.

I’ve use the follow device type that @Lgkahn wrote (link below). I believe it is for the RF9500 switch. I have two problems.

1 - The dimmer buttons don’t seem to do anything. I can see in the logs that different messages are coming over, but the slider in the device on the iOS app doesn’t move (even after refreshing the device). It just sits at 0%.

2 - When I press the on/off button I get two events that seem to come over both on and off, see my logs below. I tried the stock app that @Lgkahn also wrote, on / off work fine but still no dimmer.

I understand that I have to pair this with an app like Dim with Me or CoRE. Either way, nothing. Does anyone have any suggestions?

Which model do you actually own?

@apwelsh

AspireRF
Cooper "RF Battery Operated Switch"
Model Number: RF9500

I believe I got it working well with @Lgkahn stock device handler. Not sure why it started working all of a sudden, but still won’t work with the advanced handler.

I have a version for the RF9542-Z that I have been working on, which is based on the SDK supplied generic RF9500 device handler. The version I am working on is designed to scale better with LED lights, where the brightness level change may be indistinguishable from prior levels. So my version increments the dimmer level in linear, or exponential rates so each level is noticeably brighter than the prior, and the user can configure how many brightness levels they want. I put it on the back burner, as I was having issues with setting the level indicator on my dimmer (the 9542 is AC powered, so it has status lights). The challenge is the lack of documentation.

I had the best luck prior to my version using the stock device handler, along with Rule Machine to tie multiple LED dimmers to track the dimmer with a single rule.

Well, I thought I had it working until I started making rules in CoRE. I think Dim with me works but I need two dimmers to work together in a 3-way configuration even though they are not wired in at all. I have on / off working fine using CoRE. Dim with me only accepts a single dimmer. Struggling to get dimming working. Actually I think I am going to try to setup two DWM configs, one for each dimmer.

About a year ago when Dim with me was pretty much the only option, people did set up multiple instances of it with different ones as the master.

Now, however, there are several other options including a version of DWM specifically intended for multiple dimmers.

If you use the “lighting” quick browse list you should be able to find all of them easily:

http://thingsthataresmart.wiki/index.php?title=How_to_Quick_Browse_the_Community-Created_SmartApps_Forum_Section

What is the other dimmer?

I gave the one that @ajma did and it seems like my lights get in a bit of a loop then some turn off or on. @ajma, is this the behavior you have?

https://github.com/ajma/twack-smarthings-apps/blob/patch-1/dim-with-me.app.groovy

I tried @ASpenCO code and the main switch worked fine, but when I tried one of the slave dimmers nothing happened.

and lastly @mrsmartypants version of the app made my lights randomly turn on / off.

@ASpenCO @mrsmartypants @ajma - You ever get this working?

If not, I’ll attempt to write my own app this weekend.

Brand and model of each of the switches?

If have the two Cooper RF9500’s and 4 LIFX bulbs. That’s it.

So that counts as 6 dimmers:
Switch A
Switch B
Bulb C
Bulb D
Bulb E
Bulb F

How exactly did you set them up with twack’s code?

Also, are they set up to follow each other with any other code, including the official smart lighting?

You can see which code controls each device in the mobile app.

One) open the mobile app

Two) go to the my house/rooms view ( Icon with four little squares on the bottom)

Three) choose things

Four) find one of the devices and click on its name in the list (just the name, not the icons on the right or left of the main) this will open its detail screen

  1. once the detail screen opens, click on smart apps at the top. This will show you the list of smart apps which are associated to this device.

You can click on any of the smart app names and see the set up screens for it.