Aspire Cooper RF9500 Device Type (basic DTH in post 6)

dth_remotes
dth_lighting

(DW) #15

Thanks. @thegibertchan can you assist?


(DW) #16

Ok, this is such a frustrating and stupid process. SmartThings, for all of it’s hype, is really not yet at a stage where it is ready for the consumer market. Instead of dealing with all of this ridiculousness, I just purchased the iOS App called SmartRules, which massively simplifies the process of writing rules to tie-together Z-wave devices. Took me 10 mins to set this up and it works fine. I also associated the RF9500 with the Device Type that is in the SmartThings DeviceType library. Done and done. For anyone who wants to be able to use the RF9500 switch, this is definitely the recommended approach. I am using it as a remote switch to control a GE In-Wall Switch. I don’t use the dimmer-functions on the RF9500 since the GE switch I have doesn’t support dimming - so it was a matter of just writing 2 rules in the SmartRules app, and I am done. This whole process of screwing around with the IDE is insane. SmartThings needs to just incorporate a SmartRules type interface into their iOS app to make this whole thing easier. SmartRules was the best $7 I have spent on home-automation so far - hundreds of dollars on SmartThings stuff and finally a rules-engine that a normal person can use. Thanks SmartRules.


#17

Awesome! And, yeah. The lack of an official rules engine is painful. They said they’re working on one, but no fixed timeline.


#18

Time to resurrect an old thread. Just got an RF9500 after reading this thread. I used Gilbert’s device type and am able to get it working to turn on and off an Aeotec corded outlet. It works great until I touch the dimmer buttons. This causes the switch to “lockup” and stop responding, then it eventually loses pairing. Very strange. The switch is labeled v 1.11. I have the v2 hub and have had no other problems since I have had it, including running several custom device types and custom apps.

Is there a way to disable the dimmer buttons in the IDE so they don’t do anything? I don’t need the dimmer function, just the basic turn on/off. I know this original conversation was pre-v2, but is anyone else experiencing this with the v2 hub?


(Larry) #19

can someone tell me how they got this to work… I cannot get it to pair with the hub… exclusion is not working either… even when next to the hub


#20

Did you install Gilbert’s device type from post six of the thread we’re in now? You’ll need that to configure the device.

If that paragraph seemed a little unclear, take a look at the custom code FAQ first:


(Larry) #21

yes I am using the device type with all buttons but there is a stock 9500 device type…
I finally got it working… I had to do more than just touch the button. I also had to hit button 1 a bunch of times… It joined as a general device( didn’t find the device type). I have have 3 different smart light apps for on/off 10% 30% 60% 80% with buttons 123 pushed and held…

Does anyone know of an actual smart app that goes up and down dimming smoothly with a button held…

I am not sure what button 4 is It doesn’t seem to work.


#22

The tapping is just to keep it awake while the configure takes. You have to do that with a lot of battery operated devices.

As far as smooth dimming, to the best of my knowledge you can only get that if you’re using the device as designed by IRS manufacturer and it’s associated with a Cooper master dimmer switch rather than running its commands through the SmartThings hub. You can’t get it just using a button controller Device type in SmartThings. But I’d be delighted to be wrong, so if someone knows better just let us know.


(Larry) #23

well instructions just said hit button 2… also holding it constantly or repeatedly pushing it to keep it awake did not work… had to do a combination of button 1 and 2.


(Larry) #24

ok I had to make one change to the stock 9500 device type driver.

dim with me would not dim the lights when you slide the dimmer slider in the app.
The button stuff on the physical device worked ok but I also needed to be able to dim the group of lights and turn them on and off with the app. Smart lighting does not have a dimmer follow me type functionality as far as I could tell . So I used the dim with me smart app.
Unfort. it did not work until I added a send event for switch.setLevel (it already had one for level) in the setlevel function. If anyone needs a copy let me know… Now all the lights dim in concert with the master (the 9500 switch device)

thanks


(Nikolaus Brown) #25

I’m having trouble with this same switch and dim with me… I’ve been using the stock Cooper RF9500 driver. You mind publishing your device driver code?


(Larry) #26

it wont let me push or commit to my git hub not sure why…

here is a local copy of the code… you can compare it to stock to see the slight changes

9500 device type


(Jason Hamilton) #27

Finally got my Cooper switch in yesterday it was back ordered on Amazon. This worked great for my issue. My problem was that I wanted to control the lights in my guest room but since they’re plugged into outlets on the other side of the room and the switch was controlling an outlet this was the issue. So I got this wonderful device and the code from this page thank you @Lgkahn and @thegilbertchan for your work on the code for this. It now works great with the 2 bed side lights that are each plugged into their own leviton dimmable wall module. Push the button on this device and boom lights come on within 1 sec. I had a Leviton Zwave switch in the hole initially but with wired switches it could be up to 30 seconds before they decide to notify ST of a state change so this solved that problem for me perfectly and now I just need to find a new use for my now spare leviton switch.


#28

i added this device type using lgkahns code, but when searching for devices in smartthings, it comes up as ‘z-wave device’ not cooper rf9500. when adding this device as z-wave device, button controller doesn’t find it since it doesnt know its a button controller. any ideas?


(Jason Hamilton) #29

I think that I had to change mine in the IDE over to the device type after it was added then all was happy


#30

that worked, thanks! so how many buttons do i set up in button controller? 1/2/3/4?

dimming doesn’t seem to work (i have 9 hue white bulbs directly connected to smartthings and set up button control with this switch to turn them on/off. pressing the dimming button just turns them on off.)

also might be better if this was a momentary tile instead of a button, since sometimes the state of this button says ON when the lights are off and vice versa.


(Jason Hamilton) #31

So there are actually 3 buttons on it. The main light switch button is just 1 button. Then the dimmer is 2 for up and down. So what I did to control this is I have this in my guest room and I have 2 lamps one on each side of the bed. I wanted a way that when a person would come in to have the button control the bedside lamps. So I got 2 leviton dimmer modules and stuck them in there and hooked the lamps up to those. Then I setup the button. Once all of that was done I used the DimWithMe app and configured it so that the button was the master dimmer and then the levitons were the slaves. So now when we do anything with the button the bedside lamps act accordingly. Only wish I could figure out the code to flip the buttons around since I put my switch in upside down :slight_smile:


#32

hmm, ok, so doesn’t seem like i will be able to dim these lights then just using button controller and smartthings unless i use the dimwithme app.

i also got a phillips hue dimmer remote that works just as good and was like half the price haha.


(Jason Hamilton) #33

Lol in my place I was getting rid of the wall switch but I wanted something that still looked like a switch so that was why I went with this device.


Idea for a physical switch to control smart bulbs like LIFX or Hue
(Armand Welsh) #34

Lgkahn, I would be interested in seeing your change. Thanks!