SmartThings Community

Aspire Cooper RF9500 Device Type (basic DTH in post 6)

dth_remotes
dth_lighting

(Michael S) #7

Gilbert - Is it possible to use the Aspire RFWC5 Scene Controller as a button controller? In short, could I associate the buttons on the minimote to the buttons on the RFWC5?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

Indeed… shouldn’t the entire Cooper Aspire line be quite possibly compatible with SmartThings?

Aren’t they all Z-Wave “scene controllers”?

http://www.cooperindustries.com/content/dam/public/wiringdevices/products/documents/brochures/aspire-rf-brochure.pdf


(Nick Kiest) #9

Thanks Gilbert. Your code support is what got me to jump to SmartThings, as support for the 9500rf was so delayed from Almond+. I got it working, and got the main buttons to turn on and off my Cree Connected bulb. Using Buttons+, I got the smaller buttons to jump to preset dimming levels. Any ideas on how to actually make it act like a dimmer, i.e. the small buttons increase or decrease the dimming state?


(Ryan De Rozario) #10

managed to get the switch aded in and a single button working, not multiple though… any advice on how i can get multiple buttons working and then triggering scenes on a hue bridge?

all buttons are identifying on the debug screen when i setup the device, so im guessing its just user error somewhere along the line :stuck_out_tongue:


(DW) #11

When I copy your code into the smart-app, I get:

groovy.lang.MissingMethodException: No signature of method: script14402269616011809517032.metadata() is applicable for argument types: (script14402269616011809517032$_run_closure1) values: [script14402269616011809517032$_run_closure1@7fd44984]
Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure) @ line 16

I have been trying to figure out what I need to do to get this to work - seems I am stuck at the first step. Any help would be appreciated.


#12

That code is for a device handler (formerly called a smart device type), not a smart app. They get installed into different sections of the IDE:


(DW) #13

Got it - that makes sense, but this is still not working as expected. I now have the RF9500 device handler installed and associated with my physical switch, but super unclear how to have that actually control the master switch. The RF9500 is an aux switch that is essentially just a remote control for the master switch. Sorry for the ignorance - first time and this is incredibly confusing. Just trying to get the association piece correct.


#14

Ah…In the smartthings universe, we are not using the RF9500 as an aux to a specific master. Instead, we are just using it as a wall-mounted “button controller” which will send request to the smartthings hub. These requests could be for any device on that smartthings network, or just for a general network command like changing mode.

You won’t be able to use direct Zwave association to a Cooper master because smartthings doesn’t have the same concept of scenes. But you can use indirect command chaining so that A button press on the RF 9500 is the same thing as tapping a tile for the master in the smartthings mobile app.

I use a text to speech reader, so I can’t actually read the code that is posted in this topic. Hopefully @thegibertchan or One of the other people using this device handler can tell you what your next steps are to get actions associated with buttons.


(DW) #15

Thanks. @thegibertchan can you assist?


(DW) #16

Ok, this is such a frustrating and stupid process. SmartThings, for all of it’s hype, is really not yet at a stage where it is ready for the consumer market. Instead of dealing with all of this ridiculousness, I just purchased the iOS App called SmartRules, which massively simplifies the process of writing rules to tie-together Z-wave devices. Took me 10 mins to set this up and it works fine. I also associated the RF9500 with the Device Type that is in the SmartThings DeviceType library. Done and done. For anyone who wants to be able to use the RF9500 switch, this is definitely the recommended approach. I am using it as a remote switch to control a GE In-Wall Switch. I don’t use the dimmer-functions on the RF9500 since the GE switch I have doesn’t support dimming - so it was a matter of just writing 2 rules in the SmartRules app, and I am done. This whole process of screwing around with the IDE is insane. SmartThings needs to just incorporate a SmartRules type interface into their iOS app to make this whole thing easier. SmartRules was the best $7 I have spent on home-automation so far - hundreds of dollars on SmartThings stuff and finally a rules-engine that a normal person can use. Thanks SmartRules.


#17

Awesome! And, yeah. The lack of an official rules engine is painful. They said they’re working on one, but no fixed timeline.


#18

Time to resurrect an old thread. Just got an RF9500 after reading this thread. I used Gilbert’s device type and am able to get it working to turn on and off an Aeotec corded outlet. It works great until I touch the dimmer buttons. This causes the switch to “lockup” and stop responding, then it eventually loses pairing. Very strange. The switch is labeled v 1.11. I have the v2 hub and have had no other problems since I have had it, including running several custom device types and custom apps.

Is there a way to disable the dimmer buttons in the IDE so they don’t do anything? I don’t need the dimmer function, just the basic turn on/off. I know this original conversation was pre-v2, but is anyone else experiencing this with the v2 hub?


(Larry) #19

can someone tell me how they got this to work… I cannot get it to pair with the hub… exclusion is not working either… even when next to the hub


#20

Did you install Gilbert’s device type from post six of the thread we’re in now? You’ll need that to configure the device.

If that paragraph seemed a little unclear, take a look at the custom code FAQ first:


(Larry) #21

yes I am using the device type with all buttons but there is a stock 9500 device type…
I finally got it working… I had to do more than just touch the button. I also had to hit button 1 a bunch of times… It joined as a general device( didn’t find the device type). I have have 3 different smart light apps for on/off 10% 30% 60% 80% with buttons 123 pushed and held…

Does anyone know of an actual smart app that goes up and down dimming smoothly with a button held…

I am not sure what button 4 is It doesn’t seem to work.


#22

The tapping is just to keep it awake while the configure takes. You have to do that with a lot of battery operated devices.

As far as smooth dimming, to the best of my knowledge you can only get that if you’re using the device as designed by IRS manufacturer and it’s associated with a Cooper master dimmer switch rather than running its commands through the SmartThings hub. You can’t get it just using a button controller Device type in SmartThings. But I’d be delighted to be wrong, so if someone knows better just let us know.


(Larry) #23

well instructions just said hit button 2… also holding it constantly or repeatedly pushing it to keep it awake did not work… had to do a combination of button 1 and 2.


(Larry) #24

ok I had to make one change to the stock 9500 device type driver.

dim with me would not dim the lights when you slide the dimmer slider in the app.
The button stuff on the physical device worked ok but I also needed to be able to dim the group of lights and turn them on and off with the app. Smart lighting does not have a dimmer follow me type functionality as far as I could tell . So I used the dim with me smart app.
Unfort. it did not work until I added a send event for switch.setLevel (it already had one for level) in the setlevel function. If anyone needs a copy let me know… Now all the lights dim in concert with the master (the 9500 switch device)

thanks


(Nikolaus Brown) #25

I’m having trouble with this same switch and dim with me… I’ve been using the stock Cooper RF9500 driver. You mind publishing your device driver code?


(Larry) #26

it wont let me push or commit to my git hub not sure why…

here is a local copy of the code… you can compare it to stock to see the slight changes

9500 device type