Arrival Sensor not updating battery level

This couldn’t be related to ST Multi-Sensor battery reporting issues could it?

Well, mine isn’t with a multi-sensor. All of my multi-sensors are reporting ok. This is just with a presence sensor.

It wasn’t just multi sensors that were affected, a bunch were and I’m just wondering if it could be the same issue. In the device details (in the IDE) does it list the manufacture as Centralite or SmartThings? If so it might be the same issue.

Manufacturer is “SmartThings” with firmware version 0x00000019. Based on that other thread you referred to though they only ever show 100%. This one is showing 15%.

Yeah…I’m 99% positive its the same issue. They updated a bunch of firmware but not the device handlers. Some peoples show only 100%, its very possible yours only shows 15%.

Contact support and let them know. If I had to guess they will probably say they are aware of the problem and are working on a fix and will let you know once its done…

hah, like support is going to fix it.



I’m having the exact same issue with a 2nd gen ST presence sensor. Mine says 1%, replaced battery a couple of times, still stuck at 1%.

Same issue here Smartthings presence sensor battery replaced still reading at 1% anyone found a solution?

I gave up. Support was absolutely no help. “It will eventually update”…

To which they’ll respond “it will eventually update”… useless…

It does not eventually update at all.

Then contact them again.

FYI my 1% battery issue did eventually clear up, just took a couple of days…

I am having this same issue, mine reports 1%. I have replaced the battery twice. I assume there has been no solution. Its hard to ignore when every couple of days I get an alert about the battery level. It allways happens when I’m not at home so the first few times it freaked me out I thought there was something going on at my house, and mine never has “cleared up”. It has been a few weeks.

Here’s what I found works for me. Put the hub into inclusion (add device) before changing the battery. After inserting the new battery, press the little button on the circuit board next to the battery. The LED should light while the button is pushed. Wait a couple seconds then cancel inclusion. You wont see a new device but the battery info should update.


I’ve had to do this exact same procedure to get my SmartThings motion sensor to add back in when it dropped off randomly Nothing else worked but this did (pull battery, put into inclusion, put in battery, hit button, cancel inclusion).

These little nuances are starting to get aggravating however…

I’ve never seen any of my devices give any warning about low battery or anything other than 100% until they stop working. Replace battery and all is good, go figure…

I’ve basically stopped calling. Waste of time to reset all my stuff when its on their end or some other problem I find that they just don’t see to care about. I just ride out the nuances with the crap…

Thanks Steve, I did exactly what you said and it worked now a new battery shows 100% finally. :grinning:

Hello, old thread - but still relevant. I had issues with Fibaro flood sensors not updating battery status after battery change. Followed Steves advice (search nearby and press tmp button) - these steps updated the battery status.

Thanks Steve,