Are there one or two types of Sonoff Basic?

Sounds like it’s not flashed right.
Tell me the name of the file you are flashing onto it.
Try flashing it again maybe you’re not getting it into flash mode are you soldering the pins in our holding them in place

The file name is “Sonoff.ino.generic.bin”.

I flashing it by getting it into flash mode by hold that button with blugin USB cable.

Yeah that’s the right file.
Have you checked your connections to the switch are they soldered ok maybe you have the TX and RX connectors the wrong way.
And have you got it set to 3.3v not 5v?
Maybe you’ve fried the board with too much power.

I check TX and RX connectors it is right

I used 3.3V

There’s nothing else I can think of then lol
I suggest you look through that sonoff page that I linked above and see if anyone’s had similar

Thank you very much for helping me.

i will try again flashing sonoff …

1 Like

(What is mean “GPIO0 MUST LOW.”)
What it is mean ??
is it mean press hold that button in sonoff?

That basically means the button has to be pressed down to get it into flash mode.

Try following this.

Yes I did that to into flash mode.

I will try agian and follow your link.

Then I will back to you


Thank you very much bro @Steveuk23
I tried with one sonoff and the flashing is working fine :smiley:
After I modified the advanced set Baudrate to 115200, Flash Size to 1MByte, Flash speed to 40MHZ and SPI Mode to DOUT

Then the light of sonoff is working. That sonoff was connected with WiFi and added in ST app.

I will try to connect the flashing sonoff with light to check if it is working or not.
But I think it will work :smiley:

Success :grin:
Got there eventually it should work fine with a light of it’s switching on and off

It is work :smiley:
Thank you very much my freind @Steveuk23

1 Like

Please, Can you help me :smiley:
I have xiaomi wall switch 2 gang. I add it to my ST app.
Physically both switch (2 Gangs) are work. Bu tby ST app, only one work.
I tried to create virtual switchs to get 2 endpoint. But the created virtual switchs are not work.

adam_walker tried to help me but I don’t know what is wrong.

Please, help Me :smiley:

You’re welcome what was causing the problem then?
I don’t have one of them switches but have just had a quick read up and I’m guessing your simulated switch isn’t set up right.
Delete the one you have and install this one as I’ve just read a few posts with people saying this one works.
And once installed it needs linking to the real one I’ve not read how you do that but presume you know that.

I delete the old one (simulated switch) and I install this one. But still same, it is not work.

After I created the virtual switches, I have three Switches. One is orginal and other Two are virtual Switchs. The original is working fine But the virtual Switches are not working.

But after creating the simulated switch it will need linking somehow to the 2nd switch on the plug.
You can’t just create a simulated switch then expect it to do something.
My guess is the device has a second on/off command that you provide link the simulated switch to through WebCore or similar.
But I’m just guessing as I’ve not got the device or read any info ,
Your going to have to read all the instructions on how to fully set it up

Thank you very much for trying help me

I did the following things:

  1. I create new device handler (Aqara 2 Button Wired Wall Switch)
  2. I create Simulated Switch (DH)
  3. I Add new SmartApp (Virtual Device Sync)
  4. I pair New Device (Aqara 2 Button Wired Wall Switch) by using catchall
  5. I create Two Virtual Switches with original switch( But the Virtual Switches NOT work)

I didn,t read about link the simulated switch with webcore or similar

It must be the virtual device sync that’s linking them.
You’re probably best asking on the page for your device as I don’t know much and them

Thank you very much for helping

Have nice days :slight_smile: