App chrashes in "rooms" after adding room

So just installed my new Smartthings hub today and added some rooms and devices from Iphone. Unfortunately after adding several rooms without problems, suddenly when adding one more, my app crashed.
I Googled and found the instruction to delete app an reinstall. It worked as I am able to open the app and navigate but it crashes instantly when I click the “Rooms” again.

The crash happened when I added a room where I had typed several spaces inbetween two words. Not sure if that is relevant or not.

Anyhow I am still not able to navigate to “Rooms” without app crashing. Required to delete and reinstall app in order to open it again. Also tried on a second device (Ipad mini) with same result.

Help wanted. And I must add, not the best first impression after 2 hours of use.

Yikes - I am not aware anything specific that is causing crashers in the iOS app. Are you running any custom devices or SmartApps? If not, shoot a note to support and we will look into it right away.