App can only control devices for about 30 seconds after powering up the v2 hub

Hoping I’m missing something obvious and someone can help me.

I stopped being able to control my lights (or any device) from my phone a few days ago. I unplugged (and removed batteries) from my v2 hub for about an hour. After powering it back on, I was able to control the lights with my phone (yay!) for about 30 seconds (boo!) …then it stopped working again. I can repeat this behavior.

Actions triggered by routines (e.g., turn off lights when the house goes to Night mode) don’t work (though the mode changes correctly).

Automation (e.g., lights turning on with motion) continue to work OK and the app does get updated with status correctly (e.g., lights on). The LEDs on the front of the hub are a solid green.

I’ve tried: resetting the hub, powering it off and on, reinstalling the app on my phone, using other phones/ipads.

Any advice on what to do?

Contact support yet? That would be my first step!

Thanks for the reply. Yes, on Friday. I know they are swamped though, so decided to see if anyone in the community had a similar experience or remedies.

are the lights zwave or zigbee… do you have hub next to your wifi router or something.
sounds like channel congestion

reason I ask is lights are normally zigbee and this competes with Wi-Fi… not good idea to have it next to your wifi router. that would explain why some stuff works but not the lights.

Good idea. I’ll try disconnecting my wifi, but don’t think that’s it: it was working fine for several days (and my v1 hub worked in the same spot for months), the wifi AP isn’t close to the hub (different floor), this affects zigbee and zwave devices, and lights are controlled flawlessly by the smart lighting app.

It’s just manual and routine based control of devices that doesn’t work.

I think for some reason the smart things servers aren’t communicating with the hub correctly. I’ll try moving a couple devices back to my V1 hub to see what happens.

Or hopefully, ST support will get back to me soon.

any luck???

Thanks for checking, but no luck at all. Exact same behavior as before: I can control lights from my phone for a few seconds and then it totally stops working. The bigger impact is that routines don’t correctly work either.

Support has no ideas either. I’ll start removing devices next. Maybe one of them has an issue that somehow hangs part of the hub upon start up…or maybe my new hub is just a dud.

anything in the ide logs

Is there a way to export the logs (short of a clunky copy-paste from the web page)?

I saw no errors. I did see a few messages similar to these two, but nothing else suspicious:

Two a2121006-8250-4f83-8990-cae9527c5eaa  9:39:13 AM: debug The current time of day (Thu Nov 05 14:39:13 UTC 2015), is not in the correct time window (Tue Oct 27 02:30:00 UTC 2015): doing nothing

fa176626-4482-4ff7-94b5-8a9b9f4fe85c  9:38:57 AM: trace cp desc: Light Office Desk [1F]: Not responding

Next, I’m going to move a few devices back to my old v1 hub and see what happens.

Thanks for helping me work through this.

Old hub works fine. New hub still broken. I spent about an hour with support today and they had no luck.

Exclusion mode doesn’t seem to work on the new hub either – which makes sense. What a dud!

The thought of migrating back to my old hub – especially if exclusion mode doesn’t work properly on my new hub … Ugh.

Maybe I have too many devices? Or the new hub gets too hot? Or I have one poison device that just kills something when it initializes?

Think I’m giving up for now – what a disappointment!

In case this helps someone in the future…

In the end, ST support determined that my v2 hub was “screwy” and needed to be replaced. They are sending me a new one.

Which means I have to re-migrate everything all over again…which took so long the first time, that I doubt I’ll start it any time soon. Which is a shame, because I love my ST system…but, I just don’t have the time available to devote the multiple days it required the first time.

When I do migrate, I think I’ll either go back to my v1 hub and/or just pilot a few devices on my new v2 hub for a while.