Any Concord 4 alarm panel users out there?

Im trying to figure out what is different, here is basically what happens on mine

7:40:07 PM: debug summaryData: [[icon:indicator-dot-gray, iconColor:#878787, value:Disarmed], [icon:indicator-dot-green, iconColor:#79b821, value:Everything OK, heroInfo:[heroStatus:ok, heroMessage:Everything OK]]] - [[icon:indicator-dot-gray, iconColor:#878787, value:Disarmed], [heroInfo:[heroMessage:Everything OK, heroStatus:ok], icon:indicator-dot-green, iconColor:#79b821, value:Everything OK]]

7:40:07 PM: info SHM getInitialData 0.083 (00) incidents:00, locationId:881xxxx-xxxx-xxxxx-xxxx-xxxfcac4b0a2

7:40:12 PM: debug intrusionState()

7:40:12 PM: debug acf9ba3b-xxx-xxxx-xxxx-18e10f30fd87 – alarmSystemStatus: away (3c8307xx-xxxx-xxxx-xxxx-xxx8601cb26c)

7:40:12 PM: debug HH auto execute Alarm Away Alarm Changes State

7:40:12 PM: debug HH autoExecute(), newMode: null

7:40:12 PM: debug Alarm Handler evt.value: away

7:40:12 PM: info SHM armDisarmCheck executing away

7:40:12 PM: info SHM COMPLETED ARM/AWAY CHILDREN:0 ISA:bb2fd2ec-xxxx-xxxx-xxxx-xxx1a633963, TIME:0.071

7:40:13 PM: debug Executing β€˜ArmAway’

Scott,

I don’t see this happening in my log.
7:40:12 PM: info SHM COMPLETED ARM/AWAY CHILDREN:0 ISA:bb2fd2ec-xxxx-xxxx-xxxx-xxx1a633963, TIME:0.071

When you configure SHM, I only get options to pick sensors for home and away, of which I picked Alarm Contact for home Alarm Contact and Alarm Motion for Away. There was no option to select Alarm any where. Am I missing something here.

Thanks

Hey everyone, new to smartthings here, having fun though. Let me thank first @sdozier for all the work not only on developing this but documenting it so newbs as myself can almost get it done. Here’s as far as I got, in need of assistance now:

Pi to ST communication is working perfectly, but I’m getting absolutely nothing from ST to Pi.
Tried to Arm the Alarm device, live logging shows:

7a6271b2-33f8-41e8-8082-xxxxxxxxxxxxxx 5:58:22 PM: debug POST /concord/arm/stay&apiserverurl=https%3A%2F%2Fgraph-na04-useast2.api.smartthings.com%3A443%2Fapi%2Fsmartapps%2Finstallations HTTP/1.1
Accept: /
User-Agent: Linux UPnP/1.0 SmartThings
HOST: C0A801E4:1F8C
Authorization: Basic YWRtaW46Mjxxxxxxxx
7a6271b2-33f8-41e8-8082-xxxxxxxxxxxxxx 5:58:22 PM: debug ALARM-PANEL
7a6271b2-33f8-41e8-8082-xxxxxxxxxxxxxx 5:58:22 PM: debug convertIPtoHex:8076
7a6271b2-33f8-41e8-8082-xxxxxxxxxxxxxx 5:58:22 PM: debug convertIPtoHex:192.168.1.228
7a6271b2-33f8-41e8-8082-xxxxxxxxxxxxxx 5:58:22 PM: debug Request:’/arm/stay’
7a6271b2-33f8-41e8-8082-xxxxxxxxxxxxxx 5:58:22 PM: debug Executing β€˜ArmStay’

IP is correct, as is the port. Concordsvr.log gets nothing at all though.

However, if I go to http://192.168.1.228:8076/concord/refresh on my browser, the log shows:

2019-03-14 18:13:16,669 [concordsvr.py:logger()] - INFO - Incoming web connection from (β€˜192.168.1.116’, 53857)
2019-03-14 18:13:16,679 [concordsvr.py:logger()] - INFO - Web request: GET /concord/refresh
2019-03-14 18:13:16,685 [concordsvr.py:logger()] - INFO - TX -> 401 Unauthorized (auth key:)

I’m lost here, any ideas to try?
Thanks again.

Hi scaylabs, did you end up getting this sorted out? I recently moved into a home with a concord 4 alarm installed and wanted to get it integrated with smart things as well. I’m pretty much having the same issue you described, having PI to ST communication but nothing from ST to PI. I’m not sure what else to try.

Anyone able to help me find out how to get it to function properly?

Based on the log you are getting 401 Unauthorized

2019-03-14 18:13:16,685 [concordsvr.py:logger()] - INFO - TX -> 401 Unauthorized (auth key:)

If you are on the mobile app, you click the gear icon on the Concord 4 Alarm Panel device. You must set the API password and it must match what is in concordsvr.conf. By default it should be β€˜password’

Thanks Scott, that fixed it! Everything seems to be working fine now. I was wondering how to change the name of the β€œzones”. I added the friendly names for the zones in the .py, and also was able to specify the names in the smartapp. However, when looking at the β€œrecent” tab for the alarm panel, it still just says β€œzone9 is open/closed” when that contact sensor changes state. Can you guide me on how to make it say β€œfront door” or a friendly name instead?

SOLVED
For anyone interested, I have an ADT branded Concord 4 with ADT Pulse automation module which looks identical to the Interlogix SuperBus 2000 RS-232 Automation Module, except the part numbers are different (ADT 60-783-03 w/board 59-738-03 vs Interlogix 60-783-02). I tried, but never could get it to work with the ADT Pulse module. I then bought the Interlogix 60-783-02 module and everything worked immediately, even with my ADT Concord 4 panel.

Hello all. @sdozier thank you for your work! I saw some others on the thread ran into issues on step 21 with requesting oauth code but I dont see a resolution to this issue posted. The page returns a 404 error. How am I able to get past this step to get the code to execute step 22? I tried what @Nivas said in post 167 but seeing the same result. Thanks in advance for your help.

Hi @grocco99, if you’re seeing a 404 error then something is not right with the URL you constructed. Make sure you replace in both places graph-xx.api.smartthings.com with your specific base URL from step 3.

It’s either a problem with the automation module or serial cable , can’t say which from the log. You could attach the serial cable directly to a computer to see if you get any response .

1 Like

@dwestall thank you! That was exactly it.

1 Like

Thanks Scott @sdozier for all the work in creating this. I’ve had this project on my β€œtodo” list since I built my house 12 years ago. I ran a bunch of sensor wires during construction, purchased the Concord4 system, and then got distracted by life and never installed it! I’ve got some programming background, but zero smartthings, linux or concord4 experience. The learning curve was pretty steep, but I have the system working and everything seems to be talking to each other. A couple of tidbits to help anyone else who’s trying to implement this system:

1 - Not having any experience with SmartThings, i installed the new App, not the Classic App. It’s possible to get some limited functionality with the new App, and I struggled for several hours trying to figure out why I couldn’t get it to work. Eventually I found a comment here that mentioned β€œClassic”, which led me to investigate.

2 - I ran into the same issue that @Nivas described in post #179. For me, the issue was caused by a selection I made on the Concord 4 Integration smart app. When you make the selections from within the SmartThings app, the last one on the list is β€œSet for specific mode(s)” I had checked all 3 boxes (Away, Home and Night). When I deselected all 3 of them, the Smart Home Monitor options started working and changed the alarm state.

Thanks again Scott

Thank you for your comments to the community. I haven’t really been updating the app in a few years as it β€œjust runs” and Ive never needed anything more from it. I agree that app is indeed a bit hard to setup, partially due to the requirement of having to purchase the automation module, raspberry pi, serial cable, etc…

Hey Scott @sdozier , one more question- After reading this thread;

it sounds like ST Classic is going to be decommissioned at some point. Will it be possible to update your program to work in the new app? I’d love to hear your thoughts.

Thx

1 Like

I finally got my setup working. I started with a Concord Express so I first purchased a used Concord 4 panel off eBay, which came with an ADT branded automation module but that didn’t work so I ended up buying a used Interlogix automation module as well. The good thing is I was able to use the ADT internal mounting bracket which I like. Also, the closet where my alarm is located doesn’t have a power outlet, so I’m using this step down converter to power the Pi from the panel, and this Serial-USB cable, and somehow managed to cram everything inside the cabinet.



Thanks again @sdozier, and everyone who contributed to this thread. I actually ready it all!

Wow! Very nice job. I like that you used a step down converter and managed to keep everything in the panel. Thanks for sharing.

Ill look into updating the program to use the new app, when i get a chance. I started using the new smartthings app myself, so its worthwhile, i just need to find some time to work on it.

Scott

Getting an issue here but I’m not sure what I’ve done wrong. I replaced my Superbus thinking that was the culprit but now I don’t believe it is. The cable is also brand new:

Concord 4 Automation Server v2.0
2020-01-27 18:44:05,749 [concordsvr.py:start_logger()] - INFO - Logging started [LEVEL: INFO]…
2020-01-27 18:44:05,757 [concordsvr.py:updateStateOnServer()] - INFO - Panel Information: panelState: connecting
2020-01-27 18:44:05,758 [concordsvr.py:refreshPanelState()] - INFO - Querying panel for state (Concord 4 panel device startup)
2020-01-27 18:44:05,758 [concordsvr.py:updateStateOnServer()] - INFO - Panel Information: state: exploring
2020-01-27 18:44:05,775 [concordsvr.py:logger()] - INFO - Listening for HTTP(S) connections on port: 8066
2020-01-27 18:44:06,262 [concordsvr.py:logger()] - INFO - TX -> https://graph-na04-useast2.api.smartthings.com/api/smartapps/installations/[censoredthenumbershere]/concord/[censoredthenumbershere]/armstatus/disarmed
2020-01-27 18:44:06,264 [concordsvr.py:logger()] - INFO - ST TX Failed: 403 url:armstatus/disarmed
2020-01-27 18:44:06,286 [concord.py:send_message()] - WARNING - Resending message, attempt 2: β€˜020204’
2020-01-27 18:44:07,796 [concordsvr.py:updateStateOnServer()] - INFO - Panel Information: state: active
2020-01-27 18:44:10,318 [concordsvr.py:panelMessageHandler()] - INFO - Learning new partition 1 from TOUCHPAD message
2020-01-27 18:44:10,824 [concordsvr.py:panelMessageHandler()] - INFO - Learning new partition 2 from TOUCHPAD message
2020-01-27 18:44:13,871 [concordsvr.py:panelMessageHandler()] - INFO - Learning new partition 3 from TOUCHPAD message
2020-01-27 18:44:14,395 [concordsvr.py:panelMessageHandler()] - INFO - Learning new partition 4 from TOUCHPAD message
2020-01-27 18:44:14,902 [concordsvr.py:panelMessageHandler()] - INFO - Learning new partition 5 from TOUCHPAD message
2020-01-27 18:44:15,408 [concordsvr.py:panelMessageHandler()] - INFO - Learning new partition 6 from TOUCHPAD message

and it just sorta repeats from there with 403 errors.

Update! Had to remove the old superbus from my system’s memory using the programming menu- now there is still an error but it’s very different.

2020-01-28 11:47:54,398 [concordsvr.py:logger()] - INFO - Listening for HTTP(S) connections on port: 8066
2020-01-28 11:47:54,406 [concord.py:message_loop()] - ERROR - BadEncoding(β€œInvalid message encoding: [β€˜1’, β€˜D’, β€˜2’, β€˜2’, β€˜0’, β€˜9’, β€˜0’, β€˜6’, β€˜0’, β€˜0’, β€˜0’, β€˜1’, β€˜2’, β€˜4’, β€˜2’, β€˜5’, β€˜1’, β€˜5’, β€˜2’, β€˜B’, β€˜1’, β€˜A’, β€˜1’, β€˜1’, β€˜1’, β€˜E’, β€˜2’, β€˜B’, β€˜0’, β€˜2’, β€˜0’, β€˜8’, β€˜F’, β€˜B’, β€˜0’, β€˜1’, β€˜0’, β€˜1’, β€˜0’, β€˜D’, β€˜0’, β€˜4’, β€˜0’, β€˜2’, β€˜2’, β€˜B’, β€˜\x00’, β€˜1’, β€˜1’, β€˜1’, β€˜D’, β€˜2’, β€˜B’, β€˜2’, β€˜0’, β€˜0’, β€˜6’, β€˜F’, β€˜B’, β€˜0’]”,)
2020-01-28 11:47:54,417 [concord.py:message_loop()] - ERROR - BadEncoding(β€œInvalid message encoding: [β€˜1’, β€˜D’, β€˜2’, β€˜2’, β€˜0’, β€˜9’, β€˜0’, β€˜6’, β€˜0’, β€˜0’, β€˜0’, β€˜1’, β€˜2’, β€˜4’, β€˜2’, β€˜5’, β€˜1’, β€˜5’, β€˜2’, β€˜B’, β€˜1’, β€˜A’, β€˜1’, β€˜1’, β€˜1’, β€˜E’, β€˜2’, β€˜B’, β€˜0’, β€˜2’, β€˜0’, β€˜8’, β€˜F’, β€˜B’, β€˜0’, β€˜1’, β€˜0’, β€˜1’, β€˜0’, β€˜D’, β€˜0’, β€˜4’, β€˜0’, β€˜2’, β€˜2’, β€˜B’, β€˜1’, β€˜\x00’, β€˜1’, β€˜1’, β€˜D’, β€˜2’, β€˜B’, β€˜2’, β€˜0’, β€˜0’, β€˜6’, β€˜F’, β€˜B’, β€˜0’]”,)
2020-01-28 11:47:54,423 [concord.py:message_loop()] - ERROR - BadEncoding(β€œInvalid message encoding: [β€˜1’, β€˜D’, β€˜2’, β€˜2’, β€˜0’, β€˜9’, β€˜0’, β€˜6’, β€˜0’, β€˜0’, β€˜0’, β€˜1’, β€˜2’, β€˜4’, β€˜2’, β€˜5’, β€˜1’, β€˜5’, β€˜2’, β€˜B’, β€˜1’, β€˜A’, β€˜1’, β€˜1’, β€˜1’, β€˜E’, β€˜2’, β€˜B’, β€˜0’, β€˜2’, β€˜0’, β€˜8’, β€˜F’, β€˜B’, β€˜0’, β€˜1’, β€˜0’, β€˜1’, β€˜0’, β€˜D’, β€˜0’, β€˜4’, β€˜0’, β€˜2’, β€˜2’, β€˜B’, β€˜1’, β€˜1’, β€˜\x00’, β€˜1’, β€˜D’, β€˜2’, β€˜B’, β€˜2’, β€˜0’, β€˜0’, β€˜6’, β€˜F’, β€˜B’, β€˜0’]”,)
2020-01-28 11:47:54,427 [concord.py:message_loop()] - ERROR - BadEncoding(β€œInvalid message encoding: [β€˜1’, β€˜D’, β€˜2’, β€˜2’, β€˜0’, β€˜9’, β€˜0’, β€˜6’, β€˜0’, β€˜0’, β€˜0’, β€˜1’, β€˜2’, β€˜4’, β€˜2’, β€˜5’, β€˜1’, β€˜5’, β€˜2’, β€˜B’, β€˜1’, β€˜A’, β€˜1’, β€˜1’, β€˜1’, β€˜E’, β€˜2’, β€˜B’, β€˜0’, β€˜2’, β€˜0’, β€˜8’, β€˜F’, β€˜B’, β€˜0’, β€˜1’, β€˜0’, β€˜1’, β€˜0’, β€˜D’, β€˜0’, β€˜4’, β€˜0’, β€˜2’, β€˜2’, β€˜B’, β€˜1’, β€˜1’, β€˜1’, β€˜\x00’, β€˜D’, β€˜2’, β€˜B’, β€˜2’, β€˜0’, β€˜0’, β€˜6’, β€˜F’, β€˜A’, β€˜\n’]”,)
2020-01-28 11:47:54,851 [concordsvr.py:logger()] - INFO - TX -> https://graph-na04-useast2.api.smartthings.com/api/smartapps/installations/[censorednumbers]/concord/[censorednumbers]/armstatus/disarmed
2020-01-28 11:47:54,853 [concordsvr.py:logger()] - INFO - ST TX Failed: 403 url:armstatus/disarmed
2020-01-28 11:47:54,948 [concordsvr.py:refreshPanelState()] - INFO - Querying panel for state (Reacting to EVENT_LOST message)
2020-01-28 11:47:54,949 [concordsvr.py:updateStateOnServer()] - INFO - Panel Information: state: exploring

Edit: Rebooted my system and now we’re back to just the β€œ020204” and 403 issues, hmm…