Android version issues

The Life page has been tweaked. It is now titled SmartThings Home Life and STHM and Guest Access have been relegated to the More services section lower down the page. So tough luck if you liked them at the top of the page.

The More services section replaces the Recommended for you section. The irritating default recommendations for things like Pet Care and Home Care have been promoted to the top section but at least it now appears you can delete them and your wishes will be respected.

I suspect having the tools like STHM and Guest Access relegated below the lifestyle fluff will go down like a cup of cold sick with this forum’s audience, even if it makes sense in the broader scheme of things.

And I’m seeing a GUI glitch. When I’m in the Device’s Routines page for a device with lots of Routines associated with it, and scroll down and then scroll back up, the GUI is cutting off the first Routine on the list.

The thing I find a little odd is that ‘Touch Sounds’ (or the equivalent) doesn’t enable and disable the sound, but if you are in Do Not Disturb mode ‘Touch Sounds’ will work as an exemption from muting.

Also why just have sound on the Favourites / Dashboard pages but not the Details Pages?

1 Like

With today’s update, Smart Lock Guest Access showed up in the Life tab.

It is also showing up in the previous version in that irritating ‘Recommended for you’ section.

My Samsung has just updated, so now I know that Smartthings Find also comes under More Services on the Life tab.

I use a custom DTH from groovy for my Heatmiser thermostat, the thermostat is linked to ST through a esp8266 bridge, since the update/backend changes ? the thermostat device page no longer functions properly, the temperature is correct but that is all

Ok, I checked your device and noticed two things :thinking::

  1. Some capabilities like Switch, thermostatFanMode have a null value. This causes the issue of the disconnected cloud icon.
    I already reported this issue as it started to happen in the new version of the app.
  2. I’m not sure if one of the controls missing is one that belongs to the thermostat capability properties but it is already deprecated, so I suggest you use the ones in production
1 Like

Thank you for looking

The DTH was created by someine else so i am unable to improve or correct anything, i think it is now fair to say the integration is now finished then Nayelyz

Thank you for looking though

I see, well, it is strange that there is no status for others like switch capability for example. As a workaround, you can send commands manually using the API and this might cause a state update.

1 Like

I’m also having issues, and have been for some time. Do you think its related?

Smartthings app Checking when on mobile data - Apps & Clients - SmartThings Community

Please, contact Customer Support by sending an email to
They can help you check what’s going on.

1 Like

I have tried to contact through the email address provided, and its the US support and I’m in the UK. Is there a different email account i can email. As the support so far is terrible! Through the app, you can only add minimal information.

The UK support address is and I also recommend removing the Samsung Members app if you have it installed as it prevents you sending logs from the SmartThings app.

1 Like

Did they mention they couldn’t help you due to your location? I was told this email was for general support, no matter the location. Can you share the ticket number, please?

They were very fast to respond, here is a snip from what they said

I have now emailed [](

So will see if they are able to help via Account data access. I will update this thread when i know more.

Same problem occurs with POPP Z-Wave Thermostats and POPP Zigbee Thermostats:

1 Like

The issue has been resolved, it looks to have been part of my works AV app, which enables a private DNS session. Once i removed it, it would show first time on 4G without showing it was checking.

So it looks like it was the DNS server taking longer to resolve. Hope this helps anyone with a similar issue!

OK, whose bright idea was it to add that irritating clicking sound without giving us the option of disabling it? I have chosen to disable ‘Touch interactions’ for a reason but the SmartThings app seems to do its own thing and not abide by the phone’s system settings.