Android ST App Not Displaying 'My Apps'


(Geko) #1

When tapping ‘My Apps’ in the Dashboard, the ‘My Apps’ page shows empty grid. Also, attempting to add any new app fails with error message:

java.lang.NumberFormatException:InvalidFloat: “”

The SmartApp actually shows up in the IDE and on iPhone in incomplete state (with blue triangle).

This happens on Android 4.4.4 with latest ST mobile app.


(Convinced ST will never be unbroken…) #2

Not seeing that here. Have you tried wiping cache/data, and maybe even reinstalling?


(Geko) #3

Tried logging out and clearing app data - it didn’t help. Also tried installing and re-installing the app - still see the same error.

One interesting observation though. I have set up two locations in my account. This only happens in the second location. My primary location works ok. On iPhone both locations work. Weird.


(Brian Smith) #4

I think there is some generic issue affecting the app on both platforms. I had an issue with the iOS app not showing my apps. I had to logout and log back in a few times…then walk away for a while before it showed up. I wonder if it is a backend issue since it seems to be affecting both platforms.