Android Presence Not Working


#1

So my (and my wifes) presence was working flawlessly until about a month or so ago. Since then, it will occasionally detect that we’ve left home like 30 minutes or so after we’ve left. It never detects when we return home. I found the FAQ for this and tried all the options but none of them work. Anything else I could be missing?

For reference, this was the KB I followed:


(Bob) #2

Was it caused by an update to Android 7, Nougat.
This update caused me no end of issues.


#3

Nope. Both my wife and my phone have been running Nougat for a while.


(Bob) #4

Okay. Not sure what to suggest then apart from making sure you have battery optimisation turned off.


#5

Yes, that’s turned off. It’s really strange that it worked flawlessly for a long time and nothing has changed on my end. Other than updates to the app, but I would think that if that were the issue - it would be more widespread.


(Not Dexter) #6

Had the same problem with my wife’s Galaxy S6. Rebooted her phone and it started reporting again.


(John Dell Arciprete) #7

Been having the same problem since the ST App update. I believe that was about a month ago. I have also had no issues prior with ST detecting phone presence now its very inconsistent and it seems the only way to fix it is to open up the ST App on the phone.


#8

Both phones have been rebooted multiple times.


(Stephan H.) #9

If your phones are from Samsung, there are 2 power optimization changes needed.

  1. Make sure ST is NOT on the App Power Monitor list and
  2. Make sure that you ADD the ST app to the Unmonitored app list…at the very bottom of the battery page.

This worked for my s7 and my wife’s Note 5… at least for the past week or so.


#10

Thanks, but we’re both are running pure Android (Nexus and OnePlus).


(Steve Jackson) #11

In the past, I have had to remove and re-add the phone as a presence device to get it working again. I have no experience with Nougat. This is with Apple IOS, Lollipop & Marshmallow. Fortunately, I haven’t had an issue for quite some time now. Knock on wood.

I also now use Life 360 in addition to Smartthings presence detection. This way I have a “backup” always in place too.


#12

Yeah, the remove/readd was in the FAQ. Sadly it didn’t help either.


(Steve Jackson) #13

That stinks. That is always my last resort, always works fix. I don’t know what to say other than to maybe try Life 360. They have free accounts and work well for us.


#14

I do have Tasker for Android that I know I could use, but it’s driving me crazy that it worked so well for so long!


#15

Okay, so I’m posting how dumb I am in attempt to save others from doing the same thing. If, as part of your troubleshooting, you remove devices from your routines, pistons, whatever - make sure you actually add the specific devices back into those rules!

:confounded: