Android presence not working at all

I have managed to mostly mitigate this problem by signing up for the free Life360 service and installing the app on our phones (we actually already used it before we got smartthings), and installing the Life360 presence smartapp.

For each of our phones we now have two presence devices in ST. Standard Android presence labeled as Name and the 360 presence labeled as Name360 for each of us.

While still not perfect, presence is now far more accurate and current. For whatever reason, the Life360 presence seems to update location changes much more quickly.

1 Like

@beckwith when you say turn on location access, do you mean within the smartthings app or in the settings on your android phone? I am going to test this out, but not sure where to set location access. Thank you!

I bought a new phone (reformatted the old one), and now I can’t get it to register that I am home. I have been “away” for over a month!

Mine started working after getting back from vacation last week, and has worked great since. I changed nothing at all, so I really doubt the problem was my phone. I also changed no settings on my smartthings hub.

Finally got around to uninstalling and reinstalling the smartthings app. Also cleared cache and data before deleting the app, just in case.

All is working fine now, as of 1 day so far. Will keep you posted if it changes.

Mine was great until yesterday, randomly marking me away and back again, happened twice last night while i was asleep…

I got my wife and I setup with life360 presence now. Hers has been working perfectly, while mine has not been working at all. I think it has to do with the fact that I set hers up while at home and mine while away. Maybe there is some exchange needed with the hub at initial setup? I am going to try setting mine up at home tonight and see how that works. For what it’s worth, my wife and I both have location services turned on as well as GPS.

In my talks with SmartThings support regarding my issues earlier, they said there is no interaction between the hub, and the phone when using the phone for presence.

this makes me think all the issues we’re having have to do with stuff on their end.

@jdrorrer

The phone. I suggest you use your phone to navigate the next time you go to work or on an errand. This flushes out any misconfigured access and I believe it helps “tune” the WiFi node coordinates.

I’m sorry, if you have to periodically use your phone to navigate, even when you don’t need it, to fix this… than the behavior is broken…

I’ve never had a problem with Life360 detecting my presence or when I’m home or not, why is SmartThings having so many problems with so many people.

Android (and maybe iOS, but I don’t know) presence sensing for SmartThings is clearly broken.

@sc00tz

In your case, I agree, this shouldn’t make a difference. I would think using Life360 would have the same impact as navigation.

Have you tried playing with SmartThings “Geofence Exit Delay” in your account settings? It can be set from none to 5 minutes. Or have you tweaked your geofence size? Life360 has a fifteen minute “location update” value and I can’t find if you can configure its geofence size.

Of course, this would not explain the difference between phones.

I would like to also point to this Topic in the Troubleshooting Section. It seems to have solved my wife’s issues with her pressence always reporting as Home. I hope it continues to work. . . time will tell if it breaks again.

Yah, I’ve tried everything, it seems totally random as to when it decides to work, or not work…

Nah, Android is not the issue here – or at least not the native geolocation. My geofence is fairly narrow, and Android seems to have no issues knowing exactly where I am through the day. I’ve checked location history for all the problem devices and they all report correctly day after day, it’s only SmartThings itself that seems to be confused, which is strange since I have no idea where it’s getting this other location data from.

The Life360 integration with smartthings seems to be working for my wife and I so far (knock on wood, don’t want to jinx anything). I am using that to track presence rather than our phones now. I was having an issue where hers worked but mine didn’t and I think it was because I setup the life360 smartapp twice, once for my life360 account and once for hers. Since I installed the life360 smartapp just once and imported all users under that one account, it seems to be working fine.

1 Like

I have had the reported flakeyness from my Droid when it comes to using it as a presence device. Of course I made sure I was set to High Accuracy in locations settings however then I noticed Google still wasn’t spot on with where I was in relation to where Maps said I was… (I was always 1 min from home) My Home location was set to my address, well if you google my address it dose not take you to my house, it takes you to the neighbors down the road (outside of ST geofence) So I adjusted Google to the Latitude/Longitude of my driveway (after reporting the address problem to Google, to which they say they cant fix at this time) Also I noticed that Maps wasn’t using the account I use for Navigation/Mapping it was using my default, so if your using multiple Google Accounts, you will need to alter what Maps uses from in the App its self.

Even with the updated Android app and new firmware for my hub my wife’s phone never leaves our house even when she is across the city.
What else can I do other than reset the hub all the time.

The WAF factor is at rock bottom right now.

Email us at support@smartthings.com. What happens when she opens the app? Does she keep wifi on? Is her location setting on most accurate? Does she have any task killing apps installed?

This post is a little stale but instead of stating a new one…

My geofencing is working great. It’s relatively tight at about 1500 foot diameter around the house and reliably sees me when I’m coming home. My issue is once I walk into the house it sees me as away. 10 minutes or more later it sees me as home again. The biggest problem with that is it opens and closes the garage door. I’m assuming I lose GPS when I enter the house and it takes some time for the phone to recognize where I am off of wifi and the really poor cell coverage. Any thoughts on my theory or how to test that?

I have spent alot of time trying to troubleshoot this and here is what I have found so far. After doing what everyone else has suggested (clearing cache partition, removing/reinstalling battery, removing, reinstalling ST, cache clearing, etc) it appears that any app that uses Google Maps as a maps engine is having problems, at least on my Galaxy Note 3, which was updated to android 4.4.4 just before installing ST. When I run GPS apps such as Waze, Navionics, Offline Maps, and a GPS troubleshooting utility, all of those work just fine. When I use Google Maps or ST, it places my position at the nearest cell tower instead of my location. When I’m driving down the road, Google Maps seems to know which direction I am facing (the map turns as I turn), but the blue dot is still in the same place and just stays there. When I bring up ST, it shows the same thing and it appears it is using the Google Maps engine too. When I use the GPS troubleshooting app, it shows I always have a minimum of 10 satellites (sometimes as many as 18). I also notice which apps access GPS data the most often and when the last time each app accesses it. The ST app is the only one that doesn’t try to access GPS data. I also notice that pinpoint icon at the top of the display that shows when GPS is active never shows when ST is running. Accoring to ST, I haven’t been home in 4 days (which happens to be the same day I installed ST). I know my geofence is set correctly and it covers about a 1/2 mile circle around my house.

1 Like