Android Pie notification issues


(Chris) #1

I’m trying to do something that should be very simple. I have lots of push notifications set up for various things. I’ve always had ST push notifications (still using the classic app right now, not the new one) set to override Do Not Disturb mode since a lot of them are security related and I want to be woken up at night if someone opens a door or whatever.

Recently I’ve been getting woken up frequently by push notifications for Honeywell TCC connect. Tired of this, so I decided to segment my notifications, leaving non-priority notifications as ST push notifications, and changing my priority notifications over to SMS using WebCore. I added the webcore notification number as a contact and set it as starred, allowed starred contact to override DND, all is good there.

Now to prevent ST notifications from coming through while phone is in DND mode. It seems like with Pie there’s no longer app-level control over which notifications can override DND. ST has been coming through, probably because it was already set that way when I upgraded from Oreo to Pie. I could not find a way to disable this, either through DND settings, ST app settings, or within the ST app itself. ST notifications keep overriding DND mode and coming through. So I uninstalled ST completely and reinstalled. Went to the app, set up the notification sound I want. Now the problem is that I get no sound from ST notifications ever, even though I picked a notification sound in the app and DND mode is off.

All I want is normal behavior, sound and vibrate when DND mode is off, and no sound/no vibrate when DND mode is on. Anyone have any tips on this?


(Chris) #2

In-app notification settings

App settings


(James Yeo) #3

I don’t think this will be any help to you as I don’t know how to fix your stuck notification…

But I believe what happened is that Pie handed over control to individual apps… so if you check out some other apps, when you expand that Advanced dropdown in the notification settings, the option to override DND is listed there. If I’m recalling correctly from my past Pie reading, it is up to the App developers to implement that DND override, and to what extent, etc. So I’m thinking your previous setting is stuck in the bowels of ST settings, which by way of the changeover from Oreo to Pie, and ST not implementing the new control… you can’t get to … maybe ST support is able to get at that on the backend to remove the override?


(Chris) #4

I just did a factory reset and set everything up from scratch. Still no sounds from ST :man_facepalming:


(Chris) #5

Just figured out what’s going on. It’s using my phone default notification sound, which I have set to None. It’s doing this even though I specify a different notification tone in the ST app. Seems like a bug to me.