Android app freezing on all actions

{Pixel 6a}

First time app user here (had the older Smart Home app but uninstalled) and can’t begin to use the app. It freezes on all actions.

I can only navigate the menu and settings, but as soon as I click on anything like sign in / add device / create routine etc. the app freezes and I can’t do anything.

This happens with all app versions (went as far back as I could).

I’ve tried to clear cache / reinstall / reboot etc. etc. to no avail.

I’m guessing it’s a connection or permissions issue but not sure what it could be as I can’t see anything weird in the logs.

Any help?

OS version?

Latest Android 13 (Security update 5 Aug 23)

Another hint is that the back action makes the app unfreeze.
So it must mean that it isn’t able to show a popup or tile or something.

I am able to load the virtual home and play with that FWIW

Connecting through a VPN, or switching off either 4G or WiFi changes nothing

Any type of ad/malware blocking on the device or home network or through the VPN? Pihole?

Imagining it was a login issue, I tried switching default browser apps and switched away from Chrome to Firefox Focus, and it now works.

Very weird to not have seen any error in the Chrome redirect, anyways, hope this is helpful for someone else.

Thanks for the interest @jkp

1 Like

Using PIxel 5 had same issues - Firefox did not fix but using Edge as default fixed issue for now. Hope this helps anyone else!